Failed dependencies:

I'm using OpenSuse 13.2 and KDE

Before, with OpenSuse 13.1 the SpiderOak works fine.
Now, whith the 13.2 version, when I try to install SpiderOak, are
experiencing this error:

sergio@linux-qgry:~/Downloads/spideOak> rpm -i SpiderOak-5.1.10-1.x86_64.rpm
warning: SpiderOak-5.1.10-1.x86_64.rpm: Header V3 DSA/SHA1 Signature,
key ID 87271cbf: NOKEY
error: Failed dependencies:
libc.so.6()(64bit) is needed by SpiderOak-1:5.1.10-1.x86_64
libc.so.6(GLIBC_2.2.5)(64bit) is needed by
SpiderOak-1:5.1.10-1.x86_64
libc.so.6(GLIBC_2.3)(64bit) is needed by
SpiderOak-1:5.1.10-1.x86_64
libc.so.6(GLIBC_2.4)(64bit) is needed by
SpiderOak-1:5.1.10-1.x86_64
libdl.so.2()(64bit) is needed by SpiderOak-1:5.1.10-1.x86_64
libdl.so.2(GLIBC_2.2.5)(64bit) is needed by
SpiderOak-1:5.1.10-1.x86_64
libgcc_s.so.1()(64bit) is needed by SpiderOak-1:5.1.10-1.x86_64
libgcc_s.so.1(GCC_3.0)(64bit) is needed by
SpiderOak-1:5.1.10-1.x86_64
libm.so.6()(64bit) is needed by SpiderOak-1:5.1.10-1.x86_64
libm.so.6(GLIBC_2.2.5)(64bit) is needed by
SpiderOak-1:5.1.10-1.x86_64
libpthread.so.0()(64bit) is needed by SpiderOak-1:5.1.10-1.x86_64
libpthread.so.0(GLIBC_2.2.5)(64bit) is needed by
SpiderOak-1:5.1.10-1.x86_64
libpthread.so.0(GLIBC_2.3.2)(64bit) is needed by
SpiderOak-1:5.1.10-1.x86_64
librt.so.1()(64bit) is needed by SpiderOak-1:5.1.10-1.x86_64
libz.so.1()(64bit) is needed by SpiderOak-1:5.1.10-1.x86_64
sergio@linux-qgry:~/Downloads/spideOak>

  What should I do to install SpiderOak with OpenSuse?

Hm, you should have glibc installed… Your system wouldn’t even boot without it.
Do you maybe have a 32bit installation? You are trying to install the 64bit SpiderOak, so that would explain the errors.

uname -a

You could install it with the --nodeps option, this would ignore all dependencies.
I don’t know whether it will run then, though. (definitely not if you have a 32bit OS… :wink: you should download and install the 32bit version then.)

you’re right


sergio@linux-qgry:~> uname -a
Linux linux-qgry 3.16.7-7-desktop #1 SMP PREEMPT Wed Dec 17 18:00:44 UTC 2014 (762f27a) i686 i686 i386 GNU/Linux
sergio@linux-qgry:~> 

But, with SpiderOak 32 I get new error


linux-qgry:/home/sergio/Downloads/spideOak # rpm -i  SpiderOak-5.1.10-1.i386.rpm
warning: SpiderOak-5.1.10-1.i386.rpm: Header V3 DSA/SHA1 Signature, key ID 87271cbf: NOKEY

What can I do now?

That is no error.

It is a warning that the package is not signed, which is because it doesn’t come from a trusted repository. Therefor rpm cannot verify that it is unaltered and prints a warning about the fact.

If you didn’t get any other messages, it should be installed now.

Thanks wolfi323,
SpiderOak is installed now.
Please, I have one more question: uname -a seems that refers to an installed software, OK?
Can you explain how I know that my hardware is 32 OR 64-bit?

“uname” shows information about your system, in particular which kernel is running and whether it’s 32bit or 64bit.
See also “man 1 uname”.

Can you explain how I know that my hardware is 32 OR 64-bit?

Run “lscpu” e.g.

I am a bit confused
My PC is 32 or 64?


linux-qgry:/home/sergio # lscpu
Architecture:          i686
**CPU op-mode(s):        32-bit, 64-bit**
Byte Order:            Little Endian
CPU(s):                2
On-line CPU(s) list:   0,1
Thread(s) per core:    1
Core(s) per socket:    2
Socket(s):             1
NUMA node(s):          1
Vendor ID:             GenuineIntel
CPU family:            6
Model:                 55
Model name:            Intel(R) Celeron(R) CPU  J1800  @ 2.41GHz
Stepping:              3
CPU MHz:               1599.984
CPU max MHz:           3100.0000
CPU min MHz:           1600.0000
BogoMIPS:              4825.60
Virtualization:        VT-x
L1d cache:             24K
L1i cache:             32K
L2 cache:              1024K
NUMA node0 CPU(s):     0,1

Your CPU can operate in 32bit and 64bit mode (from a hardware point of view).
But as you installed a 32bit operating system, you can only run 32bit software.

Thank you for the explanation.