Fail to start OBS 2.0

I’m trying to take a look at OBS 2.0 but cannot make it work. Each time it tries to boot, the boot process hangs just after the message

gpg: Generating a default OBS instance key

(I left it for several hours, so it’s not just some lengthy operation.) I looked a bit into the scripts and found that this message is printed by the obsstoragesetup script. So I booted from Knoppix and commented the two gpg2 calls in this script, so that the machine at least completed the boot. However, when I tried to run the gpg2 --gen-key from command line, it hanged just after the message about random numbers and recommendation to press keys and move mouse.

I tried this on VirtualBox and Vmware virtual machines, and also on real hardware; versions I tried were x86_64-2.0.0-build3.5 and x86_64-2.0.0-build3.8. Versions 1.7.x worked fine.

What could be wrong here?

You are probably better off to either subscribe to the build service
mailing list, or jump on IRC to chat direct;

have a browse of the archive here;

Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel
up 1:45, 2 users, load average: 1.07, 1.06, 1.01
GPU GeForce 8600 GTS Silent - Driver Version: 173.14.25

The issue is partially solved. The problem was that generating keys actually did not hang but took very long time (I just left the machine working overnight, and today I saw that it completed initialization steps and booted). So, the question is, why it took so long, but now that the machine is working, it’s not a critical problem.

Thanks for the advice, I’ll take a look at their mailing list.

It is due to a missing hardware number generator. You will run into the same problem when creating a new top level project :confused:

I will change the appliance in version 2.0.2 to just disable signing and warn about that if no number generator is installed.