Fail to set up nvidia G04 346.35

i changed my graphical adapter from a Geforce 210 to a Geforce 730
then
i remove the nvidia G03 flavour (340.76)
then
i restart pc
then
nouveau is the used driver
then
i install nvidia G04 flavour (346.35)
then
i restart pc
then
i get a text console

i forced to install again the nvidia-uvm-gfxG04-kmp-desktop and nvidia-gfxG04-kmp-desktop
but
same result. i get a text console

also i tried with no success to start by adding nomodeset in boot statement during start up

Again?
You should know already which information is needed for help. :wink:

Please post the Xorg.0.log and a list of all installed nvidia and kernel packages.

rpm -qa | egrep "kernel|nvidia"

Btw, a GeForce 730 should have worked with the G03 driver as well. So there would have been no need to remove G03 and switch to G04.

Oh, and please try another reboot, without reinstalling the driver. In certain cases, it doesn’t work at the first reboot after (re-)installation, but should work on subsequent boots. This is a 13.1 specific problem, that won’t get fixed. But setting NO_KMS_IN_INITRD=“yes” (you have run “sudo mkinitrd” afterwards, as you should know) should prevent that (although the nvidia packages should set that automatically).

yes i set NO_KMS_IN_INITRD=“yes”

yes i reboot 2 times

yes the G03 flavour runs well with this new card

fah client fails to use gpu for computing then i want to experiment the last version of the driver.

i will install again the driver and send you the list of packets

i don’t understand “that won’t get fixed” because 13.1 is the next opensuse LTS. is it normal a LTS one keeps this kind of bug ?

Well, then use that if you cannot get G04 to work I’d say.

But just to be sure: you should never install both G03 and G04 packages.
As both support your card, YaST may want to install both, so you might have to “taboo” the G03 packages if you install G04.

fah client fails to use gpu for computing then i want to experiment the last version of the driver.

I don’t know what “fah client” is.
IIYC it uses/needs OpenCL. That actually should work fine with the G03 driver as well, but AFAIK you need to install additional cuda packages that are available from nvidia’s homepage (they do offer an additional repo).

i don’t understand “that won’t get fixed” because 13.1 is the next opensuse LTS. is it normal a LTS one keeps this kind of bug ?

There is no real bug.

Just to explain again: the driver won’t work on first reboot after installation with NO_KMS_IN_INITRD=“no”. But the nvidia packages set this to “yes” anyway. This is true for the G03 driver as well.
This is not really fixable without breaking CUDA again.
If you want to know more or have this fixed, file a bug report.

Also, the nvidia driver packages are not part of the distribution, so it doesn’t matter whether 13.1 is LTS or not.
And actually there is no “LTS” in openSUSE. 13.1 will be out of official support after about ~18 months (actually longer because 13.2 was delayed), like any other release. Then the Evergreen project (a bunch of volunteers basically) will keep on providing security and bugfix updates for another ~18 months.

i tried to install G03 but it fails also .
i uninstall G03 then now this is “nouveau” which is used .

i get some difficulties to load “nouveau” :

  • it seems that if you if you delete “nomodeset” in the boot statement by editing it during start up there is no effect. “nomodeset” stays active . you must use yast tool boot manager to remove it.

  • yesterday i launch “nouveau” with success and i use it several hours .
    but this morning i start pc then nouveau is not loaded
    i must restart pc to load nouveau

  • in gkrellm there is no more gpu temperature and in gkrellm settings there is no ore any senosrs about gpu temperature in the contrary if the previous adapter

  • the lists of modes is not complete . in kde settings there are only 640480 , 800600 , 1024768 . for example 12801024 is not in the list

i assume there is something weird around new kernel 3.11.10.29 , the new adapter GT 730 and any graphical driver

linux-b4lz:~ # rpm -qa | egrep “kernel|nouveau”
xorg-x11-driver-video-nouveau-1.0.9-3.1.2.x86_64
libdrm_nouveau2-32bit-2.4.46-3.2.2.x86_64
kernel-desktop-devel-3.11.10-25.1.x86_64
kernel-devel-3.11.10-25.1.noarch
kernel-devel-3.11.10-29.1.noarch
kernel-firmware-20130714git-2.21.1.noarch
kernel-desktop-devel-3.11.10-29.1.x86_64
patterns-openSUSE-devel_kernel-13.1-13.6.1.x86_64
kernel-desktop-3.11.10-29.1.x86_64
libdrm_nouveau2-2.4.46-3.2.2.x86_64
kernel-desktop-3.11.10-25.1.x86_64
linux-b4lz:~ #

i join the xorg.0.log and xorg.0.log.old
http://paste.opensuse.org/86069474
http://paste.opensuse.org/29889699

i lauch again mkinitrd to be sure nouveau is in the initrd as kms driver

linux-b4lz:~ # mkinitrd

Kernel image: /boot/vmlinuz-3.11.10-25-desktop
Initrd image: /boot/initrd-3.11.10-25-desktop
KMS drivers: nouveau
Root device: /dev/disk/by-id/ata-ST1000DM003-1CH162_S1D7EL8Q-part2 (/dev/sdc2) (mounted on / as ext4)
Resume device: /dev/disk/by-id/ata-ST1000DM003-1CH162_S1D7EL8Q-part1 (/dev/sdc1)
Microcode: AMD CPU family: 0xf does not support microcode updates
Kernel Modules: thermal_sys thermal processor fan scsi_dh scsi_dh_emc scsi_dh_alua scsi_dh_rdac scsi_dh_hp_sw button wmi video mxm-wmi i2c-algo-bit drm drm_kms_helper ttm nouveau sata_nv xhci-hcd hid-logitech-dj hid-holtek-kbd hid-lenovo-tpkbd hid-ortek hid-roccat hid-roccat-common hid-roccat-arvo hid-roccat-isku hid-samsung ohci-pci
Features: acpi amd_microcode kms plymouth block usb resume.userspace resume.kernel

Kernel image: /boot/vmlinuz-3.11.10-29-desktop
Initrd image: /boot/initrd-3.11.10-29-desktop
KMS drivers: nouveau
Root device: /dev/disk/by-id/ata-ST1000DM003-1CH162_S1D7EL8Q-part2 (/dev/sdc2) (mounted on / as ext4)
Resume device: /dev/disk/by-id/ata-ST1000DM003-1CH162_S1D7EL8Q-part1 (/dev/sdc1)
Microcode: AMD CPU family: 0xf does not support microcode updates
Kernel Modules: thermal_sys thermal processor fan scsi_dh scsi_dh_emc scsi_dh_alua scsi_dh_rdac scsi_dh_hp_sw button wmi video mxm-wmi i2c-algo-bit drm drm_kms_helper ttm nouveau sata_nv xhci-hcd hid-logitech-dj hid-holtek-kbd hid-lenovo-tpkbd hid-ortek hid-roccat hid-roccat-common hid-roccat-arvo hid-roccat-isku hid-samsung ohci-pci
Features: acpi amd_microcode kms plymouth block usb resume.userspace resume.kernel
linux-b4lz:~ #

after running mkinitrd i restart the pc .
nouveau is well loaded.

linux-b4lz:~ # lsmod | grep nouveau
nouveau 1013347 0
ttm 92265 1 nouveau
drm_kms_helper 56806 1 nouveau
drm 313440 3 nouveau,ttm,drm_kms_helper
i2c_algo_bit 13413 1 nouveau
mxm_wmi 13021 1 nouveau
video 19507 1 nouveau
wmi 19070 2 nouveau,mxm_wmi
button 13952 1 nouveau
linux-b4lz:~ #

then
i go to read xorg.0.log then i read something strange :

  • geforce 730 gpu family NVE0 is not listed :

    93.411] (II) NOUVEAU driver for NVIDIA chipset families :
    93.411] RIVA TNT (NV04)
    93.411] RIVA TNT2 (NV05)
    93.411] GeForce 256 (NV10)
    93.411] GeForce 2 (NV11, NV15)
    93.411] GeForce 4MX (NV17, NV18)
    93.411] GeForce 3 (NV20)
    93.411] GeForce 4Ti (NV25, NV28)
    93.411] GeForce FX (NV3x)
    93.411] GeForce 6 (NV4x)
    93.411] GeForce 7 (G7x)
    93.411] GeForce 8 (G8x)
    93.411] GeForce GTX 200 (NVA0)
    93.411] GeForce GTX 400 (NVC0)
    93.411] (II) NOUVEAU driver
    93.411] (II) NOUVEAU driver for NVIDIA chipset families :
    93.411] RIVA TNT (NV04)
    93.411] RIVA TNT2 (NV05)
    93.411] GeForce 256 (NV10)
    93.412] GeForce 2 (NV11, NV15)
    93.412] GeForce 4MX (NV17, NV18)
    93.412] GeForce 3 (NV20)
    93.412] GeForce 4Ti (NV25, NV28)
    93.412] GeForce FX (NV3x)
    93.412] GeForce 6 (NV4x)
    93.412] GeForce 7 (G7x)
    93.412] GeForce 8 (G8x)
    93.412] GeForce GTX 200 (NVA0)
    93.412] GeForce GTX 400 (NVC0)

  • kms is enabled (see above mkinitrd) but

    93.412] (II) VESA: driver for VESA chipsets: vesa
    93.412] (++) using VT number 7

    93.412] (EE) [drm] KMS not enabled
    93.412] (EE) [drm] KMS not enabled
    93.412] (EE) open /dev/dri/card0: No such file or directory

-acquiring monitor definition failed (Philips 170C5)


93.841] (II) VESA(0): VESA VBE DDC read failed

i join the xorg.0.log
http://paste.opensuse.org/11393230

To find out why the nvidia driver is not working, we need the Xorg log and the package list with the nvidia driver installed of course.

Those logs show that it is not even installed (so it cannot be loaded obviously), and “vesa” is used instead.

i uninstall G03 then now this is “nouveau” which is used .

No, it is not, according to the logs you posted.

  • it seems that if you if you delete “nomodeset” in the boot statement by editing it during start up there is no effect. “nomodeset” stays active . you must use yast tool boot manager to remove it.

And how do you judge that it “stays active”?
If you remove it from the command line, it is removed, and the kernel is started without “nomodeset”.

Probably you still have a blacklist in the initrd or in your system?
Please post the output of:

grep nouveau /etc/modprobe.d/*

And for using nouveau you should set NO_KMS_IN_INITRD=“no” and run “sudo mkinitrd”.

  • yesterday i launch “nouveau” with success and i use it several hours .
    but this morning i start pc then nouveau is not loaded
    i must restart pc to load nouveau

And how do you determine that you ran nouveau “successfully”?

  • in gkrellm there is no more gpu temperature and in gkrellm settings there is no ore any senosrs about gpu temperature in the contrary if the previous adapter

AFAIK this only works with the nvidia driver.
It definitely does not work with vesa anyway.

  • the lists of modes is not complete . in kde settings there are only 640480 , 800600 , 1024768 . for example 12801024 is not in the list

Well, that’s probably because you are using the “vesa” driver.
Your logs tell that it can only determine these resolutions:

   212.442] (--) VESA(0): Virtual size is 1024x768 (pitch 1024)
   212.442] (**) VESA(0): *Built-in mode "1024x768"
   212.442] (**) VESA(0): *Built-in mode "800x600"
   212.442] (**) VESA(0): *Built-in mode "640x480"

i assume there is something weird around new kernel 3.11.10.29 , the new adapter GT 730 and any graphical driver

I don’t think so. I haven’t heard of other people complaining about problems.

I’d rather think there’s something weird about your particular system. As I already wrote some months ago, there might still be some files left-over or system files overwritten from your previous experiments with some other inofficial nvidia driver package that interferes.
But I have no idea what that could be, and where to search for it.

I’d rather suspect a kernel module though.
Does “find /lib/modules -name nvidia” show anything? (with the nvidia driver uninstalled)

I’m quite sure a completely fresh installation would fix your problems.

Really?
All the logs you posted tell otherwise.

If it really worked, some blacklist was still in the initrd probably.

linux-b4lz:~ # lsmod | grep nouveau
nouveau 1013347 0
ttm 92265 1 nouveau
drm_kms_helper 56806 1 nouveau
drm 313440 3 nouveau,ttm,drm_kms_helper
i2c_algo_bit 13413 1 nouveau
mxm_wmi 13021 1 nouveau
video 19507 1 nouveau
wmi 19070 2 nouveau,mxm_wmi
button 13952 1 nouveau
linux-b4lz:~ #

The nouveau kernel module is loaded, yes.
But that doesn’t necessarily mean that Xorg is using the nouveau driver too.

then
i go to read xorg.0.log then i read something strange :

  • geforce 730 gpu family NVE0 is not listed :

Well, I have no idea whether your card should be listed.
But 13.1 is quite old already.
It might be that the included nouveu driver just does not support your card at all.
Although judging from the Xorg logs (and in particular the “KMS not enabled” messages), this seems to not be the reason for the problem.

  • kms is enabled (see above mkinitrd) but

    93.412] (II) VESA: driver for VESA chipsets: vesa
    93.412] (++) using VT number 7
93.412] (EE) [drm] KMS not enabled
93.412] (EE) [drm] KMS not enabled
93.412] (EE) open /dev/dri/card0: No such file or directory

Does it work if you disable plymouth?
(add “plymouth.enable=0” to the boot options)

To find out why the nvidia driver is not working, we need the Xorg log and the package list with the nvidia driver installed of course.

Those logs show that it is not even installed (so it cannot be loaded obviously), and “vesa” is used instead.

in this post i just say there is also a pb with “nouveau” and i supply all the info about this pb

it’s new because till now there was no pb

and yes now i understand by reading Xorg.0.log this a vesa driver which is active

Probably you still have a blacklist in the initrd or in your system?
Please post the output of:

linux-b4lz:~ # grep nouveau /etc/modprobe.d/*
linux-b4lz:~ #

And for using nouveau you should set NO_KMS_IN_INITRD=“no” and run “sudo mkinitrd”

yes i do this everytime

  • in gkrellm there is no more gpu temperature and in gkrellm settings there is no ore any senosrs about gpu temperature in the contrary if the previous adapter AFAIK this only works with the nvidia driver.

with nouveau i get gpu temperature with gkrellm

Does “find /lib/modules -name nvidia” show anything? (with the nvidia driver uninstalled)

linux-b4lz:~ # find /lib/modules -name nvidia
/lib/modules/3.11.10-25-desktop/kernel/drivers/video/nvidia
/lib/modules/3.11.10-25-desktop/kernel/drivers/net/ethernet/nvidia
/lib/modules/3.11.10-29-desktop/kernel/drivers/video/nvidia
/lib/modules/3.11.10-29-desktop/kernel/drivers/net/ethernet/nvidia
linux-b4lz:~ #

But you started this thread because of a problem with the nvidia driver.
So I was actually expecting to see logs with the nvidia driver failing.

A log with the nvidia not even installed doesn’t help much in finding out why the nvidia driver doesn’t work… :wink:

it’s new because till now there was no pb

You had problems with the nvidia driver before. That’s what I was referring to.

with nouveau i get gpu temperature with gkrellm

Ok.
But as mentioned, the vesa driver definitely does not support this.
I wasn’t sure about nouveau, but I do know that gkrellm contains a specific plugin for the nvidia driver.

linux-b4lz:~ # find /lib/modules -name nvidia
/lib/modules/3.11.10-25-desktop/kernel/drivers/video/nvidia
/lib/modules/3.11.10-25-desktop/kernel/drivers/net/ethernet/nvidia
/lib/modules/3.11.10-29-desktop/kernel/drivers/video/nvidia
/lib/modules/3.11.10-29-desktop/kernel/drivers/net/ethernet/nvidia
linux-b4lz:~ #

Alright. Those “video/nvidia” files/directories should not be there I suppose. At least they are not included in the kernel package, unlike “net/ethernet/nvidia” (which contains the ethernet driver for nvidia mainboard chipsets).
And the official nvidia driver packages install the kernel modules to a different place, /lib/modules/x.xx.xx-xx-desktop/updates/ to be exact.

So maybe that’s causing your problems? They might contain an incompatible nvidia kernel module, that’s even copied to the initrd.

Remove them:

sudo rm -r /lib/modules/3.11.10-25-desktop/kernel/drivers/video/nvidia /lib/modules/3.11.10-29-desktop/kernel/drivers/video/nvidia

Then run “sudo depmod -a”, and mkinitrd again.
Hopefully nouveau will work then, and maybe the nvidia driver as well.

If not, we will have to investigate further…

Does it work if you disable plymouth?
(add “plymouth.enable=0” to the boot options)

no

22.460] (EE) [drm] KMS not enabled
22.460] (EE) [drm] KMS not enabled

are still there

i join the xorg.0.log
http://paste.opensuse.org/27780762

Well, actually this seems to contain the nvidiafb driver, which doesn’t exist any more in 13.2’s kernel (but does in 13.1).
So removing it probably won’t help.
What do they contain?

ls -l /lib/modules/3.11.10-25-desktop/kernel/drivers/video/nvidia

And could you please also post the output of this?

find /lib/modules -name *nvidia*

sudo rm -r /lib/modules/3.11.10-25-desktop/kernel/drivers/video/nvidia /lib/modules/3.11.10-29-desktop/kernel/drivers/video/nvidia Then run “sudo depmod -a”, and mkinitrd again.

after i restart pc
then
vesa driver is used nto “nouveau”

i join the Xorg.0.log
http://paste.opensuse.org/74231324

linux-b4lz:~ # ls -l /lib/modules/3.11.10-25-desktop/kernel/drivers/video/nvidia
ls: cannot access /lib/modules/3.11.10-25-desktop/kernel/drivers/video/nvidia: No such file or directory
linux-b4lz:~ #

linux-b4lz:~ # find /lib/modules -name nvidia
/lib/modules/3.11.10-25-desktop/kernel/drivers/net/ethernet/nvidia
/lib/modules/3.11.10-29-desktop/kernel/drivers/net/ethernet/nvidia
linux-b4lz:~ #

Right, because KMS is still disabled for some reason.

And apparently there are no files left containing nvidia in the name (other than the ethernet driver), so there should nothing interfere.

Can you please post the output of:

dmesg | grep -i nouveau

This will hopefully give a clue what’s wrong with nouveau.

According to FeatureMatrix · freedesktop.org your card should be supported by nouveau, and the XOrg log doesn’t really look like it weren’t.
nouveau might have problems with your card, but it should at least load.

Could you please also post /etc/sysconfig/kernel? It might have been modified since you last posted it months ago…

And the output of this as well:

grep drm /etc/modprobe.d/*

PS: as you suspected something to be wrong with the 3.11.10-29 kernel, try to select the previous one (3.11.10-25) in “Advanced Settings” in the boot menu.
Does nouveau work then?

linux-b4lz: # dmesg | grep -i nouveau
linux-b4lz: #

According to FeatureMatrix · freedesktop.org your card should be supported by nouveau

yes but what version , a more recent i assume ?

today the official kernel for 13.2 is 3.16.7 . is it possible to get a 3.16.7 for 13.1 ?

linux-b4lz:/ # grep drm /etc/modprobe.d/*
linux-b4lz:/ #

Hm.
So there’s absolutely no output from nouveau. This seems to indicate that it is not even tried to be loaded…

Try running “sudo /sbin/modprobe -v nouveau”, and then post the output of “dmesg|tail”.

Can you try adding “nouveau” to “INITRD_MODULES” in /etc/sysconfig/kernel and run mkinitrd?
Does this change anything?

yes but what version , a more recent i assume ?

The current one I suppose.

But again, your problem doesn’t seem to come from your card not being supported yet by the nouveau driver.
And fbdev fails to load as well.

today the official kernel for 13.2 is 3.16.7 . is it possible to get a 3.16.7 for 13.1 ?

The kernel is not really specific to a certain openSUSE release, so you could just install the 13.2 one.

Or the latest stable one (4.0 at the moment) is always available here:
http://download.opensuse.org/repositories/Kernel:/stable/standard/
But don’t expect the nvidia driver to work with this. (it might, or it might not support it already)

As openSUSE keeps multiple kernel installed by default, you can always go back to the older one in “Advanced Options” in the boot menu.

But, this will not change the Xorg driver. You’d have to completely switch to a newer Xorg as well.
And this probably won’t help at all as long as you get that error (KMS not enabled) anyway I think.

linux-b4lz:/ # grep drm /etc/modprobe.d/*
linux-b4lz:/ #

Ok, then please post a complete directory listing:

ls -l /etc/modprobe.d/

And the contents of /etc/modprobe.d/50-blacklist.conf in particular.

PS: you do not happen to have anything related to bumblebee installed I hope?
Like bbswitch (and/or bbswitch-kmp-desktop), bumblebee or bumblebee-nvidia?

linux-b4lz:~ # /sbin/modprobe -v nouveau
linux-b4lz:~ # dmesg|tail
464.771226] SFW2-INext-ACC-TCP IN=enp0s7 OUT= MAC=00:1e:8c:69:b1:35:00:07:cb:49:7b:9c:08:00 SRC=89.27.14.97 DST=192.168.0.52 LEN=64 TOS=0x00 PREC=0x00 TTL=45 ID=39083 DF PROTO=TCP SPT=60667 DPT=6881 WINDOW=8192 RES=0x00 SYN URGP=0 OPT (020405B4010303000101080A124FFB890000000004020000)
465.698962] SFW2-INext-DROP-DEFLT IN=enp0s7 OUT= MAC=00:1e:8c:69:b1:35:00:07:cb:49:7b:9c:86:dd SRC=2002:0501:1b68:0000:0000:0000:0501:1b68 DST=2a01:0e35:2e94:5030:021e:8cff:fe69:b135 LEN=1280 TC=0 HOPLIMIT=118 FLOWLBL=0 PROTO=ICMPv6 TYPE=3 CODE=1 [SRC=2a01:0e35:2e94:5030:021e:8cff:fe69:b135 DST=2002:0501:1b68:0000:0000:0000:0501:1b68 LEN=1480 TC=0 HOPLIMIT=53 FLOWLBL=0 OPT ( FRAG:0 INCOMPLETE ID:a9708e8f ) PROTO=UDP SPT=7881 DPT=49001 LEN=1917 ]
485.162300] SFW2-INext-ACC-TCP IN=enp0s7 OUT= MAC=00:1e:8c:69:b1:35:00:07:cb:49:7b:9c:08:00 SRC=188.134.77.250 DST=192.168.0.52 LEN=60 TOS=0x00 PREC=0x00 TTL=42 ID=5771 DF PROTO=TCP SPT=42631 DPT=6881 WINDOW=14600 RES=0x00 SYN URGP=0 OPT (020405B40402080A01FB11C30000000001030307)
485.945089] SFW2-INext-DROP-DEFLT IN=enp0s7 OUT= MAC=00:1e:8c:69:b1:35:00:07:cb:49:7b:9c:86:dd SRC=2002:2e48:f142:0000:0000:0000:2e48:f142 DST=2a01:0e35:2e94:5030:021e:8cff:fe69:b135 LEN=1280 TC=0 HOPLIMIT=115 FLOWLBL=0 PROTO=ICMPv6 TYPE=3 CODE=1 [SRC=2a01:0e35:2e94:5030:021e:8cff:fe69:b135 DST=2002:2e48:f142:0000:0000:0000:2e48:f142 LEN=1480 TC=0 HOPLIMIT=53 FLOWLBL=0 OPT ( FRAG:0 INCOMPLETE ID:10e2c265 ) PROTO=UDP SPT=7881 DPT=49001 LEN=1917 ]
504.852111] SFW2-INext-ACC-TCP IN=enp0s7 OUT= MAC=00:1e:8c:69:b1:35:00:07:cb:49:7b:9c:08:00 SRC=67.165.201.205 DST=192.168.0.52 LEN=60 TOS=0x00 PREC=0x00 TTL=42 ID=55292 DF PROTO=TCP SPT=33098 DPT=6881 WINDOW=29200 RES=0x00 SYN URGP=0 OPT (020405B40402080A16A254DB0000000001030307)
505.599711] SFW2-INext-DROP-DEFLT IN=enp0s7 OUT= MAC=00:1e:8c:69:b1:35:00:07:cb:49:7b:9c:86:dd SRC=2002:bce6:371c:0000:0000:0000:bce6:371c DST=2a01:0e35:2e94:5030:021e:8cff:fe69:b135 LEN=1280 TC=0 HOPLIMIT=118 FLOWLBL=0 PROTO=ICMPv6 TYPE=3 CODE=1 [SRC=2a01:0e35:2e94:5030:021e:8cff:fe69:b135 DST=2002:bce6:371c:0000:0000:0000:bce6:371c LEN=1480 TC=0 HOPLIMIT=53 FLOWLBL=0 OPT ( FRAG:0 INCOMPLETE ID:5a470399 ) PROTO=UDP SPT=7881 DPT=49001 LEN=1917 ]
506.049427] SFW2-INext-DROP-DEFLT IN=enp0s7 OUT= MAC=00:1e:8c:69:b1:35:00:07:cb:49:7b:9c:86:dd SRC=2002:5ebe:5e6a:0000:0000:0000:5ebe:5e6a DST=2a01:0e35:2e94:5030:021e:8cff:fe69:b135 LEN=316 TC=0 HOPLIMIT=115 FLOWLBL=0 PROTO=UDP SPT=500 DPT=500 LEN=276
524.756575] SFW2-INext-ACC-TCP IN=enp0s7 OUT= MAC=00:1e:8c:69:b1:35:00:07:cb:49:7b:9c:08:00 SRC=81.234.43.59 DST=192.168.0.52 LEN=60 TOS=0x00 PREC=0x00 TTL=47 ID=27268 DF PROTO=TCP SPT=61698 DPT=6881 WINDOW=7300 RES=0x00 SYN URGP=0 OPT (020405B40402080A01B60B8D0000000001030300)
527.630666] SFW2-INext-DROP-DEFLT IN=enp0s7 OUT= MAC=00:1e:8c:69:b1:35:00:07:cb:49:7b:9c:86:dd SRC=2002:1fca:cd2d:0000:0000:0000:1fca:cd2d DST=2a01:0e35:2e94:5030:021e:8cff:fe69:b135 LEN=1280 TC=0 HOPLIMIT=118 FLOWLBL=0 PROTO=ICMPv6 TYPE=3 CODE=1 [SRC=2a01:0e35:2e94:5030:021e:8cff:fe69:b135 DST=2002:1fca:cd2d:0000:0000:0000:1fca:cd2d LEN=1480 TC=0 HOPLIMIT=53 FLOWLBL=0 OPT ( FRAG:0 INCOMPLETE ID:0251e501 ) PROTO=UDP SPT=7881 DPT=49001 LEN=1917 ]
544.676580] SFW2-INext-ACC-TCP IN=enp0s7 OUT= MAC=00:1e:8c:69:b1:35:00:07:cb:49:7b:9c:08:00 SRC=145.255.36.160 DST=192.168.0.52 LEN=60 TOS=0x00 PREC=0x00 TTL=46 ID=57947 DF PROTO=TCP SPT=38378 DPT=6881 WINDOW=7300 RES=0x00 SYN URGP=0 OPT (020405500402080A25034A470000000001030300)
linux-b4lz:~ #

linux-b4lz:~ # dmesg| grep nouveau
1.201157] fb: conflicting fb hw usage nouveaufb vs VESA VGA - removing generic driver
1.201807] nouveau E DEVICE][0000:02:00.0] unknown chipset, 0xb06070b1
1.201813] nouveau E DRM] failed to create 0x80000080, -22
1.202078] nouveau: probe of 0000:02:00.0 failed with error -22
linux-b4lz:~ #

linux-b4lz:~ # ls -l /etc/modprobe.d/
total 52
-rw-r–r-- 1 root root 3613 Sep 27 2013 00-system.conf
-rw-r–r-- 1 root root 181 Nov 28 2013 50-alsa.conf
-rw-r–r-- 1 root root 5943 Apr 10 2014 50-blacklist.conf
-rw-r–r-- 1 root root 128 Mar 10 2014 50-bluetooth.conf
-rw-r–r-- 1 root root 30 Nov 26 2013 50-cdc_ncm.conf
-rw-r–r-- 1 root root 33 Sep 28 2013 50-ipw2200.conf
-rw-r–r-- 1 root root 34 Sep 28 2013 50-iwl3945.conf
-rw-r–r-- 1 root root 30 Sep 28 2013 50-iwlagn.conf
-rw-r–r-- 1 root root 18 Sep 28 2013 50-prism54.conf
-rw-r–r-- 1 root root 194 Jan 3 2014 50-sound.conf
-rw-r–r-- 1 root root 0 Jan 3 2014 50-sound.conf.YaST2save
-rw-r–r-- 1 root root 84 Jan 2 2014 50-user-blacklist.conf
-rw-r–r-- 1 root root 47 Nov 22 2011 99-local.conf
linux-b4lz:~ #

50.blacklist.conf
http://paste.opensuse.org/28702933

PS: you do not happen to have anything related to bumblebee installed I hope?
Like bbswitch (and/or bbswitch-kmp-desktop), bumblebee or bumblebee-nvidia?

no

Well, that’s at least a definitive error message now finally.
So it doesn’t look like you could get nouveau to work with your current kernel.

Still, the nvidia driver should work, both G03 or G04.
Care to try that again?

sudo zypper in nvidia-gfxG04-kmp-desktop nvidia-uvm-gfxG04-kmp-desktop nvidia-glG04 nvidia-computeG04 x11-video-nvidiaG04

Before you should add “nouveau” from /etc/sysconfig/kernel if you did add it though.

And just to mention it again: if it doesn’t work on first boot, just try to reboot again without changing anything.
If it still does not work, just try to reboot again and add “nomodeset” to the boot options.

linux-b4lz:~ # ls -l /etc/modprobe.d/
total 52
-rw-r–r-- 1 root root 3613 Sep 27 2013 00-system.conf
-rw-r–r-- 1 root root 181 Nov 28 2013 50-alsa.conf
-rw-r–r-- 1 root root 5943 Apr 10 2014 50-blacklist.conf
-rw-r–r-- 1 root root 128 Mar 10 2014 50-bluetooth.conf
-rw-r–r-- 1 root root 30 Nov 26 2013 50-cdc_ncm.conf
-rw-r–r-- 1 root root 33 Sep 28 2013 50-ipw2200.conf
-rw-r–r-- 1 root root 34 Sep 28 2013 50-iwl3945.conf
-rw-r–r-- 1 root root 30 Sep 28 2013 50-iwlagn.conf
-rw-r–r-- 1 root root 18 Sep 28 2013 50-prism54.conf
-rw-r–r-- 1 root root 194 Jan 3 2014 50-sound.conf
-rw-r–r-- 1 root root 0 Jan 3 2014 50-sound.conf.YaST2save
-rw-r–r-- 1 root root 84 Jan 2 2014 50-user-blacklist.conf
-rw-r–r-- 1 root root 47 Nov 22 2011 99-local.conf
linux-b4lz:~ #

What’s in 50-user-blacklist.conf please?

Before you should add “nouveau” from /etc/sysconfig/kernel if you did add it though.

i remove “nouveau” in INITRD_MODULES in kernel file in and run mkinitrd

Care to try that again?

i must try because with vesa no webcam with kopete , skype , hangouts

What’s in 50-user-blacklist.conf please?

i blacklist “powernow_k8” . if not during start up i get a pc freeze.

i load it in boot.local