Factory: Something related to EVDEV broken for today's update?

I run a Factory release on a test box and boot into init 3 before manually invoking startx. After running zypper up today, I can no longer boot into X. The Xorg log recorded these errors:

2395.446] (EE) ioctl EVIOCGNAME failed: Inappropriate ioctl for device
2395.462] (EE) PreInit returned NULL for “ImPS/2 Generic Wheel Mouse”

Things were running fine yesterday. I did not make any modifications to the 10-evdev file in /etc/X11/xorg.conf.d, so I’m pretty sure the problem was a result of a updated package on Factory.

Does anyone know how I can fix this? udevd is running when I checked, and all the devices seem to respond correctly when I ran evtest.

Nevermind, PEBCAK. Turns out that the error was a red herring. It was a problem with the /usr/bin/kde4 script (now that I think of it, there was a KDE update last night). Figured something was up when out of frustration I typed “xdm” and hit enter, and the X server started. So I created a local .xinitrc and forced it to start KDE directly, and it did. But I could not figure out for the life of me what’s wrong until another bout of frustration made me type “cat /usr/bin/kde4” and noticed that it was actually a script that adds a path to /opt/kde3/bin. Doing a ls on said directory shows that it was empty. The script also tried to invoke “exec “$@””. No idea what that does either, but I first assumed that $@ is a variable that holds the words “startkde” somehow.

Didn’t work.

So out of frustration I just modified the script to invoke startkde directly. Problem solved.