Factory: Package corruption Error

Hi,

I’m using the factory releases of OpenSUSE and during an update which I’ve been running yesterday, I’ve started encountering anodd error. Wether I use Yast, or Zypper, I get the following error message: “Package javamail-monolithic-1.4-253.3 seems to be corrupted during transfer. Do you want to retry retrieval?” (copied from Zypper) from ANY package I attempt to download/update.
I’ve tried rebuilding the local rpm database and force refreshed all repositories and their respective caches. Though it doesn’t resolv the situation.
As the behavior started during the update, I guess it must have something to do with another updated package being corrupted but I don’t have the slightest clue what to look for!

If anyone has any idea, please help!

Thanks,
Adrixan

Hi everyone,

I’ve found out myself what was causing the odd behaviour:
The mirror from gd.tuwien.ac.at seems to be broken currently and it sent a custom error page in reply to the request of the missing rpm which yast misinterpreted. So I’ve manually changed my repositories to another mirror, now it works like a charm again!

kind regards,
Adrixan