Factory on a Nvidia Optimus laptop


I tried both an upgrade, and a later fresh install of Factory, but it stops on boot, displaying a Nouveau error.
The upgrade made the boot halt completely, and the fresh install hung about 5 minutes, before continuing.

So I was wondering, if anyone else has had any success with Factory on a Nvidia Optimus laptop?

Other problems noticed:
The external Logitech mouse, was lagging a lot.
Yast crashing, even after removing libproxy1-config-kde4 (Ex. in Users and groups)

You should post 13.2 problems on the beta form not here.

That said. Optimus is truly a messed up hardware spec.and may take a while to settle down in the factory.

Remember this is testing software and you have to expect things not to work If you read the beta form you will see that so far you can manually install the NVIDIA driver so consider that you may have to take things nto your own hands to make it work. You should not expect to use factory on a production machine it is for testing

Thanks. My bad.
Can I move the post in any way?

The problem seems to be the Nouveau driver, which was installed automatically, for some reason.
Installing Bumblebee did not help a bit.
The official guide mentioned adding the user to some groups, using the useradd command, but no, command not found.
Launching Yast to manage users and groups, was not an option either, since it crashed every time.

I read some post about blacklisting Nouveau, but none of these suggestions helped.
I could not get rid of this driver, so I ended up reverting the whole thing, using Clonezilla. :slight_smile:

Btw. it works perfectly in 13.1, so I am sticking with this, at the moment. (Steam, Bumblebee, etc.)

This thread will be moved to Pre-release/Beta and is CLOSED for the moment.

Moved from Aplications and open again.

No. On Bumblebee the system normally uses the intel chip.
And there seems to be a problem with the intel driver in Factory at the moment, at least on certain chips (it worked file on my intel system when I tried a Factory LiveUSB).
Downgrading Mesa to the version from 13.1, or upgrading the intel driver to a 3.0.0git version from OBS might help.
See also:
(and the following posts)

Installing Bumblebee did not help a bit.

Of course not, because even with Bumblebee the system still uses the intel chip.
And also blacklisting nouveau will not help, because your problem is not caused by nouveau. nouveau is not even used.

Your YaST crash is most likely also caused by the graphics driver, according to the other thread.

So it is problems with the Intel driver, which is causing these error messages about Nouveau?

If I remember correctly, the boot errors looked something like this:
[Number] Nouveau (more text)
(About 10 lines)

Is it an Optimus only or a model that can switch between Optimus and Nvidia only? Brand and model?

No. But as I said, the system normally should use the intel driver, thus nouveau shouldn’t be relevant.
Unless you switched of the intel graphics in the BIOS of course (some models allow this).

I take it that the system just halts when those nouveau errors appear?
I slightly misunderstood your problem then, sorry.

If I remember correctly, the boot errors looked something like this:
[Number] Nouveau (more text)
(About 10 lines)

Looks like a kernel/nouveau kernel module problem then.

Try to add “nomodeset” to the boot options, that should prevent nouveau from being used at all.
But this will also prevent the intel driver from working if you should need it.
Maybe “nouveau.modeset=0” would be more specific to nouveau, I’m not sure right now.

Btw, you have to recreate the initrd after blacklisting nouveau. Otherwise it might still get loaded there, before the system even sees your blacklist file (especially if you have plymouth installed, as this is normally started by the initrd already and loads the graphics drivers).
Factory uses dracut now to create an initrd, I don’t know how you would have to run it. Maybe just “dracut” (as root) would suffice.

It is a MSI GE70 2PE Apache Pro:

No hardware switch for graphics, only the Intel HD Graphics 4600 and the NVIDIA GeForce GTX 860M.
The switching can be done either by using Bumblebee, or automatically using the official Nvidia driver on the latest kernel with Optimus support.
(Not sure if I am understanding you correctly)

Unless this has changed recently, you cannot switch at all between intel and nvidia only by installing the official nvidia driver.
And just installing the nvidia driver breaks the intel driver as I already mentioned.

You have to use Bumblebee if you want to switch.

Switching should work with the latest kernel and nouveau though as I understand it. Maybe you’re confusing this?

(Not sure if I am understanding you correctly)

You might be able to switch between intel and nvidia in the BIOS settings (by either disabling the one or the other). I think that’s what hank_se meant.