Factory keeps trying to install texlive on zypper dup

So, I’m running a fresh factory installation from the 8-20 snapshot.

I noticed it wasn’t upgrading any packages, but have not figured out that it will only do that once a new snapshot is release, not when a new package is released.

Anyway, since the 8-28 updates, when I run a “zypper dup” it keeps trying to install texlive package (and it’s numerous dependencies).

However, I let it install it once, since I thought it might be a new dependency for a package for some reason. However, when I went to manually remove it, it removed just fine, taking no other packages (other than it’s texlive deps) with it.

Then I go back to do a zypper dup, and again, it want so to pull in all of texlive.

Anyone else seen this, or have any idea why it’s trying to install a new package without dependencies?

No, that is not happening here.

I have texlive and latex installed on one of my systems, but not on others. I updated to 20140829 earlier today (and to 20140828 yesterday). But “texlive” was not installed during that “zypper dup”.

My guess is that you have something else installed that is recommending “texlive”.

If there a way to determine what is requesting that package, or why zypper keeps pulling it in?

On 2014-08-31 06:46, TeutonJon78 wrote:

> If there a way to determine what is requesting that package, or why
> zypper keeps pulling it in?

Try with yast.

Cheers / Saludos,

Carlos E. R.
(from 13.1 x86_64 “Bottle” at Telcontar)

I got exactly the same thing going on for the last while… tried to check dependencies in yast but can’t make out what might be trying to pull it in…

OK… update on this!

I checked the option in Yast to “ignore recommended packages for already installed…”
problem then solved.

Glad I’m not the only one who had this.

I tried doing a fresh install using 0829 snapshot (it’s just in a VM so no big deal), and this time it didn’t pull in the update, even with the same software installed. So, it must have been a small bug in a package that kept trying to pull it in.

I tried to use the yaster solver to find it, but as soon as I install libqdialogsolver1, it would crash every time, so I couldn’t find out who was recommending texlive either.

A little poking around with rpm and grep yields this:

gwb@linux-5i94:~> rpm -q --recommends python-matplotlib

so it looks like pythonmatplotlib went a little overboard with “recommends”.

Would this be grounds for a bug report?

Maybe, maybe not.
Depends on why it recommends it in the first place, i.e. whether texlive is used/needed by python-matplotlib and for what.

But as it is only recommended, you don’t actually have to install it.
Just add a lock on those packages (or “taboo” them in YaST), and “zypper dup” won’t install them.

Or disable the automatic installation of recommended packages at all, see /etc/zypp/zypp.conf:

## Whether required packages are installed ONLY
## So recommended packages, language packages and packages which depend
## on hardware (modalias) will not be regarded.
## Valid values: boolean
## Default value: false
# solver.onlyRequires = false

I think that this is bug.
There was everything OK last week.
I regularly try Net Factory ISO in VirtualBox. But there is that annoying texlive case this week.

I have problem when I try to install krusader.

zypper install krusader

insists on installation of more than 1500 packages, absolute majority are unnecessary texlive packages.

I just checked. And, indeed, if I try to install “krusader”, it wants to install many texlive packages.

Yes, I’m inclined to agree that is a bug.

And why do you think this is related?

python-matplotlib does indeed recommend texlive (as posted by GeoBaltz), so it’s obvious that it gets installed. This in itself is no bug. (it would be a bug though if it recommends it unnecessarily)

Krusader OTOH does not recommend texlive. And the package hasn’t been changed in a year anyway.
So if texlive is going to be installed it might be pulled in by some other package/pattern, or there is indeed a bug in zypper.

But I just tried to install krusader in my up-to-date Factory VM, and it is true that texlive was pulled in (and also some GNOME and python packages).
I’ll try to find out which one.

If you want to install krusader without installing texlive, use the “–no-recommends” option or set “solver.onlyRequires” as already mentioned.
Or taboo texlive.

In this case it’s kate, or kate-python-plugins actually.
This recommends IPython, which in turn requires python-matplotlib among others.
And python-matplotlib recommends texlive as already mentioned in this thread.
But AFAICS that’s nothing new, especially nothing that has changed in the last week.
In fact, those recommends have been added in November last year already, the change entered Factory in January:

What has changed recently though, is the creation of the kate-python-plugins package which recommends IPython:

Again, if the recommendation is unnecessary, it is a bug.
If it does need texlive (or IPython in the case of kate-python-plugins) for some function, this is probably done on purpose. Otherwise people will complain that it doesn’t completely work after they installed it… :
See here e.g.:

Good catch – I had installed Kate on that install of Factory. I don’t think I did on the install that isn’t asking for textlive at the moment. Thanks.

Indeed! I was getting all these texlive packages coming in until I uninstalled KATE… pity, cos I like Kate. it’s back to Kwrite now…

You do not have to uninstall kate!

Again, those packages are not required, they are only recommended. And texlive is not even recommended by kate, but by python-matplotlib.

Run e.g. “sudo zypper in --no-recommends kate” and kate will be installed without pulling in kate-python-plugins, IPython, python-matplotlib, and texlive in the end.
Or just uninstall and lock python-matplotlib f.i., to not get texlive installed again.

Or set “solver.onlyRequires=true” in /etc/zypp/zypp.conf as I already posted, then absolutely no recommended packages will ever be installed automatically.

I consulted this texlive case with openSUSE representative at Akademy 2014 in Brno https://akademy.kde.org/2014 during Factory presentation.
We were trying to install krusader. He stated that this is bug, which should be reported.

Editing of /etc/zypp/zypp.conf is not correct way of packages installation.

Also both representatives stated general rule.
Developers do not read forum. If you want something to be solved, you must report bug.

The thing is that those recommends probably make sense for each package in isolation.

kate e.g. has to recommend kate-plugins-python, because they were part of that package until recently. If it wouldn’t recommend those plugins, people would suddenly miss those plugins after an update/upgrade.
kate-python-plugins recommending IPython seems to make sense as well.

But I wouldn’t expect IPython pulling in texlive. The question then is, should it not recommend python-matplotlib, or should python-matplotlib not recommend texlive/latex? There might be good reasons for both of those as well. And what about inkscape? (Nobody has mentioned that one here yet. It is also pulled in.)

In the end it is the combination of all those recommends that causes the (probably) unexpected behavior, that kate (or krusader for that matter) pulls in texlive.
But it’s not always easy to find a good compromise. Having too few recommends will cause people to complain that their freshly installed package doesn’t work properly…

Editing of /etc/zypp/zypp.conf is not correct way of packages installation.

Of course not.
But I suggested it as a (permanent) work-around to not get all those recommended packages installed.

Also both representatives stated general rule.
Developers do not read forum. If you want something to be solved, you must report bug.

I wrote this as well already often enough.
Here in this thread I upto now forgot to explicitely state that somebody should report it, if they think it is a bug, though.

I have to say that personally I don’t really care, as I have texlive installed anyway. So I wouldn’t even have noticed this…

Personally, I agree. I hope the OP, or someone else having this problem, does report it.

Use this link to report: openSUSE:Submitting bug reports

Reporting a bug is fairly easy. The worst that can happen, is that the bug might be marked INVALID. Reporting as a bug will at least require someone to make a decision as to whether recommending texlive is reasonable in this case.

I have made some research in Fedora KDE.

  1. krusader is installed automatically during installation process. But there is not kate installed. krusader package does not depend on kate in Fedora.
  2. When I tried to install kate, there was any dependency on some type of kate-python plugin. Only kate alone was installed.