Facebook Video's Don't Play After Upgrade to 15.3

Hi, I just upgraded from 15.2 to 15.3, and now I can’t play any video’s on Facebook or listen to music on XMRadio in Firefox. I think I remember having to install libavcodec56, libavdevice56 and libavformats56, but they don’t seem to be available on either the standard repos or in the Packman repos. I tried using the debug console in Firefox to see if I could find the missing libs but with no success. What am I missing?

Upgrade.
Use libavcodec57 and/or libavcodec58, etc.

They are already installed which is what confuses me.

Does the browser play any audio successfully? When you attempt to play media content, does the stream show up in ‘pavucontrol’?

Is it firefox-specific? ie it works if you try another browser?

Please take a look at the “Firefox MP4/H.264 Video Support” SDB: <https://en.opensuse.org/SDB:Firefox_MP4/H.264_Video_Support&gt;.

  • You need the libavcodec, ibavformat and libavdevice packages (57 and 58_134/13/76 – the numbers change occassionally
    ) from either the Packman Essentials repository or, the VLC repository.

I can play YouTube video’s with Firefox. Plus Chrome is able to play the XMRadio plus the Facebook video’s.
It would appear that the issue was me performing the upgrade late and not following the directions completely when adding the Packman Essential repo’s. Thank You for your time though.

The issue appears to be I forgot the final step of the process when adding the Packman repo’s. My only excuse was it was late after a long day. Thank You for your time and help though.

Thanks for the thank you –Yes, long days – including overshooting the maximum of 10 hours on site – Been there; done that … :wink:

[INDENT=2]Even worse – day shift and then on call either for the evening shift or, the night shift – telephone pager going off at 2 o’clock in the morning; try to remember to pull on some clothes, jump into the car, drive to the customer’s site, relieve a bleary-eyed colleague who had been working the issue since 7 o’clock in the evening …
[/INDENT]

All good. Glad to read it is now resolved. :slight_smile:

Been there, done that, as well! I wonder if there are more of us? Would one say that more than 10 of us is a brotherhood? LOL

Reasonably common for those of us working in the technical service sectors and supporting 24/7 SLAs. (I will be on call next week for example.)

Now retired, but still remembering the nights :frowning:

But also the feeling when in the end everything was running again. <:)

I had this problem and I tried clearing the cache data, and updating to the new version, and Facebook worked. However, I remarked, Meta’s FB, Intstagram social network is doing badly.