Extremely slow boot of Leap 42.1 from SSD over USB 3.0

Well, I don’t see anything wrong in that journalctl output.

But before you start to think I am crazy, and my system must be fine, look:

> sudo systemd-analyze time
Startup finished in 2.222s (kernel) + 18min 37.627s (initrd) + 11.459s (userspace) = 18min 51.309s

Am I the only person trying to do an installation on an external SSD over USB 3.0?

I’ve got it!

It was the SATA to USB3 adapter/converter! They are not all created equal.

I switched to a different SATA to USB3 adapter (Insignia) and all is good now!

Booting up in like 20 s or so from powered off to logged in to my session.


Thank you to everyone who taught me some interesting commands.

Now I have to figure out how to mark this thread solved …

Ok, I guess there is no way to mark it SOLVED.

And in reality - it isn’t really solved - in a perfect world there would be some message from the system saying that there is a problem with the SATA to USB hardware - and some way to override that message and boot up quickly with that hardware because it does work fine eventually - but that is asking a lot.

At least I found a way around it and I hope that this information can be of use to anyone else who encounters this problem in the future.

Glad you found it I’d not guessed that from here :open_mouth: