Extremely High CPU usage??

Ladies and Gentlemen,

I have a finding. As I said before, I use VMware to run Windows … a lot. Again, prior to this version I did not have the high CPU activity, unless I was doing some heavy work, which would be expected. It was, like it was/is supposed to be … another machine inside the same machine.

Now then, I’m sure you all know that. However, what you don’t know is how I have been “playing” with these toys. Way back when, about SuSE 6.2 and VMware 3.0 I created a Win2k machine that I tar’d and carried from one version to another. A whole Windows system in one file! During the VMware 3.5 versions I had to create a New Win2k machine and started carrying it from version to version. Still with VMware 3.5.9. However, we hit openSuSE 11.x and I had to update to VMware 7. Now then I still carried my Win2k from VMware 3.5.9 over to VMware 7. This scenario was carried on thru openSuSE 11.3.

So here we are in openSuSE 11.4 and I decided that I needed a “clean” Windows Desktop. I had stuff on there that I had forgotten why I got them. So, after installing VMware 7.1.3 and the patch needed, I installed a brand new copy of Windows 2k. From that point on I had High CPU usage. Why? Well, I don’t know … yet.

I have learned that it is NOT specific to openSuSE 11.4. I had wiped my previous 11.3 and installed 11.4. Since I now had two copies of 11.4 on my PC I decided to put 11.3 back on my machine … only in the Test Partition instead… replacing the test version of 11.4. I un-tar’d a copy of the “newest” Win2k that I had just created for 11.4 and installed in on 11.3. Guess what??? The same High CPU usage… only this was on 11.3. So I dumped that one and un-tar’d the Win2k that was used in openSuSE 11.3. Guess what??? No more High CPU usage!!! I’m sorry that I don’t know what the difference is … yet … but when/if I find out I will get back here and let everyone know. It seems that something has affected the re-install of Win2k … from scratch, so to speak. I really don’t know how or why they are different. I mean it is the same procedure now as it was 5 years ago.

If anyone has any ideas ... please pass them my way.  Again if/when I find something I will put it up here.  Till then it is a lot of head scratchin' (have to make sure I have used my Head and Shoulders). :P

Take care all,
Chuck

On 2011-03-20 03:36, chucktr wrote:
> If anyone has any ideas … please pass them my way. Again if/when
> I find something I will put it up here. Till then it is a lot of head
> scratchin’ (have to make sure I have used my Head and Shoulders). :stuck_out_tongue:

I have a thought I can’t clearly formulate, it is foggy.

If something in the new virtual machine is polling the system, the cpu
usage in the host skyrockets. Some types of emulated clock, I believe.
Mouse things, perhaps.

I remember once, when windows was simply waiting for me to login or press a
key or something (I don’t remember exactly) the cpu went to 100% in the host.

There may be clues in vmware documentation.


Cheers / Saludos,

Carlos E. R.
(from 11.2 x86_64 “Emerald” at Telcontar)

Bring up task manager in the VM and see if some process is being a hog from some reason. If the task manager reads cpu load as low, then look at VMware and see if maybe you are hitting swapping in the VM. When I say swapping, I mean the max memory limit you have set for all VM’s in VMware.

I once hit the max memory limit I set and that cause high load on one of my VM’s with swapping. I just raised the max mem limit for all VM’s and halved the memory allocated to that VM. Solved the problem. Also look at the VM swap preference in VMware settings for that VM.

Hello again,

Probably the final report.  May be a bit lengthy cause I need to explain and relate all the circumstances.  Or short if I can.  Watch what you read cause I am switching between openSuSE 11.3 and openSuSE 11.4.
  1. As stated, in the “Fresh” install, on openSuSE 11.4, of VMware 7.1.3 (with the patch) and then an install of Windows 2000, I experienced extremely high CPU usage. The main indication of this was by the CPU fan screaming (well it was loud).

  2. Suggested “fixes” were tried and only minor corrections were seen. Still to much CPU activity.

  3. Went back to openSuSE 11.3 did the same installation as above in 11.4 … HIGH CPU… acutally this was a copy of the one I had created in the openSuSE 11.4 VMware.

  4. Installed, in openSuSE 11.3, a “copy” of a previously used Win2k that I had tar’d. If you know about VMware you’ll know that it creates a vmware dir in your home dir … that contains dirs of all the Virtual Systems that you install. IF you have room you can tar up the individual dirs and save them for later. Eliminates a bunch of re-installing. That’s what I had done with an “older” Win2k setup. This “older” one DID NOT cause high CPU even under this newly installed VMware, in openSuSE 11.4.

  5. Puzzled… I started going over the installations. Then it hit me!! Somebody threw a brick, or should have, and got my brain working again. The Lord I think. Anyway, the “older” Win2k was installed on an “older” PC. One with a Single Processor with a Single Core. My “newest” PC has only one Processor -but- it has two cores. So, in my “infinite wisdom” I decided that I could set the VMware Virtual Machine for 2 cores, 512MB of RAM, 2 DVD’s and an 8GB hard disk… BEFORE the installation of Win2K…
    … ** Big Mistake**. …
    This will cause HIGH CPU usage. In fact IF I had paid attention to some of the things I read in various forums, I would have know that.

  6. Now then, for the initial install I used the “default” of 256MB of RAM, 1(one) Processor, 1(one) core and I reduced the default HD from 8GB to 6GB. The installation went smooth and fine. After finishing the OS worked great NO high CPU usage.

  7. Exited the Virtual Machine and edited the settings to increase the core count to 2 and the amount of RAM to 512MB. Restarted the Virtual Machine and the were NO high CPU problems. According to the CPU monitor Widget “both” cores are working and the total CPU stays below 60% most of the time. Even with VMware/Win2k running. I would expect to be able to use Homesite, edit Web pages and do it without the CPU fan howling all the time… or most of it anyway. I can now experience that again.

Thanks to all,
Chuck