Extrange problem with filesystem...


In a few days ago here, the SUSE presents the following problem:

I went to empty the trash, it is still a while and then said that it was not possible to delete the folder or file ‘x’ (x as a small example). But the most strange is that after displaying that message, the partition where is the ‘home’ and the folder ‘Trash-0’ (the trash folder) turn as read-only partition. I tried a procedure that is unmount and remount the partition where is the ‘home’ and other folders I have in the same partition for Samba and a variety of backups.

That procedure of unmount and remount the partition, for now works fine as a rw partition, but then I try to delete the folders and files that generate conflict, is again frozen and at times I have left the partition as read-only… And start again.

The user folders and files do not seem to have no problem and I am not returned to use this files, while not solve the problem. I do not want to delete them because they have very vital information.

My system is:

  • Chipset: nVidia MCP61

  • CPU: AMD Athlon 64X2 6000+

  • MEM: Kingston 2GB DDR2

  • VGA: ATI Radeon X1550


  • /dev/sda1: SWAP

  • /dev/sda2: ROOT (Reiserfs)

  • /dev/sda3: HOME (Reiserfs)

  • /dev/sda4: SRV (Reiserfs)

  • OS: openSUSE 11 - x86_64

As a precaution, I have the automount of the /home partition disabled. Any help would be very useful.


Camilo Bohórquez.
Bogotá (Colombia)

When I turn the machine a moment ago, I showed this message to attach as JPEG.


I hope I do not have to change the HD, as it does not take 6 months of having purchased.


Hi there!

Have you tried to login as root and delete the files from trash? I had a problem deleting files from trash, i solved it that way.


This could be your problem.
In kde, you can use file manager super user mode to navigate to your /home/user/Desktop

I don’t know the equivalent in gnome.

Post your /etc/fstab