Extract a config from running kernel

Carried over from the libata.force thread: libata force parameter

Now…I’m looking to extract a config from a working kernel…that much was pretty easy…all ya gotta do is “cp /proc/config.gz .” which will put it in whatever directory you’re currently in and then do a “gzip -d config.gz” to get the config file.

Now…after that it gets a bit tricky…Linus says you should never compile a kernel in /usr/src/ because those header files in …/include should never change. He says you should extract a new kernel gz in your home directory and compile it there. I tend to agree (who am I to argue?). Anyway…whereever your sources are this is where you need to copy the config file…

Like this…my home dir is “/home/dart”. So I would put the kernel sources there under “/home/dart/linux”. I would cd to /home/dart/linux and do “cp /proc/config.gz .” then “gzip -d config.gz” which should leave you with a file called “config”, then “mv config .config”

Now here’s where I run into a problem…when I do “make xconfig” I get this…

Windeath:/usr/src/linux # make xconfig

  • Unable to find the QT3 installation. Please make sure that
  • the QT3 development package is correctly installed and
  • either install pkg-config or set the QTDIR environment
  • variable to the correct location.

make[1]: *** No rule to make target scripts/kconfig/.tmp_qtcheck', needed by scripts/kconfig/qconf.o’. Stop.
make: *** [xconfig] Error 2

Tried to install the qt3-devel packages from CD but guess what? I ran into cdrom errors which is what I was trying to fix in the first **** place…catch 22 eh?

Refer to this thread…libata force parameter

Can you not “make menuconfig” instead?

Ya I could…but that’s not really the point is it?

I don’t know. I would say it is the point. It depends if you want to compile a kernel to fix you libata problem first or if you want to play with qt3 stuff.

The funny thing is…the 11.3 dvd I burned will be be detected and mount…the 11.2 dvd I burned on the same day…the same way…won’t. Problem is 11.3 programs won’t install on my 11.1 installation and 11.3 absolutely won’t update for me…not with the installation CD or the Live CD. Not that I would want to anyway with all the problems I’ve been reading about…Seriously…I never had anywhere near this many problems with Mandriva. Now that I got a fast connection I’m about ready to try Gentoo and compile everything myself. Don’t even mention RedHat…I haven’t done them since before 2000…

My advice, whether you want it or not…Suse really needs to take a step back and iron out all the wrinkles. Like my drill seargent used to say “you can’t get the wrinkles out of the top sheet till you get the wrinkles out of the bottom one”…I tried Suse because Linus said it’s what he used and quite frankly I’m very disappointed…

Ok then…I could plod my way through an archaic, mind-numbing, pre-historic configuration system OR try to fix a qt3 problem (which I tried to do and failed) that shouldn’t have been a problem anyway…hmmm