external USB drive dilema

I have a 200GB external drive formerly used by a mac with time machine.

I plug it in to my Linux laptop via the USB port and it sees it fine. But it tells me, (even as root) I don’t have permission to access or erase the data.
I want to format it to be used by my Linux laptop for whatever!
Where can I find that info? I want to format that drive with my Linux laptop. Don’t laugh to hard, I am lost here.


Hello riberto,

I do not know what you already tried. Did you try to use the yast

Delete the old file system on the external drive and make a new one, I guess
this is the easiest solution.

!!! Please be very careful that you select your external hard drive and not
your main hard disk.

When you do not need any data present on the disk, martin_helm’s advice might be the best solution to use the disk in your system.

When you want to access the existing file system/data on it, you must be aware what sort of file system it is and if it is supported bby openSUSE.

To see if it is mounted at all do


Thanks so much guys!

I did use the partitioning option.

It did partition the drive, so it got wiped out! (its ok!)

But I still cant use it with linux?
I am either NOT authorized or it can’t be accessed???
By the way, the partition program did mess up my regular drive. But the install DVD fixed it for me.


Once more,

T H A N K S !!

It is strange because if you change partition for a external drive it cannot
affect you internal harddisk at all.

Did you by accident change something on your internal drive?

What filesystem did you chose for the external drive, did you select to
delete the existing partitions on it then created a new one and format it or
did you something else?

Maybe you can describe your steps in detail so that we can help you to see
why it is not mounted.

You have to create a file system on that drive if it is not created already. Please post the output of the following:

fdisk -l

And adding to syampillai’s question, you said that you used YaST partitioner, but that gives a lot of options. As long as we do not have crystal balls to look what you are doing, can you please give more hard information in your posts?

Did you:
. make one or more partitions;
. let them format to what time of filesystem (or not);
. let them be mounted where (or not).

Apart from the *fdisk -l *output and answerr to the above, please also the output of:


Here is where I get in TROUBLE!

I followed your directions and it all worked.
It was NOT till I switched from the Kubuntu laptop to my OpenSuse laptop that it all clicked!!

I guess the laptop was just stuck in lala land???

I see the drive just great now, I plugged it to my wifi base and my whole network sees it too.
I am now exploring and learning how to do over the air (WiFi) back-ups.
I see a NOS in my future!

Thanks a billion guys!!!


Congrats :slight_smile: