External Monitor Resolution too low...

I’m running OpenSuSE 11.0 on a Dell D630 with a Intel 965 graphics. Everything is working fine (dualhead, Xinerama, 1280x800 on the laptop screen, etc), except that 1024x768 is the max resolution I’ve been able to attain on the external monitor. http://forums.opensuse.org/images/smiliesnew/sad.png

The xorg.conf file has been modified to include Virtual settings, and the mode, 1280x1024, in the Screen, Display subsection.

I’ve renamed and run sax2 from init 3 multiple times without being able to change the remote screen any higher than 1024x768.

This is frustrating because I know it will work with the higher resolution…it did work properly once before, but lost the settings when I attempted to work with OpenSuSE 11.1 for a few days.

Any help would be appreciated.



I’m having a similar problem on my Toshiba Tecra A10.
The laptop screen shows 1280x800 without problems.

At the office, I have an external HP LP2465 with native resolution of 1920x1200.

Vista (ugh) has no problems driving both laptop and external at their native resolutions.
A few colleagues are running Ubuntu on their laptops (Dell mostly) and have no problems either.

However, on my OpenSuse 11.1, the maximum resolution for the external monitor is 1152x720.

I’ve looked in Sax2 to select the correct monitor, but the HP LP2465 isn’t there.
I tried the ‘LCD 1920x1200’ but still the maximum resolution is the one mentioned above.

I also tried modifying xorg.conf, but to no avail.

Can anyone help ?

kind regards,


I have the same problem. Unfortunately, it appears to be a common problem with Intel Integrated Graphics. I have not managed to get more than 1024x768 on my external monitor (which is capable of 1600x1200).

I am half thinking of trying Ubuntu. I have always had reasonable success with Ubuntu and dual monitors.

Today I found something which looks promising, somewhere on the net…

Dual monitor on intel 945 - Linux Forums

Have a look at replies 5 & 7 by reveil.
Haven’t tried it out though. Will try on monday to see if it works.
I’ll also try the Ubuntu live-cd to see if that makes any difference.

Hi zak89

Post your current xorg.conf file. Have you tried manual mode entries for external monitor. I have heard that EDID does not work correctly for all hardware, so often the maximum resolution (especially for external monitors) is not used. I’m assuming it is connected via VGA port? What does xrandr -q report (with ext monitor plugged in)?

Have a look at this page for a possible insight on this.