External HDMI monitor not detected because wrong GPU is being used


I recently installed openSUSE on an lenonvo idepad gaming 3 laptop which has two GPU:s, a GTX 1650 TI and the integrated graphics of the Ryzen CPU. I was struggling with drivers for the NVIDIA card but I think they are installed properly now. However external monitors are still not recognized if i plug them in via HDMI and goes to “Display Configuration”. The monitor gets no signal at all. I suspect that the HDMI might be connected directly to the NVIDIA card and that the card is not being used by the OS. Is there a way to verify this and if necessary switch to using the GTX 1650 TI?

If i run:

glxinfo|egrep "OpenGL vendor|OpenGL renderer"

the output is:

**OpenGL vendor** string: AMD 
**OpenGL renderer** string: AMD RENOIR (DRM 3.41.0, 5.13.1-1-default, LLVM 12.0.0)

Which i assume means that the integrated CPU-graphics is running the show?

If you open a terminal and run the commands, what is the output?

/sbin/lspci -nnk | egrep -A3 "VGA|Display|3D"
xrandr --listproviders

The response is:

01:00.0 **VGA** compatible controller [0300]: NVIDIA Corporation TU117M [GeForce GTX 1650 Ti Mobile] [10de:1f95] (rev a1) 
        Subsystem: Lenovo Device [17aa:3a44] 
        Kernel driver in use: nvidia 
        Kernel modules: nouveau, nvidia_drm, nvidia 
05:00.0 **VGA** compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Renoir [1002:1636] (rev c7) 
        Subsystem: Lenovo Device [17aa:3a44] 
        Kernel driver in use: amdgpu 
        Kernel modules: amdgpu


Providers: number : 1 
Provider 0: id: 0x54; cap: 0xf (Source Output, Sink Output, Source Offload, Sink Offload); crtcs: 4; outputs: 1; associated providers
: 0; name: Unknown AMD Radeon GPU @ pci:0000:05:00.0 
    output eDP

The problem was solved by getting suse-prime via: https://software.opensuse.org/package/suse-prime
And then running: sudo prime-select nvidia

I guess it could be done in a cleaner way by adding repo in YaST so that it could find package.

I hope this is a permanent switch that won’t revert after reboot.

Thank you very much malcolmlewis for engaging in my thread.

Suse-prime is not available for Leap 15.3?