External HDD Won't Automount. Help.

Hey. I’m attempting to mount my HDD, but i keep getting this message:

Error mounting /dev/sdb1 at /run/media/nenad/Nikolina HDD: Command-line `mount -t "ntfs" -o "uhelper=udisks2,nodev,nosuid,uid=1000,gid=100,dmask=0077,fmask=0177" "/dev/sdb1" "/run/media/nenad/Nikolina HDD"' exited with non-zero exit status 13: $MFTMirr does not match $MFT (record 0).
Failed to mount '/dev/sdb1': Input/output error
NTFS is either inconsistent, or there is a hardware fault, or it's a
SoftRAID/FakeRAID hardware. In the first case run chkdsk /f on Windows
then reboot into Windows twice. The usage of the /f parameter is very
important! If the device is a SoftRAID/FakeRAID then first activate
it and mount a different device under the /dev/mapper/ directory, (e.g.
/dev/mapper/nvidia_eahaabcc1). Please see the 'dmraid' documentation
for more details.

Please help :frowning:


nenad@openSUSE:~> cat /etc/fstab
/dev/disk/by-id/ata-Hitachi_HTS545050B9A300_091111PB4406Q7JHGR4A-part3 swap                 swap       defaults              0 0
/dev/disk/by-id/ata-Hitachi_HTS545050B9A300_091111PB4406Q7JHGR4A-part1 /                    ext4       acl,user_xattr        1 1
/dev/disk/by-id/ata-Hitachi_HTS545050B9A300_091111PB4406Q7JHGR4A-part2 /home                ext4       acl,user_xattr        1 2

and that’s with the hdd plugged in.

Well, have you tried to “run chkdsk /f on Windows then reboot into Windows twice”, as the message suggests?
Or maybe “ntfsfix” in Linux (package “ntfsprogs” in openSUSE) might work as well.

The filesystem seems to be corrupted.
It could be caused by your hard drive dying as well, so better have a look at the kernel log (dmesg) whether there’s mention of read/write errors, and the output of “smartctl -a” (although this might not work with your particular external drive).

It’s been removed from a Windows box without “Safely remove hardware” and it has left the NTFS in an inconsistent state.

Plug the hard drive to Windows, run chkdsk on it and safely remove it.

Worked! (though i had to use my gf’s computer as i don’t use win, it’s her HD.)

Thank you!