External HDD won't auto-mount

I put a line in fstab,

sdb1                 /media/fantomext     auto       auto                  0 0

edited the PolicyKit rule, and even set sdb1 to mount to /media/fantomext in YaST (“Do Not Mount at System Start-up” is unchecked). But despite all this, it’s still not automatically mounting. What’s going on here? :?

Because sdb1 does not exist on your system (except when your working directory happens to be /dev, which is not the case during the usage of /etc/fstab). Most probably* /dev/sdb1* does.

This may give you more info on the subject: SDB:Basics of partitions, filesystems, mount points - openSUSE

And reading man fstab might also tell you the use of the fields in /etc/fstab. The third field (the first *auto *you have) must be the fstype. Now the man fstab page refers to man mount for this. There it says that when *auto *it tries to guess … Better fill in what it is, so there is no guessing. And when you know what it is, you also know better what mount options (the fourth field) are valid for this fstype.

Huh. Now it mounts, but it’s only accessible to root. Guess I’ve gotta look at the manual. What fun.

I did it! I’ve never really used man before. I’ve known about it, but… It’s actually useful and thorough.

As it turns out, ntfs by default is only accessible by root, for whatever reason. So I had to use the option uid=1000 (my UID). (Root would be uid=0)

Man, I really wish I could edit posts… Or at least for an hour after the posting. Oh well.

Anyway, here’s my problem now. Though I have access to the drive… Dolphin can open it and I can view files, but I can’t, say, copy a file from my desktop to the external, I get a permission error. So it’s read-only…

uid=value, gid=value and umask=value
       Set  the  file  permission on the filesystem.  The umask value is given in octal.  By default, the files are owned by root and not readable by somebody else.

Let’s see…

Well, this is odd. YaST won’t let me add rw to the fstab options… I get error code -3039, which I can’t find any useful info on. Any ideas? I’m stumped. External is still not writable other than by root.

YAOMTC wrote:
> I did it! I’ve never really used man before. I’ve known about it, but…
> It’s actually useful and thorough.

congratualtions, you are on your way to Linux Greatness!

Give a hacker a fish and you feed him for a day.
Teach man and you feed him for a lifetime.

Didn’t notice my more recent posts, eh? Stopped at that one?

AFAIK for NTFS it’s better to use ‘ntfs-3g’ instead of ‘auto’. See what happens if you make this line in /etc/fstab

/dev/sdb1 /media/fantomext ntfs-3g rw, uid=1000 0 0

Please ‘man ntfs-3g’ for more options.

Ah, that did it. I had put the same line in there yesterday (before trying YaST), except I used ntfs instead of ntfs-3g. It works great now, thanks! :smiley: