External HDD Recovery Effort - Need Help Understanding TestDisk Results...

Hello all,
I am trying to recover my LaCie External 500GB HDD which seems to be corrupted after a misfortunate event. I was copying a large file to it and the computer crashed and I was forced to manually restart the computer. Now on plugging the drive in to my Windows PC I get the error “Windows needs to format drive K: before you can use it” or something like that, and when I plug it into my MacBook I get the error message “The disk you inserted was not readable by this computer”. I have been running test disk to attempt to recover the drive and the data on it, and I need help understanding what all the results I’ve come up with mean, and if it’s actually possible to fix it? I have tried various different routes and have taken screenshots of everything, which I will post.
Any help would be massively appreciated.

(This drive was not backed up because it was the biggest drive I owned)

Following are the steps I took on TestDisk and what it showed…
Obviously I selected my Hard Drive and pressed Enter, then I selected Intel/PC because thats what it said the partition type was.
Then I get to the first window.

So I pressed “Advanced” and got this next window.

I When I pressed “List” all I got was a screen that says this: “Can’t open filesystem. Filesystem seems damaged.”

Not very good… So I pressed “Quit” and returned to the previous menu where instead I pressed “Boot”.
This is what I got:

This is where I got confused. I really have no idea what all those “warnings” mean. However as my next move I pressed “Dump” because I knew what that meant. When I pressed that I got something a little interesting…
It showed me my boot sector and backup boot sector dump, but as I scrolled to the bottom I noticed something strange.
It looked like this:

Now you’ll notice if you string all that together it says this: “A disk read error occurred… NTLDR is compressed… Press Ctrl+Alt+Del to restart…” Now I thought that was quite strange. I looked up what the “NTLDR” was and apparently it’s a problem to do with an operating system, correct? There is no operating system on my external hard drive is there? Or is that the problem?

I really need help to understand this all, and whether its possible to fix my poor LaCie hard drive.
Thanks, Trent.

Boot windows in to the shell and run

chkdsk /f

I just tried that… It came up with an error message saying: “Data error <cyclic redundancy check>”

Any ideas?

See if there is any useful info here

Yes I agree with you, your hard disk might be corrupted. To recover your data from corrupted hard disk you can give a try to Remo Recover utility. 2 days ago my friend recovered all his data from damaged hard drive after employing Remo Recover tool. May be it will aid you also.

I have a new PC so saved all my files to my external hard drive and set it up, decided to mak a backup imediately and without thinking saved it to my external harddrive - now it only shows that and none of the files I have written over the lst 7 years! HELP!

You need to explain yourself a little more clearly.
Also tell us what Operating System you are using and what your were using to write a backup?

If you over wrote the files they are gone but if you are just copying files that should not be a problem.

Tell use exactly what you did what format the drive had and what program you used