External HDD not mounting

Hello there, I have found one very odd thing with my external HDD. I am currently using Tumbleweed with GNOME 45. But since the update to GNOME 45 I get this screenshotted message when I attempt to mount the external HDD:
Screenshot from 2023-11-05 13-51-59

It was working fine with GNOME 44, and I tried it on my daughters laptop that has POP!OS and it worked fine. So just wondering and hoping that it is an easy fix.

In terms of hardward, the laptop I am using is a Lenovo Thinkpad 320-15AST, 16GB RAM and AMD A6-9220 RADEON R4, 5 COMPUTE CORES 2C+3G × 2

How do you try to mount the drive? Show the terminal command you are using…

As you see it mutters about unknown file system and the like.

It mentions /dev/sdb1, thus it has )at least) one partition. But what is supposed to be on there?

And of course, getting rid of all the stuff a desktop environment adds to the game, what if you simply try to mount it (as root)

mount /dev/sdb1 /mnt

I assume all he shows and tells is about a mount with help of the DE (Gnome in this case), thus no command involved. But yes

is rather vague and describes no real technical details.

@judasdisciple I suspect it has not been unmounted properly. If as root user run a file system check against /dev/sdb1. Also check the output from journalctl -f while mounting to see if any more information.

Also what filesystem is it on /dev/sdb1…?

I actually only tried using Nautilus. I have not tried to do it via the terminal

Admittedly my terminal game is very much off. But when I do the ‘journalctl -f’ I get this output:

Nov 05 14:27:40 localhost.localdomain dbus-daemon[1683]: [session uid=1000 pid=1683] Activating via systemd: service name=‘org.gnome.Terminal’ unit=‘gnome-terminal-server.service’ requested by ‘:1.99’ (uid=1000 pid=4837 comm=“/usr/bin/nautilus --gapplication-service”)
Nov 05 14:27:40 localhost.localdomain systemd[1531]: Created slice Slice /app/org.gnome.Terminal.
Nov 05 14:27:40 localhost.localdomain systemd[1531]: Starting GNOME Terminal Server…
Nov 05 14:27:40 localhost.localdomain dbus-daemon[1683]: [session uid=1000 pid=1683] Successfully activated service ‘org.gnome.Terminal’
Nov 05 14:27:40 localhost.localdomain systemd[1531]: Started GNOME Terminal Server.
Nov 05 14:27:41 localhost.localdomain systemd[1531]: Started VTE child process 6317 launched by gnome-terminal-server process 6297.
Nov 05 14:27:48 localhost.localdomain su[6341]: The gnome keyring socket is not owned with the same credentials as the user login: /run/user/1000/keyring/control
Nov 05 14:27:48 localhost.localdomain su[6341]: gkr-pam: couldn’t unlock the login keyring.
Nov 05 14:27:48 localhost.localdomain su[6341]: (to root) ingvar on pts/0
Nov 05 14:27:48 localhost.localdomain su[6341]: pam_unix(su:session): session opened for user root(uid=0) by ingvar(uid=1000)

Nice answer, but you could have told also what is on there (which file system type) and what when you do mount it on the terminal.

Ah, I see. Apologies, my terminal usage tends to be limited to zypper dup. The HDD was formatted using FAT32, if memory serves me correctly. When I try

mount /dev/sdb1

I get

mount: /dev/sdb1: can't find in /etc/fstab.

Oh, and please when posting computer text (from the terminal) do not use the Blockquote " button, but the Preformatted text</> button just next at the right of it.

Will do. Haven’t actually used this forum since it updated to this setting, so again just familiarising myself with it all.

That was NOT what I suggested. Mu suggestion included a mount point. And now mount tries to find that in an /etc/fstab entry, which does of course not exist.

So please trye again

mount /dev/sdb1 /mnt

And do not split when you copy paste (with the superfluous comment “I get” in between). Only one copy sweep is needed and that should include the prompt/command line, all output and the new prompt line.

In that case, Malcolm’s suggestion that it may not be properly removed from a MS Windows system might be true. Thus connect it to such a system (I hope one is available), and then “remove savely”.

will have to wait until I’m at work. Tried again: localhost:/home/ingvar # mount /dev/sdb1 /mnt mount: /mnt: special device /dev/sdb1 does not exist. dmesg(1) may have more information after failed mount system call.

@judasdisciple and the device is plugged in? Just check that it is sdb from the output of the command lsblk. I suspect it just needs a filesystem check…

Definitely plugged in. When I did the journalctl -fI unplugged it and plugged it in again and got the following

Nov 05 14:50:12 localhost.localdomain kernel: sd 2:0:0:0: [sdc] Synchronizing SCSI cache
Nov 05 14:50:12 localhost.localdomain kernel: sd 2:0:0:0: [sdc] Synchronize Cache(10) failed: Result: hostbyte=DID_ERROR driverbyte=DRIVER_OK
Nov 05 14:50:20 localhost.localdomain kernel: usb 3-1: new SuperSpeed USB device number 6 using xhci_hcd
Nov 05 14:50:20 localhost.localdomain kernel: usb 3-1: New USB device found, idVendor=0bc2, idProduct=231b, bcdDevice=18.05
Nov 05 14:50:20 localhost.localdomain kernel: usb 3-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
Nov 05 14:50:20 localhost.localdomain kernel: usb 3-1: Product: Expansion
Nov 05 14:50:20 localhost.localdomain kernel: usb 3-1: Manufacturer: Seagate
Nov 05 14:50:20 localhost.localdomain kernel: usb 3-1: SerialNumber: NA8N3LR8
Nov 05 14:50:20 localhost.localdomain kernel: scsi host2: uas
Nov 05 14:50:20 localhost.localdomain kernel: scsi 2:0:0:0: Direct-Access     Seagate  Expansion        1805 PQ: 0 ANSI: 6
Nov 05 14:50:20 localhost.localdomain kernel: sd 2:0:0:0: Attached scsi generic sg1 type 0
Nov 05 14:50:20 localhost.localdomain mtp-probe[9050]: checking bus 3, device 6: "/sys/devices/pci0000:00/0000:00:10.0/usb3/3-1"
Nov 05 14:50:20 localhost.localdomain mtp-probe[9050]: bus: 3, device: 6 was not an MTP device
Nov 05 14:50:21 localhost.localdomain mtp-probe[9075]: checking bus 3, device 6: "/sys/devices/pci0000:00/0000:00:10.0/usb3/3-1"
Nov 05 14:50:21 localhost.localdomain mtp-probe[9075]: bus: 3, device: 6 was not an MTP device
Nov 05 14:50:23 localhost.localdomain kernel: sd 2:0:0:0: [sdc] 1953525167 512-byte logical blocks: (1.00 TB/932 GiB)
Nov 05 14:50:23 localhost.localdomain kernel: sd 2:0:0:0: [sdc] 4096-byte physical blocks
Nov 05 14:50:23 localhost.localdomain kernel: sd 2:0:0:0: [sdc] Write Protect is off
Nov 05 14:50:23 localhost.localdomain kernel: sd 2:0:0:0: [sdc] Mode Sense: 53 00 00 08
Nov 05 14:50:23 localhost.localdomain kernel: sd 2:0:0:0: [sdc] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
Nov 05 14:50:23 localhost.localdomain kernel: sd 2:0:0:0: [sdc] Preferred minimum I/O size 4096 bytes
Nov 05 14:50:23 localhost.localdomain kernel: sd 2:0:0:0: [sdc] Optimal transfer size 33553920 bytes not a multiple of preferred minimum block size (4096 bytes)
Nov 05 14:50:23 localhost.localdomain kernel:  sdc: sdc1
Nov 05 14:50:23 localhost.localdomain kernel: sd 2:0:0:0: [sdc] Attached SCSI disk
Nov 05 14:50:24 localhost.localdomain kernel: ntfs3: sdc1: It is recommened to use chkdsk.
Nov 05 14:50:24 localhost.localdomain kernel: ntfs3: sdc1: volume is dirty and "force" flag is not set!
Nov 05 14:50:24 localhost.localdomain gnome-shell[1946]: Unable to mount volume Seagate Expansion Drive: Gio.IOErrorEnum: Error mounting /dev/sdc1 at /run/media/ingvar/Seagate Expansion Drive: wrong fs type, bad option, bad superblock on /dev/sdc1, missing codepage or helper program, or other error

Did you try to read your own post? It is unreadable.

As was already suggested earlier, it was not cleanly unmounted. Maybe it was just unplugged instead of “safely removed” in Windows. The most easy way is to plug it in in Windows and then to properly remove.

Very clear what the issue is from the output…

Honestly, I don’t use the terminal very often so I often find it a little difficult to understand. But thank you for your patience, it is appreciated. Will see what happens when I plug it into a Windows machine next time I am actually at work.

But what I don’t understand why it is that is still worked on my childs laptop without any of these issues.

Hi.

All ok but user tell us he can do that in Gnome 44 and other distros. So this is a little bug because this should be included in the release notes: GNOME Release Notes

I have an external HDD with NTFS for using in Windows machines. All times Windows insists in chkdsk needs but ever time I can use it anyway. And never got an issue in Plasma Desktop.

So the question may be changed by "how can user got their disk mounted in Nautilus on GNOME 45 without modify /etc/fstab??

1 Like