External hardrive mount problem

Hi all, am having this problem when trying to mount my external 500g hdd (usb). I have used this before with no problems, and now all of a sudden i cannot mount the filesystem, what is going on?

This is the error message that i get through dolphin. Just thinking about this, there was a udisk update that i downloaded just the other day, could this have something to do with it?

An error occurred while accessing ‘Iomega’, the system responded: org.freedesktop.UDisks.Error.Failed: Requested filesystem type is neither well-known nor in /proc/filesystems nor in /etc/filesystems

Am using 11.4

Could it be the same as this
Installed Kernel Updates, now get error when mounting USB stick. Why?


I fixed this by adding “ntfs” to /etc/filesystems

Regards, Tony

hey many thanks, that worked :slight_smile:

Cheers, that solved it for me too.

I was a victim of this abstraction, too. “ntfs” worked alright. Thanks!

Thank You. Had the same problem and can confirm the solution just works.

Best regards,