External Hard Drives--How to locate and mount

Newbie question.

I have an external Western Digital Hard drive connected via IEEE1394 (FireWire).

When I look in YaST2>>Hardware>>Hardware Info, I can see it attached, but it doesn’t show up anywhere else (desktop, folders, etc…)

How do I locate it otherwise, mount it, and access it.

It’s formatted in HFS+ (which I know could be a problem) but some sites suggest it can be done.

the same issue occurs when I plug my Blackberry in via USB…I can see it in the Hardware tree, but don’t know how to access it.

Any help would be excellent…

I love CLI!

What happens if you plug a USB memory stick into a port?

Just plugged one in and got this error message:

*Failed to mount “KINGSTON”.

org.freedesktop.hal.storage.mount-removable no ← (action, result).*

Trying another one gives the same error.

I’m installing the PolicyKit Development package…just a hunch from the HAL site.

But, oddly enough it does show an icon on my desktop, which is not the same for the my Western Digital and Blackberry.

The icon remains and will not mount or eject…goes away after unplugging USB Stick.

good; did you install 11.1 from a liveCD?

and this thread


is active in the forum; you may feel it useful to check through it too

I’m not sure…if “Live” is the option where you can install into the RAM of another operating system? then No…I went full steam ahead, downloaded the iso and burned it to a DVD, and started my linux/openSUSE adventure.:wink:

Funny you should post that thread above…I just left there and it seemed an unresolved issue. Do you know if it has been resolved elsewhere?

No; I hadn’t read through every thread of it;

did you install the Policy kit installs?

once you have those installed, interesting to first see if you can plug a USB memory stick in and get it recognised; Suse 9.3 was about the first of the Suse iterations to offer recognition on plug-in;

Pulled away to another thread on the same issue…

I installed th PolicyKit and updated through zypper just to be sure , but no change.

It may have something to do with built in security features of the HAL daemon…not sure. More reading to do.

Problem persists…

Someone suggested switching to Gnome, but Xfce4.4 is so zippy and I just migrated from OS X …what a difference…and the adventure!

There has to be a solution.


And in fact here is a part of the answer…

Here’s the site:

Need A Little Hal/policykit Help - openSUSE Forums

PolicyKit is very new, as it turns out and you have to add these lines to the PolicyKit.conf file located at: /etc/PolicyKit/PolicyKit.conf

*<match user="(my user name)">
*<return result=“yes”/>

Put them between the <config version=“0.1”> and </config> lines.

Replace what is in the quotes with your user name.rotfl!

Now the USB devices are recognized and allowed…not sure about Firewire yet.

so you are confirming that by editing as you describe;

that you now can read and write to your external hard drives?

Yes the external drives that connect via USB will mount automatically when plugged in and I can access all information on them.

The Firewire drive is still not recognized at all…

It has an alternate USB 2.0 option for connecting it, so I will try that route…and post back the results.

Any more ideas are welcome.

Connecting it via USB will mount and read the contents of the drive but gives one error message per “part”. All of the error message panels can be closed and then the drive is accessible as a READ ONLY drive.

*Failed to mount “/org/freedesktop/Hal/devices/volume_part4_size_28672”.

Given device “/org/freedesktop/Hal/devices/volume_part4_size_28672” is not a volume or drive.*

Could this read only status have to do with the HFS+ Partition?

Other messages related to this same external firewire drive which is now connected via USB 2.0.
After closing all of the error messages that announce the inability of each “part” to successfully mount, I get this message:

Failed to mount “fireWire”.
Mount operation claims to be successfull, but kernel doesn’t list the volume as mounted.

—AND when trying to eject the drive—

Unable to eject “fireWire”:
Device to unmount is not in /media/.hal-mtab so it is not mounted by HAL

be careful here; you are now straddled across two posts, and the same sort of topic:

maybe settle on one?

USB: now you have to make the user have write ability to the drives;

FIREWIRE: something else here I do not know about; by contrast I plugged an external drive into our 10.2 system two years ago and it … worked fine … but I would have had to change ownership I am sure; (ie root seems to grab ownership initially)

when logged into this forum, use the search at the top of the page to search on “external hard drives” and something like read write ownership; I ended up using a GUI method, and others advocate a CLI (terminal) method;

must dash; will follow later

Got it! Closed my discussion on the other thread and redirected attention here.


Once I gave up the idea that openSUSE 11.1 and I were going to meet up successfully regarding the firewire connection.

I plugged the drive into the USB.

I logged in as root and copied the necessary files to my internal hard drive.

Logged out and logged in as user.

Reformatted the disk as ext3, using the command: *mkfs.ext3 /dev/sdb
Used the command: chown -R <username>:users <mount point> (fill in the desired user name and mount point)

Now I have read and write access to the disk.

How can I set the mount point as something different from the one selected by the system at boot-up? right now it mounts to /media/disk-1.

I am still getting the following error message when I try to eject the disk.

*Unable to eject “500G Volume”:

Cannot spawn /bin/eject*

gosh you are doing well; you have effortlessly leaped across several large fences and got things done;

I never bother to eject a drive: I think that is a Mac thing? With Suse, I just turn them off (meaning external USB hard drives); and memory sticks, I just pull them out when I have finished copying to them; seems fine on Suse;

when you say

How can I set the mount point as something different from the one selected by the system at boot-up?

why do you want to change it, and to what?

my understanding is that these devices are set differently to hard drives in your system; so the /etc/fstab file will list permanently mounted drives and their mount points; whereas ext USB drives; (that I think of as essentially the same as a memory stick); can be plugged in and out;

I lay this out; so that I can be corrected by others if necessary