External hard drive not in device notifier

Hello all,

I have bought an HD dockingstation from Sharkoon: SATA QuickPort Duo USB3.0 -v.2- | SHARKOON Technologies GmbH

It is connected to a USB3 port of my pc. When I insert a hd formatted with ext4 (for backup reasons) and switch on the power of the dockingstation, nothing happens.
Usually, when I insert an USB-pen (formatted with FAT32), the device notifier pops up and I’m able to access the content.
With the dockingstation, the device notifier doesn’t pop up and when I open the device notifier manually, it’s empty (no devices).

However, when I open Dolphin, I see a new device on the left. When I right-click on the new device, I have the option the mount it.
So, I mount the new device. Than it asks me for the root-password. I enter the root-password. Now I can access the device.

I have the following questions:

  1. why does the external harddrive not appear in the device notifier?

  2. why does the system discriminate between usb-sticks and external harddrives?

  3. why do I need to enter the root password in order to access the external harddrive but NOT for an USB-stick?

  4. can I configure the system in such a way that it treats external harddrives in the same way as a USB-stick?

I’m using openSUSE 12.2 and KDE 4.8.5.

Best regards.

I guess we need some information from the system. Like what does dmesg say when you switch the device on.
What does

lsusb

say about the device?
Does udev create device files?

ls -l /dev/disk/*

And about the disk. Does it have only one partition? Does the ext4 file system you mention a volume label?

But I agree that I do not completely understand why this device, that apperently at least “somewhere” is recognised as a storage device (else Dolphin would not get signalled it’s existance by the system), is not shown in the device notifier (like Dolphon only an application that likes to get signalled by the system about storage device connection).

Again a guess, I see logic in the fact that the device can not be mounted by the end-user’s desktop application and the fact that the device notifier does not notify. After all, why should it notify the end-user that there is a storage device (s)he can not mount?

The output of dmesg:


 3203.720693] usb 2-5: new high-speed USB device number 4 using ehci_hcd
 3203.836064] usb 2-5: New USB device found, idVendor=152d, idProduct=0551
 3203.836073] usb 2-5: New USB device strings: Mfr=10, Product=11, SerialNumber=5
 3203.836080] usb 2-5: Product: USB3.0 to SATA Bridge
 3203.836086] usb 2-5: Manufacturer: JMicron
 3203.836090] usb 2-5: SerialNumber: 961DFFFFFFFF
 3203.837215] scsi7 : usb-storage 2-5:1.0
 3204.840880] scsi 7:0:0:0: Direct-Access     ST350032 0AS              0000 PQ: 0 ANSI: 2 CCS
 3204.841327] sd 7:0:0:0: Attached scsi generic sg3 type 0
 3204.842609] sd 7:0:0:0: [sdc] 976773168 512-byte logical blocks: (500 GB/465 GiB)
 3204.843494] sd 7:0:0:0: [sdc] Write Protect is off
 3204.843505] sd 7:0:0:0: [sdc] Mode Sense: 28 00 00 00
 3204.845348] sd 7:0:0:0: [sdc] No Caching mode page present
 3204.845351] sd 7:0:0:0: [sdc] Assuming drive cache: write through
 3204.848710] sd 7:0:0:0: [sdc] No Caching mode page present
 3204.848719] sd 7:0:0:0: [sdc] Assuming drive cache: write through
 3205.147650]  sdc: sdc1 sdc2 sdc3 sdc4
 3205.151142] sd 7:0:0:0: [sdc] No Caching mode page present
 3205.151150] sd 7:0:0:0: [sdc] Assuming drive cache: write through
 3205.151158] sd 7:0:0:0: [sdc] Attached SCSI disk

The partition:

/dev/sdc1 1 GB Swap
/dev/sdc2 30 Gb Ext4
/dev/sdc3 400 GB Ext3
/dev/sdc4 30 GB Ext4

When I attach my USB-stick, the output of dmesg is:

 3006.338725] usb 2-5: new high-speed USB device number 3 using ehci_hcd
 3006.454148] usb 2-5: New USB device found, idVendor=1b1c, idProduct=1a09
 3006.454158] usb 2-5: New USB device strings: Mfr=1, Product=2, SerialNumber=3
 3006.454165] usb 2-5: Product: Voyager GT 3.0
 3006.454170] usb 2-5: Manufacturer: Corsair
 3006.454175] usb 2-5: SerialNumber: 22112816450000010070
 3006.499053] Initializing USB Mass Storage driver...
 3006.499647] scsi6 : usb-storage 2-5:1.0
 3006.499815] usbcore: registered new interface driver usb-storage
 3006.499820] USB Mass Storage support registered.
 3007.501323] scsi 6:0:0:0: Direct-Access     Corsair  Voyager GT 3.0   1.00 PQ: 0 ANSI: 4
 3007.501739] sd 6:0:0:0: Attached scsi generic sg3 type 0
 3007.503124] sd 6:0:0:0: [sdc] 62607360 512-byte logical blocks: (32.0 GB/29.8 GiB)
 3007.503617] sd 6:0:0:0: [sdc] Write Protect is off
 3007.503627] sd 6:0:0:0: [sdc] Mode Sense: bf 00 00 00
 3007.504053] sd 6:0:0:0: [sdc] Write cache: disabled, read cache: enabled, doesn't support DPO or FUA
 3007.508124]  sdc: sdc1
 3007.511094] sd 6:0:0:0: [sdc] Attached SCSI removable disk

The partion:

/dev/sdc 29.85 GB Corsair Voyager GT 3.0
/dev/sdc1 29.85 GB WIN95 FAT32 LBA FAT CORSAIR

OK, we got the relevant dmesg output, which shows that in both cases a mass storage device (disk) is found.

But I asked for more. I guess that the lsusb is not needed anymore, but the

ls -l /dev/disk/*

is still missing.

And I see you try to tell something about the partitioning (wehich is good), but we almost never trust stories. We then prefer the output of

fdisk -l /dev/sdc
  1. why does the external harddrive not appear in the device notifier?

I’m also using openSUSE 12.2 and KDE 4.8.5, and do not experience this behaviour. My USB hard drive is notified in the same way as my USB memory stick.

  1. why does the system discriminate between usb-sticks and external harddrives?

I don’t know that it necessarily does, although udev may play a part.

  1. why do I need to enter the root password in order to access the external harddrive but NOT for an USB-stick?]

I don’t have to do this. My HD is partitioned with an NTFS and an ext3 partition, and dolphin allows me to mount either without entering any credentials first.

  1. can I configure the system in such a way that it treats external harddrives in the same way as a USB-stick?

Yes, it will be a polkit policy setting.

I note that for my flash memory device, I get

udevadm info -a -n /dev/sdb|grep remo
    ATTR{removable}=="1"
    ATTRS{removable}=="fixed"
    ATTRS{removable}=="unknown"
    ATTRS{removable}=="unknown"

whereas for my USB-connected hard disk, I get

udevadm info -a -n /dev/sdb|grep remo
    ATTR{removable}=="0"
    ATTRS{removable}=="unknown"
    ATTRS{removable}=="unknown"

However, KDE treats them alike (for me at least). AFAIU, KDE 4.8.5 still uese udisks (as opposed to udisks2), so you should be able to relax the ‘org.freedesktop.udisks.filesystem-mount-system-internal’ policy to allow mounting without root authorisation (as you do with your memory stick). Others, please correct me if I’m wrong here. :slight_smile:

To do this, edit /etc/polkit-default-privs.local, so that it includes the line

org.freedesktop.udisks.filesystem-mount-system-internal no:no:yes

then run the following as root

set_polkit_default_privs

Confirm policy settings with

pkaction --action-id org.freedesktop.udisks.filesystem-mount-system-internal --verbose

Now, try plugging in your USB-connected hard disk again. Can you mount as a user without credentials?