External Drive Does not show in /media


I have an external drive for back-ups. I use it for both Windows and Linux. Windows can access the drive fine (meaning I can get my stuff out of my old PC and into Linux) - but my openSuse system can’t see the drive (or doesn’t let me see it).

I’ve tried the

lshal -m

command and I can see when I power the HDD up and down; however, it isn’t mounted anywhere when I look at

fdisk -l

The drive’s disc access light is on all the time - this only happens when the disc is in use, which makes me think that openSuse is trying to get at it but failing.

Any suggestions? I have another HDD at work which has all my backups as well - it works fine.

The only time I have seen this (drive light come on, but no access) was when the external drive did not have enough power. I solved this by two approaches (both of which worked):

  • used a powered USB hub, that gave the drive more power, and what also worked was:
    *] used a bifurcated cable that had two USB connections for the PC and only one USB connection for the drive. This was so the drive obtained power from the two USB connections, and used only one of the USB connections for data.

I don’t think lack of power is the issue. The drive worked fine with this laptop when it was Windows-only and when it was dual-boot; something has changed in my settings (for which I take full responsibility) but I have no idea what…

So are you saying you don’t have windows any more? Some users have had issue with NTFS drives that have not been removed properly in windows. Boot with it in a win pc and safely remove. It might sort the problem of what is refered to as ‘a dirty’ drive.

No, I’ve tried that as well to no avail.

Boot up with a utility like parted magic see how it reads it:
Downloads - Parted Magic

Tried the partition editor with YaST, GParted and KDE Partition Manager. None can see the drive.

Just be 100% certain, you could under MS-Windows, run “chkdsk” (with the appropriate flag added) to fix any errors found.

I know you stated you mounted and unmounted under MS-Windows but that may not be enough.

I have an old external hard drive which is not automounted under Linux. It could be mounted only manually (but it was detected).

I have seen the storage in mobile phones not recognized when connected to a Linux PC.

But when it comes to the light actually coming on in a Hard drive, as noted I have only seen that when there was a power deficiency. I also note in the case I observed, that the drive worked partly under MS-Windows (but not reliably) with the power deficiency.

You are a genius - the power cable was not correctly inserted :shame:. The disk now appears in Konqueror. HOWEVER…, I get a “TODO: have to rethink extra options” message. In the /media folder, there is a file, .hal-mtab-lock created, but it is empty.

Any other ideas on this?

Does the drive now show up under “fdisk -l” when run with root permissions?

Its also possible the drive is now dirty after all the failed attempts, and may need to be cleaned under MS-Windows (ie mount/umount properly under MS-Windows, and possibly run “chkdsk” with appropriate option (where I do not know the option off of the top of my head)).

Yes, it shows up. I’ll do chkdsk under Windows and let you know.

I forgot to ask, and a quick skim did not show me the answer … what version of openSUSE are you using? There are differences between versions, and the older versions had some hiccups that were fixed with 11.1.

OK - reran chkdsk and safely removed - still no joy (TODO…error still appearing).

I’m running openSuse 11.0 32 bit.

One other thing which may help - I have plugged in a memory card and it is recognised immediately, generating a .hal-mtab file which has some info in it. The external drive creates an empty file.

I think this is why. openSUSE-11.0. It is very important in these support threads that the openSUSE version number is supplied … often those of us giving support mistakenly assume one is using the latest version of openSUSE (which curently is 11.1).

From what I recall, hot plug auto mount of NTFS drives did not work in openSUSE-11.0 as packaged/provided. There was an easy work around that could be applied. …

The guidance for that is here:
NTFS - openSUSE - external HD hotplug bug in openSUSE-11.0

From @swerdna’s guide

OpenSUSE pre version 11.1: When you plug a USB NTFS drive into openSUSE it automounts read-only by design of the openSUSE developers. If you want it mounted read-write, you can either unmount it and then remount it using one of the CLI commands I’ve outlined above or you can change the system default way of automounting NTFS drives so they will always automount read-write. To do that you essentially put a link into the directory /sbin that redirects the automount process to the ntfs-3g driver. The following command will create the permanent adjustment:

sudo ln -s /sbin/mount.ntfs-3g /sbin/mount.ntfs

Thanks - I’ll give that a go.