Extended monitor wih key combination


My laptop screen goes black :slight_smile: and I think its a light bulb, as under windows 7 extended monitor works normaly, in windows Fn+F8 key combination works to switch to extended monitor bt it doesnt work here in opensuse 11.4 kde…

Is there any help I can use to turn on extended screen, from bootup or with key combination like in windows?


You can use xrandr. I don’t know if it works with Nvidia graphic cards but with ATI it does. In Monitor section in KDE settings you can check “names” of those two monitors. Example xrandr command making dual screen: “xrand --output DFP1 --mode 1920x1080 --above LVDS --output LVDS --mode 1366x768”. Next you can use xbindkeys to make a key combination for that shell command. Xbindkeys has good man pages so you’ll do that without any problems I think.

Hey tommer
Yee thats the thing here, my screen is totaly black and i can do nothing under opensuse even if its booted and running… can not go to monitor settings. Under windows Fn+F8 key combination allows me to switch to extended monitor and use windows, but I want to use linux and those keys just dont work here…

I was hoping there is some trick in grub that i can blindly typein and suse will boot with extended screen on …but no replays.

What’s yout graphic card and driver? /etc/X11/xorg.conf? I’m not an expert in that subject, but with that information maybe someone else will be able to help you.

Card is nvidia gs 8400 and its the latest driver…