Extended Attribute Support in 11.3

Just tried to test ea support by running setfattr on a test file and received an error message to the effect that this function is not supported. Is that corrects and if so how do I turn on ea support?

Add acl to the mount options. This is the installation default, so you probably turned it off when you were installing.

Hello Budgie2,

I am very curious as to what you are doing and why … I’m a noisy penguin … :smiley:

I am very interested in making better use of file system metadata … from xattr and gvfs. On the gnome side of things, it appears that we might be getting some real stability finally. xattr is a bit of a mystery to me … I really don’t see much use for it beyond storing SELinux contexts. I know (program replaced by Tracker) tried to use it …, but it the app was junk, tried to use it a few times over the years.

Anyway, I’m always interested in learning what things folks are trying … looking for new ideas …

Have fun!


Ah, that reminds me, you will also need to add the user_xattrs options to store the ACLs in.