ext partition ownership

I’ve looked all over and tried different ways to get ownership changed to a partition. I’ve used Yast/system/partition and put myself as the owner but, doesn’t happen.
In Fedora and Ubuntu I use sudo chown -R allan:allan /media/mydata
Here I get chown: invalid group: `allan:allan
Here is my fstab entry:
/dev/disk/by-id/scsi-SATA_WDC_WD2500AAJS-_WD-WCAR00032564-part3 /media/mydata ext3 user,acl 1 2

I would like to be listed as user on boot up.

That message means there is no group called allan. Try sudo chown -R allan:users …

Get this:
allan@linux-syr1:~> sudo chown -R allan:users
chown: missing operand after allan:users' Try chown --help’ for more information.

Well you were supposed to type /media/whatever after that. Exactly the same command as before, but with allan:users instead of allan:allan. I guess my laziness in typing … misled you huh? Oh, don’t type /media/whatever, it’s, um, /media/mydata.

Double duhh on me thanks that worked. One more ?.
Is there a way load me as user on boot up by editing fstab? here’s the fstab entry:
/dev/disk/by-id/scsi-SATA_WDC_WD2500AAJS-_WD-WCAR00032564-part3 /media/mydata ext3 user,acl 1 2

The ownerships of objects in the ext3 filesystem are contained in the filesystem itself, not by any mount option, unlike FAT filesystems. So the files there are owned by whomever created them.