ExpressVPN Setup - It seems that the expressvpn daemon is not running.


Almost have a 100% operational system…

Trying to get ExpressVPN working.

When I follow below instructions I get error in terminal:

jlp@new-host-3:~> expressvpn activate
Cannot connect to expressvpnd daemon.

It seems that the expressvpn daemon is not running. Please run "sudo service expressvpn restart" to start it.

If the problem persists, please contact us.

Any ideas?
When I run “sudo service expressvpn restart” in terminal I get below:

jlp@new-host-3:~> sudo service expressvpn restart
[sudo] password for root: 
service: no such service expressvpn




Does it provide a systemd service? Switch to root user;

su -
systemctl status expressvpn

On a side note openSUSE uses systemd so the likes of Ub* instructions may not work and sudoers is not really configured unless you do it…

Tried that, did not work…

Any other ideas?
I really need my VPN to work…


So there is no systemd service? I can’t/won’t go to the insecure site so perhaps follow up with the provider as to if there is a systemd service…

Things you left out of your post…

  • Which installer did you download and run? - For the given choices, Fedora is typically the best try.
  • Did you reboot? Often if implemented as a service, whether it can be successfully started or not, it might be configured to start on boot.

Also, to get a more descriptive error when something doesn’t work (and you’re manually invoking),
You can capture your system events in real time by opening an elevated console, running the following command and leave it open as you do whatever might throw an error (in your case start the expressvpn service)

journalctl -f


I just ran into this problem moving from CentOS to OpenSUSE for my desktop. It appears that for some reason the rpm installation does not copy over the systemd service file. (Problem 1)
Going off of my Fedora installation, I did the following:

sudo cp /usr/lib/expressvpn/expressvpn.service /etc/systemd/system/expressvpn.service
sudo ln -s /usr/lib/expressvpn/expressvpn.service /etc/systemd/system/

Then started the service:

sudo systemctl enable --now expressvpn.service

That gave this response:

Removed /etc/systemd/system/ 
Created symlink /etc/systemd/system/ → /etc/systemd/system/expressvpn.service.

So there was a difference in what systemd wants the link target to be for OpenSUSE apparently. (Problem 2?)
Anyway, everything works now. Good luck.

worked perfect on leap 15.2! Thanks for this!

I use Express VPN … but I don’t use their custom app (?).

Instead I just use their ovpn files, and the nominal openVPN app and the Network Manager that comes with openSUSE.

What might be the best way to install the updated package from ExpressVPN? Just use Yast to remove old package and the install latest the same way?