Expected update by now

Greetings, new Tumbleweed user here. I just installed Tumbleweed yesterday morning, and rather from what I’ve read about Tumbleweed, I would have expected an update needed by now. Below is my repository list.

danny@localhost:~> zypper lr -u
Repository priorities in effect:                                                                                     (See 'zypper lr -P' for details)
      90 (raised priority)  :  1 repository  
      99 (default priority) :  5 repositories

# | Alias                            | Name                        | Enabled | GPG Check | Refresh | URI                                                                                
1 | http-ftp.gwdg.de-be300b51        | Packman Repository          | Yes     | (r ) Yes  | Yes     | http://ftp.gwdg.de/pub/linux/packman/suse/openSUSE_Tumbleweed/                     
2 | http-opensuse-guide.org-154c63cb | libdvdcss repository        | Yes     | (r ) Yes  | Yes     | http://opensuse-guide.org/repo/openSUSE_Tumbleweed/                                
3 | openSUSE-20200325-0              | openSUSE-20200325-0         | No      | ----      | ----    | hd:/?device=/dev/disk/by-id/usb-SanDisk_Cruzer_Glide_4C530001251227108441-0:0-part2
4 | packman                          | packman                     | Yes     | (r ) Yes  | Yes     | http://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Tumbleweed/                
5 | repo-debug                       | openSUSE-Tumbleweed-Debug   | No      | ----      | ----    | http://download.opensuse.org/debug/tumbleweed/repo/oss/                            
6 | repo-non-oss                     | openSUSE-Tumbleweed-Non-Oss | Yes     | (r ) Yes  | Yes     | http://download.opensuse.org/tumbleweed/repo/non-oss/                              
7 | repo-oss                         | openSUSE-Tumbleweed-Oss     | Yes     | (r ) Yes  | Yes     | http://download.opensuse.org/tumbleweed/repo/oss/                                  
8 | repo-source                      | openSUSE-Tumbleweed-Source  | No      | ----      | ----    | http://download.opensuse.org/source/tumbleweed/repo/oss/                           
9 | repo-update                      | openSUSE-Tumbleweed-Update  | Yes     | (r ) Yes  | Yes     | http://download.opensuse.org/update/tumbleweed/                                    

Does anyone see anything amiss here? Perhaps one of the repos that should have been enabled?

Thanks in advance!

Hi and welcome to the Forum :slight_smile:
You need to use the command line and zypper to do a distribution upgrade not an update as Tumbleweed is rolling.

I use some extra verbosity to the update to see what is happening as follows;

su -
zypper ref
zypper -vvv dup

The above should get you to 20200326, you should also look at following the development mailing list for information and also see notifications that a new release is available.

I should have mentioned I tried just zypper dup before, and it came back “Nothing to do.”

I’ll try your suggestions.

I guess, coming from Arch I was expecting a needed update fairly frequently.

Yes, but …

The frequency varies. Each update is tested at openQA. And if it fails the test, that update is skipped. That just means that some bug needs to be fixed. You won’t be missing updates, but the update to some packages is delayed until all detected problems are solved. My estimate is that there are 2-5 updates per week. But I think there was a delay of over a week at one time.

That update to 20200326 was probably published after your “zypper dup”.

Thank you all!

I’ve got to say, I’m really pleased with how well this is running on my old Dell laptop (Latitude E6430), including connecting to my wireless HP printer.

Very nice!

Hi, welcome !!!

Not per se. If you follow the installer’s suggestions and enable the online repos like the OP did, it takes newer packages from the repos.

@OP: my bet is that if you look at

cat /etc/os-release

your output will state that it’s already 20200327.

FWIW you have the packman repo active twice, remove on of them.

Always good to read positive feedback. :slight_smile:

Removed one of the packman repos, then

su -
zypper ref
zypper -vvv dup

resulted in 106 updates.

your output will state that it’s already 20200327.

Nope. Still 20200326

danny@localhost:~> cat /etc/os-release 
NAME="openSUSE Tumbleweed" 
# VERSION="20200326" 
ID_LIKE="opensuse suse" 
PRETTY_NAME="openSUSE Tumbleweed" 

I’ll just be patient. I’m sure it’s fine.