Existing root partition not found in Expert Partitioner in Leap 15.x

Firstly, referring to the below bug report, I do not knowingly have SBM installed.

Normally I use ‘zypper dup’ to upgrade to a new release, which I did successfully with Leap 15.0 but after doing this for 15.1, the current kernel I was using (that worked) on 4.14.14 was removed from the grub menu, and the new (Leap 15) 4.12 kernel was added to the grub menu, along with the existing 4.15 kernels I had that didn’t work.

End result, trying to boot into 4.12, X keeps trying to start, which results in a flickering screen and a login prompt. At this point the keyboard input does not seem to work, i.e. Ctrl+Alt+Fx, Ctrl+Alt+Backspace or Ctrl+Alt+Del has no effect.

If I try to use runlevel 3 or 1, I get a login prompt but still can’t input anything. So I try an Update or Installation using both 15.0 and 15.1 ISOs on usb stick. On each I find that my root partition, which is EXT4, is not found.

I’ve tried booting into rescue mode and doing a chroot into my root partition, then getting networking up, but it seems no dbus socket is created which causes wicked problems, so I guess that’s another topic.

My searches don’t show any appropriate fix, so my question is: Is the undetected partition issue being looked at still? I have 4 partitions on my /dev/sdb hard drive, but none are recognized by the Expert Partitioner.

I understand from what I’ve read that libparted is the problem, as fdisk finds the partitions no problem.

Finally from the rescue command prompt in chroot, I can get to the login screen fine by typing ‘sddm’, but still no keyboard input or moving mouse pointer.

Ideally I’d like to get each of these problems fixed, but after using Suse since 2004, I’m seriously considering trying a distro that will have Wayland and plasma 5 and be a bit more stable when updating to a new version.

Leap 15.1 is still on the way to be developed (somewhere Beta, or not even that??). I am not sure that testing if a successfull upgrade in the way you did it was even done until now. Thus you can expect all sorts of problems.

You are of course free to test 15.1 and report problems to the developers, but not many of the openSUSE users here will have any experience with it.

Hi Henk,

Thanks for your response. Yes I realize 15.1 is an Alpha version, but I was hoping the regression in the partitioner would have been fixed by now. That bug I quoted was opened back in June, so it’s hard to believe no one else has come across the issue.

I’ve spent the last week trying to sort this, and it’s not the first time I’ve had issues with Suse upgrades, so as I need to get my workstation up and running again soon, I may change to another distro. I changed from Tumbleweed to Leap because I needed stability, but it’s just not happening.

Thanks for your input anyway.

When you need stabiliity, why do you even contemplate 15.1?

Honestly, I started out with upgrading to 15.0, then I saw a release for 15.1 but missed the Alpha part, my bad. I haven’t really kept up with the releases as I always have to fix things on my setup when upgrading to a stable release. So I usually stay with my fixed setup for a good while.

My problems with 15.0 ranged from issues with the plasma desktop, to problems with my dual Acer displays not showing properly or not getting the correct resolution, so I was hoping 15.1 would have fixed some of those issues. I should have read the release notes first. Again, my bad.

I found a temporary workaround for anyone with networking issues.

  1. Start an Update session using a 15.x ISO
  2. Abort the session which should bring you back to the text ‘Start Installation’ screen.
  3. Select ‘Network setup’ and choose dhcp on your wireless device (you may have to select ‘Start Installation’ first, just going by memory here.)
  4. Select ‘Start Installation’ and ‘Rescue’
  5. from the prompt, chroot into your root partition, updates can then be installed from there.

Currently I lose connectivity after some time, so I’m trying to find a way to get internet access again without going through this whole process again.

Hope this helps someone.

I was able to do

dhclient
ifconfig wlan0 down
ifconfig wlan0 up

to restore internet connection.

After doing zypper up (5000 package update), the zypper dup (3000 package upgrade), I was able to log in again from the login screen after a reboot.

So the same issues I had before with fonts and screen resolutions are still there, but at least I’m in my system again now.

I am therefore closing this thread, although the issue with the Expert Partitioner remains, and thus is not yet solved.

1097081 – Parted 3.2 fails to read MBR partition table if it contains SBM (Smart Boot Manager) was resolved as invalid, so don’t expect it to ever get “fixed”.

So the same issues I had before with fonts and screen resolutions are still there
Which issues are those? Where were they reported?

That bug AFAICT was related to SBM which I don’t knowingly have as stated earlier, so I assumed I’d have to raise an issue for this.

Currently my issues are with plasmashell and the Activity menu crashing, so clicking on any of the panel items does nothing. These things happened before the update. Now when I log in I have kdeinit5 errors for something that’s crashing, but there is no indication of what that is. My System Load Viewer widget shows nothing at all.

Usually I would be able to kill plasmashell when it freezes or disappears, but I’m unable to do that currently. So I don’t know what’s causing that, and it has been like that for a while, I just have not had the time to report or look into these issues. If they have been reported, I’ve just been too busy to check. Even getting to a terminal screen either works or doesn’t, and I’m currently getting output to stdout making it difficult to enter username and password.

Then if searching for solutions to such trouble produce no fruit, describe that trouble in a thread that contributors who wish to avoid non-KDE/Plasma subjects like partition* are likely to see. IOW, if you need help with Plasma, the thread subject should include the string Plasma and/or KDE.

Hi mrmazda,

As I’ve worked around the partition issue I’ve considered this thread closed already. My immediate problem is to get my TP Link adapter software to build and install successfully, and currently it doesn’t. I’m actually surprised the Realtek 8814au.ko driver isn’t already included in the kernel yet, so I have to build the source for every new kernel installed.

When I’ve solved this WiFi driver problem, and don’t have to keep bringing the interface up, every time it goes down in a session, to get internet access, I can provide more threads for my other issues.

Thanks for your input

Perhaps since I consider this partition issue a blocker for users like myself, maybe it’s time for me to change distro then, if developers can’t be bothered to fix it. You can’t expect people with little knowledge of linux to progress if they don’t want to wipe their existing partitions.

Developers won’t try to fix bugs they don’t know about, and they don’t come here looking for bugs to fix. Did you report this on Bugzilla? openSUSE:Submitting bug reports - openSUSE Wiki explains how and what’s required.

So far you provided zero evidences that you are affected by this bug.

maybe it’s time for me to change distro then, if developers can’t be bothered to fix it.

Did you actually read this bug? This is upstream issue, you will encounter the same problem in any distro that includes recent enough libparted.

You can’t expect people with little knowledge of linux to progress if they don’t want to wipe their existing partitions.

Which clearly demonstrates that you did not even bother to read the bug you claim is of so much concern to you. Distribution maintainer provided package that could be used during installation, together with explanation for people with little knowledge how to use it. The user who reported this bug considered it suitably resolved. There is not much more distribution maintainer can do without introducing incompatibility with any other distro out there. If you are indeed so much concerned about poor users, go and complaint where it belongs - to libparted developers. Then reopen this openSUSE bug pointing to upstream commit that fixes it and I am sure openSUSE libparted maintainer will be more than happy to include fixed release or backport it if necessary.

Ok, you’ve raised some good points. I’m well aware of how and where to raise issues. In the mean time I’m using my backup desktop XFCE to try and get things working again. I guess my initial reason for creating this thread was to find out if anyone else had this experience.

Like I’ve said, this thread can be considered closed, and I’ve asked for it to be locked.

Thanks for your input.

Your comments are noted. Again, I’ve considered this thread closed.