Executing Dolphin as root is not possible.

Logged in as a user i occasionally use dolphin in superuser-mode (org.kde.dolphinsu.desktop) to move files between various directories (of different users).

Today when i pressed on the org.kde.dolphinsu.desktop icon i (as always) got prompted for my root password but after i had entered it (correctly!) nothing happened. Doing “kdesu dolphin” in a console showed the same behavior and gave the same result. When i entered dolphin in a root-console i got:

# dolphin                                                                                                                                           
Executing Dolphin as root is not possible.

My system setup is

openSUSE 42.2
kernel 4.10.8-2.gea9dcd4-default
plasma 5.9.4
frameworks 5.32.0
Qt 5.8.0
dolphin 17.03.80

Searching the NET i found this




So is the meaning of his, that from now on dolphin can’t be used in superuser-mode anymore?



I’m not having a problem here. This is with vanilla 42.2.

It looks as if you have a newer version of dolphin.

I would not personally be troubled by that change. I never use dolphin as root, except when checking reports such as yours.

On this “out-of-the-box” Leap 42.2 system, the versions are as follows:

  • Dolphin: Version 16.08.2
  • KDE Frameworks 5.26.0
  • Qt 5.6.1
  • plasma5-workspace: 5.8.6-8.1 (LTS)

You seem to be using a KDE Plasma 5 version from the “KDE:” repository.
In the KDE Menu, the command to launch Dolphin in super-user mode is: dbus-launch dolphin -qwindowtitle “%c” “%u”
A “normal” Dolphin session is launched with: dolphin %u

Yes, it seems that during February 2017 the Dolphin code was changed to disallow execution as “root”.

On the other hand, none of the Bug Report authors are mentioning HOW they’re launching Dolphin – they’re only writing “as root” . . .

Whether or not the “dbus-launch” behaves as one expects has yet to be proved.
And, no one has reported the result of “SDDM – login as another user” (possibly as ‘root’) and launching Dolphin from that KDE session.

Yes, i do. But that behavior is new (came with the last update i made?).

Well, i’m certainly not afraid of the command line but on occasions i find GUI-based file managers quite convenient …



You can no longer use Dolphin as root, even if you are logged in as root in KDE. I was pretty unhappy about it and I think it should be my choice if I want to use Dolphin as root or not, and not a decision of a KDE developer.
Anyway, Krusader works quiet well for what you want to do, just be careful, you can kill your system rather quickly.


Yes, that is how “org.kde.dolphinsu.desktop” works.

I have not tried that one either, but i guess that will not really be different from launching dolphin within a terminal as root.



I share your point of view.

Well…, dolphin is my favorite file manager (just a personal choice).

Yes, working as “root” always requires additional care and attention.



…very bad this decision to do not allow to run dolphin as super user >:(, but, on my opensuse leap 42.2, plasma 5.9.4, KDE frameworks 5.32.0, KDE applications 17.03.80, Kernel 4.4.57-18-default, nvidia drivers it seems to works well launching from the kicker searching super and click on file manager - super user mode…
manythanks, ciao, :slight_smile: pier

You might notice that the slogan they once displayed at their website – “Experience Freedom!” – is no longer there. :wink:

However, they still say this, which to me seems less and less truthfull: “dedicated to creating an open and user-friendly computing experience”


I am certainly not pleased with some of the directions they are taking with the new Plasma 5.

Yes, to me they seem to be getting more & more Apple or Microsoft all the time, dictating to the Users how the Users will do things and taking away the alternate choices.

Except for one choice they cannot take away: I have switched to another desktop, after using KDE as my sole desktop for many years. I now use Xfce, and I am keeping an eye out at other alternatives.

I’m a simple user, I don’t feel I cannot use dolphin as root “so friendly”…>:(
…and the choice you talk about isn’t so easy too for a simple user, I know kde, windows, mac, but not xfce…

I’m not happy with this decision either, but I don’t use it dolphin as root much so I won’t go to the drastic step of dropping kde.
In any case, if you really need root access you can still use konqueror (for now) which ironically uses dolphin for its file manager.

it will happen to all gui apps, kate/kwrite also. Its required to profit from the new security enabled by wayland.

That means that the Superuser can only edit using Konsole and vi?

But wait, using Konsole as root will then also be blocked I assume.

and to make things even safer nobody will be allowed to use KDE at all ;).

Guess i will have to give XFCE another try (after more than 15 years of KDE :().



rotfl!the only way to write in superuser mode will be hammer and chisel … and root will be changed in rude…

Sadly this is true, kwrite already stopped working as root after the latest update. Time to learn somthing new.

very bad :(, remaining in kde, what can I use to edit files, graphically similar to kwrite, as root??

…but in my last update
Version 4.14.30
Using KDE Development Platform 4.14.30
it works and also dolphin as superuser…

Kwrite: 17.03.80-2.3
Dolphin: 17.03.80-81.9

you can read kde dev talk about kate changes, root edit functionality will be provided by “sudoedit” (was new to me), not the end of the world but they could have provided a smoother workflow.