Excessive mic input noise

ASUS H97M-E motherboard with Realtek ALC887
LEAP 42.2

There is excessive, continuous, static hissing noise on both the front and rear mic inputs, even when no mic is connected. The noise is bad enough to make using a mic impossible. My first thought is to ensure the correct driver is being used.

I have used the YAST Sound control to automatically configure the audio. It is detected as “9 Series Chipset Family HD Audio Controller”

head -n 1 /proc/asound/card0/codec* outputs:
Codec: Realtek ALC887-VD

The file /etc/modprobe.d/50-sound.conf has the following content:
options snd slots=snd-hda-intel,snd-hda-intel

u1Nb.SVBsy0mp657:9 Series Chipset Family HD Audio Controller

alias snd-card-0 snd-hda-intel

NXNs.elCX_tboTmB:nVidia Corporation

alias snd-card-1 snd-hda-intel

The file /etc/modprobe.d/50-alsa.conf has the following content:install snd /sbin/install-snd-module snd $CMDLINE_OPTS
install snd-pcm /sbin/install-snd-module snd-pcm $CMDLINE_OPTS
install snd-seq /sbin/install-snd-module snd-seq $CMDLINE_OPTS

How can I determine if this is a driver problem and correct it, if so?

I’d suggest running the ALSA diagnostic script (/usr/sbin/alsa-info.sh) to get more comprehensive information
https://en.opensuse.org/SDB:Audio_troubleshooting#First_method_to_run_script

Post the URL that it generates here, so that others can advise further.

Here is the link to script output

There is definitely something wrong with the audio. If I connect both a mic and headphones to the computer, I can hear the mic faintly through the headphones, without any audio applications running.

I tried listening during a reboot and the mic can be heard going from silence to live during boot, before the Desktop is loaded.

The ‘Front Mic’ level seems to be at maximum?

Simple mixer control 'Front Mic',0
   Capabilities: pvolume pswitch
   Playback channels: Front Left - Front Right
   Limits: Playback 0 - 31
   Mono:
    Front Left: Playback 31 [100%] [12.00dB] [on]
    Front Right: Playback 31 [100%] [12.00dB] [on]

Have you tried configuring with ‘pavucontrol’?

I think deano_ferrari is on the right track, that before the driver is blamed, one should be certain the mixer is configured ok.

One problem with Linux (IMHO) is it provides so many possibilities for control that it can confuse and lead to unintentional misconfigurations. So I took a look at the entire mixer settnig

I have commented on various aspects in your PC’s openSUSE GNU/Linux mixer setting:


**Simple mixer control 'Front Mic',0**
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono:
  Front Left: Playback 31 **[100%]** [12.00dB] [on]
  Front Right: Playback 31 **[100%]** [12.00dB] [on]
**Simple mixer control 'Front Mic Boost',0**
  Capabilities: volume
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: 0 - 3
  Front Left: 0 **[0%]** [0.00dB]
  Front Right: 0 **[0%]** [0.00dB]
...
**Simple mixer control 'Rear Mic',0**
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono:
  Front Left: Playback 31 **[100%]** [12.00dB] [on]
  Front Right: Playback 31 **[100%]** [12.00dB] [on]
**Simple mixer control 'Rear Mic Boost',0**
  Capabilities: volume
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: 0 - 3
  Front Left: 0 **[0%]** [0.00dB]
  Front Right: 0 **[0%]** [0.00dB]

Looking at the Front and Rear mic (above), possibly by having the boost at 0%, you are forcing the playback to 100% to get feedback from the Mic. I recommend instead you move the boost up to 33% or even 66% and reduce the playback signficantly.

Further are you using the Line input ? I note:


Simple mixer control 'Line',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono:
  Front Left: Playback 0 [0%] -34.50dB] **[on]**
  Front Right: Playback 0 [0%] -34.50dB] **[on]**

If not using it , then I recommend muting “simple mixer control - line” further. i.e. not only 0% but switch it OFF (as it is currently ON). If that stops your Mic from functioning then switch it back ON.


Simple mixer control 'Capture',0
  Capabilities: cvolume cswitch
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 46
  Front Left: Capture 16 [35%] [0.00dB] [on]
  Front Right: Capture 16 [35%] [0.00dB] [on]
**Simple mixer control 'Capture',1**
  Capabilities: cvolume cswitch
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 46
  Front Left: Capture 46 **[100%] **[30.00dB] [on]
  Front Right: Capture 46 **[100%]** [30.00dB] [on]

If you put your Rear/Front Mic boost up higher, you should not need 100% for “capture-1” on your associated Mic position. Reducing that capture may reduce the noise.


**Simple mixer control 'Digital',0**
  Capabilities: cvolume
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 120
  Front Left: Capture 60 **[50%]** [0.00dB]
  Front Right: Capture 60 **[50%]** [0.00dB]

Do you need digital input to the mixer ? Try setting that to a lower value and see if it has a positive effect. If not, then restore the value.


Simple mixer control 'Input Source',0
  Capabilities: cenum
  Items: 'Front Mic' 'Rear Mic' 'Line'
  Item0: 'Front Mic'
Simple mixer control 'Input Source',1
  Capabilities: cenum
  Items: 'Front Mic' 'Rear Mic' 'Line'
  Item0: 'Front Mic'
**Simple mixer control 'Loopback Mixing',0**
  Capabilities: enum
  Items: 'Disabled' 'Enabled'
**  Item0: 'Enabled'**

Must you have loopback mixing enabled ? What happens if you “disable” loopback mixing ?

Note that I may not reply for days - as I am about to fly out to a different continent and I do not know when I will regain internet access.

Indeed; I have been experimenting with controls, trying to discover what may affect what. Many settings are likely at extreme values from when I was searching for cause-and-effect.

Using alsamixer, I raised mic boost.
Result: All sound on the mic input is increased; static and signal alike.

I noted that there are TWO “Front Mic Boost” and TWO “Rear Mic Boost” controls in alsamixer. This seems strange, since all other attributes only have a single control.

I recommend muting “simple mixer control - line” further. i.e. not only 0% but switch it OFF (as it is currently ON). If that stops your Mic from functioning then switch it back ON.

Done. Result: No noticable effect.

If you put your Rear/Front Mic boost up higher, you should not need 100% for “capture-1” on your associated Mic position. Reducing that capture may reduce the noise.

This is interesting. Adjusting the Capture value results in a raise or lower of the audible mic input (and noise). It also causes a change in the Pulse Audio volume control for the mic.

Adjusting the “Front Mic” value, however, has no effect. I would expect it to be the primary control.

Could this be a clue?

Do you need digital input to the mixer ? Try setting that to a lower value and see if it has a positive effect. If not, then restore the value.

Changing this value has no noticable effect.

Must you have loopback mixing enabled ? What happens if you “disable” loopback mixing?

Set to Disabled. No noticable effect.