Exaile won't open after install

I’m running 11.2 Gnome and I’ve installed Exaile and its now listed in Yast, but it won’t open. I rebooted and it still would not open.

What am I missing to get Exaile to work?

I had the same error. It looks like some script error on my 64 bit opensuse installation. It turns out the start script has some path errors. I opened in a text editor (as root user) this file: /usr/bin/exaile and made look like this:


#!/bin/sh
 exec python /usr/lib/python2.6/site-packages/exaile/exaile.py  --datadir=/usr/share/exaile/data --startgui "$@"

Now exaile works rotfl!

Had the same problem with Exaile not start after install.
And i did the same as you did whith the Exaile script and now it works for me too lol!

glad to help. Have fun rotfl!

Hello,

Did the same but when I try launch Exaile in konsole I get this error


INFO    : Loading Exaile 0.3.1.1...
INFO    : Loading settings...
python: symbol lookup error: /usr/lib64/python2.6/site-packages/gst-0.10/gst/_gst.so: undefined symbol: gst_pad_link_check_get_type

Same error when launching Rhythmbox as well.

I forgot to add that I am using openSUSE 11.3 64bit with KDE. When I try to run Exaile as root I get this error


Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/exaile/exaile.py", line 52, in <module>
    main()
  File "/usr/lib/python2.6/site-packages/exaile/exaile.py", line 49, in main
    exaile = main.Exaile()
  File "/usr/lib/python2.6/site-packages/exaile/xl/main.py", line 79, in __init__
    if xldbus.check_exit(self.options, self.args):
  File "/usr/lib/python2.6/site-packages/exaile/xl/xldbus.py", line 57, in check_exit
    bus = dbus.SessionBus()
  File "/usr/lib/python2.6/site-packages/dbus/_dbus.py", line 219, in __new__
    mainloop=mainloop)
  File "/usr/lib/python2.6/site-packages/dbus/_dbus.py", line 108, in __new__
    bus = BusConnection.__new__(subclass, bus_type, mainloop=mainloop)
  File "/usr/lib/python2.6/site-packages/dbus/bus.py", line 125, in __new__
    bus = cls._new_for_bus(address_or_type, mainloop=mainloop)
dbus.exceptions.DBusException: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

PS
Sorry for bumping. I was searching solution in meanwhile, without results of course :frowning:

Sorry for the bump, but if people are still experiencing this problem, this might fix it…

A solution for this problem could be found here: Re: [packman] Miro 3.0.3: undefined symbol: gst_pad_link_check_get_type
(for me this fixed muzofan’s problem: Rhythmbox had the same error; make sure all the gstreamer sources are from packman and it works like a charm)

I had same problem when running exaile in a terminal
python: can’t open file ‘/usr/lib/exaile/exaile.py’: [Errno 2] No such file or directory

I ran this to locate the file

rpm -ql exaile

When I located the path of my file /usr/lib/python2.6/site-packages/exaile/exaile.py

I open as root an editor

This was my old destination

exec python $EXAILE_PREFIX/lib/exaile/exaile.py --datadir=$EXAILE_PREFIX/share/exaile/data --startgui $@

I then changed it to

exec python $EXAILE_PREFIX/lib/python2.6/site-packages/exaile/exaile.py --datadir=$EXAILE_PREFIX/share/exaile/data --startgui $@

Exaile now works.