Exact copy of files -how to?

Hi. Here is the situation. I’ve made the backup of suse using systemimager, by default the image is stored in /var/lib/systemimager/images/Name_of_the_image and I would like to copy this backup to external usb hard drive which is now EXT3 formated. If I try to copy it via Dolphin, it fails to copy the files which are of 0 size (devices, temp files,…) so I must find a better way to copy files to usb drive :frowning: I think that rsync should help me with this, so I thought entering comman like

rsync my_image_08_11_2009 -av /media/USB-HDD/

, I tried and it seems to have copied all files, but still I’m a bit in doubt if it really has. Did I select the right swithes with the rsync command? How can I verify the data is exact as the original? Since it is a backup of system, I need to make it right. Please help.

If you have K3b installed, a quick way is to load each image, upon which K3b will calculate the md5, after which you cancel the operation.

If the md5 calculations are the same, the images are almost certainly identical. If not, they definitely aren’t.

I am assuming they are .iso images.

Thanks john_hudson, md5 is a good idea. So I tried

echo -n my_image_08_11_2009/ |md5sum -

and compared it with the source folder, and they do differ :frowning: How can I improve my copying?

What about dd if= of=?

Not sure what other parameters you may need in your case…

I’ve learned something out of this :slight_smile: So, to repeat the story…systemimager creates backup by default in /var/lib/systemimager/images/Name_of_the_Image. Inside this folder there are exact copies of the entire system you did backup, so the backup is not packed in some special format like iso, it looks like it is “copy pasted” and you can browse it’s content. Then I wanted to copy this backup somehow to an external usb hard drive, which is party formated as ext3. The problem is that you can not just copy paste via dolphin the content of backup, since it contains some “strange” files like devices of computer, which appear (at least some of them) as 0 sized files. So to be able to transfer backup to some other location (usb drive in my case) you have make a tar archive, you do that via konsole

tar -cvf Laptop_image_08-11-2009.tar Laptop_image_08_11_2009/

Afterwards I did a md5sum check file of the entire backup folder. First swift position to the backup folder and do

find  .  -type f   2>/dev/null  -exec md5sum {} \; >/var/lib/systemimager/images/Laptop_image_08_11_2009_md5sum.txt

Now you can copy/paste the tar archive with the md5sum file to the desired location (in my case usb hard drive). This is it:) However pay attention when you extract the content of the tar archive, avoid extracting it via “right click” in dolphin. Insted do it via konsole like

tar -xvf Laptop_image_08_11_2009.tar

Afterward do a check to verify the extracted content via konsole, but first switch position to the extracted archive location, then do similar to this

md5sum -c /home/arcull/Laptop_image_08_11_2009_md5sum.txt

and see if it reports any problems. I did issue all commands as root users, which might not be necessary, but I did want to make sure I have the required permissions. Once again I would emphasise, avoid using “right clicks” to create/extract archive in cases like this, in my case the extracted content did not match the md5sum file because of this.