Evolution unstable

I am running Evolution 3.10.2 on Opensuse 13.1 (64-bit) on Gnome 3.10.

There are 2 email accounts one is an EWS account and the other POP.

Every first time Evolution is started after reboot it ‘freezes’ during the initial accessing of one or other or both of the account servers. In the case of the POP server, one ore more emails may be downloaded, but the process does not go to completion and hangs at the n+1th mail. This freeze does not time out, i.e.Evolution is stuck in that state for ever. In the case of the EWS server. the message ‘loading…’ appears in the the account and Evolution remains stuck in that state for ever. (Sending/receiving mails or deleting them from the inbox causes Evolution to freeze.
It may be possible to write mails in that condition, but not to send them). Only if there are no mails on the servers will Evolution behave as normal.

Quitting the program seems the only alternative, but Evolution** does not quit** and waits for ever (i.e. no time-out, and no message to force quit). On logging out from Gnome, there is a message that Evolution is waiting to quit and it does finally complete the log-out after about 5 minutes (estimated). On logging in again to Gnome, Evolution behaves normally from then on.

Could it be that Evolution is tucked in the system at a level below the application level and is, therefore, beset with the similar sicknesses to MS Outlook?

Has anyone else noticed this behaviour? Does anyone have a solution? :’(



I’m having this problem too. I originally did a zypper dup from 12.3 to 13.1 and thought it might have something to do with this, so I did a clean install, but the problem persists. I use xkill to terminate evolution. I use xfce and was starting evolution via a keyboard shortcut. If I start it from the cli I don’t have the problem. Often if it has retrieved mails successfully it then crashes on switching folders. Seems to be generally unstable.

I know this doesn’t help you but at least you now know that you’re not alone with your problem …

Thanks, I was beginning to wonder if was alone! I would also put this message directly into the Gnome-Evolution forum, but I am not sure yet whether this might be an integration (or even an installation) issue.


I rechecked my observations and I have to say that I made this statement in error. This above is not, strictly speaking, the case. The ‘freezing’ of the EWS account happens approximately every second time on starting Evolution whether or not there are mails on the EWS server.

In the meantime, though, for about 5 days now, the phenomena described in the post (except this one here) have not been observed. Evolution seems no longer to freeze on collecting the mails from the POP server at start-up. Did a SW update solve the problem, I wonder?



Although not too much help for your exact situation, I’m running evolution 3.10.2 with 9 pop accounts and one imap account on open Suse 13.1, KDE 4.11.4. I have no troubles with evolution. I am subscribed to the evolution list and have seen problems with EWS, but most seem to be resolved. Give them a try.


Evolution no longer freezes on fetching mail. Evolution hasn’t been updated since I installed so some other update must have solved that problem. It still crashes sometimes when I switch folders. I guess I’ll just be patient and wait for some update that fixes that …

Similar behaviour here (i.e. Evolution freezes and refuses to quit) with OS 13.2 and Tumbleweed X86_64, Evolution 3.12.11 and Gnome 3.14.2
Three IMAP+ accounts here, the problems seems to be related to network connection - disconnection (Laptop with 3G dongle).
Manually disconnecting and synchronizing folders before actually switching off the network connection seems to avoid the problem.
I’ll try to be more specific the next time it happens.

I’ve had it freeze recently while fetching mail. I had to use fetchmail to get the e-mail and feed
it to evolution. This seemed to solve the problem. Perhaps it was choking on some
particular message.

To feed the mail in I tried to set up a Maildir account. This always crashes evolution with a gtk
error when selecting the maildir directory. I think that this bug report from 2005 shows the
same problem!