Evolution MAPI Problems

OpenSuSE 11.2 (x86_64) (up to date with maintenance from the community repositories for everything installed)
Evolution 2.29.20100112-1.2 (x86_64) (reports itself as 2.29.6 in the Help -> About box.
Evolution-MAPI 0.29.5-1.3 (x86_64)

I’ve been trying to use OpenSuSE with Evolution in our Windows network environment as a replacement to Windows w/Outlook, etc. I thought I would post the problems I’m currently experiencing in the hopes of someone telling me what I’m doing wrong, or that they are bugs that will get worked on.

At a high-level, I only send/receive email through our Exchange server using the MAPI connector.

1 - Some email that I reply to or forward to others is not sent back out through the MAPI connector. Instead, Evolution drops it into the “On This Computer” outbox and send it from there. That will not work of course. What I can’t figure out is what triggers it to go this route. It doesn’t seem to depend on where it came from originally (an internal email vs. external). It seems almost random.

2 - When scheduling an meeting, the busy/free times of the invitees are not shown, even though they are all on the same Exchange server.

3 - When a meeting is scheduled & sent out, the organizer (me int his case) is actually seen by Exchange as someone scheduling the meeting on behalf of me. To clarify: when it’s received, it doesn’t say that I scheduled it, it says I (using my email address) scheduled it on behalf of me (the Exchange user).

4 - Proxy support: I cannot get Evolution to authenticate correctly through our ISA server. I’ve tried configuring it through the network settings in Evolution as well as trying to use the system settings (which I also can’t get to go through our ISA proxy). It seems that Evolution is not passing my credentials to the proxy, even though I check the box and tell it that authentication is needed.

I probably have some more things, but that’s good for now.


I had one more to add…

5 - Sometimes when I receive email, I do not see everyone it was sent to. None of the other “To:'s” or “CC:'s”. Doesn’t always happen, but quite often. I can’t tell what the conditions are that it happens under, or when it works right.