Evolution/EWS not connecting to MS Exchange Server

I have been accessing a MS Exchange Server using EWS with Evolution client without difficulty for a while, (OS 13.1, OS, 13.2 and LEAP 42.1 (since December 2015).

Now and again I get messages asking for my credentials again. These messages usually stop coming after a while, even if I do not renew my credentials. I just assume that there is a problem in the handshake with the server that gets solved after a while (e.g. server is down until restarted, timeout on the handshake, etc)

Today, however, although the MS Exchange server is up and running (proven by webmail access), I am continually getting access complaints from the server. Can anyone advise me how to troubleshoot this problem? Is anyone aware of (new) incompatibilities with MS Exchange that EWS and Evolution might need to catch up on?


Although I don’t support Exchange today, am somewhat familiar with its history over the years.

You may need to determine the version of your Exchange Server, over the years Exchange Web Services (Accessing Exchange using a Web Browser) has varied how much the page code requires Internet Explorer to provide proprietary code (like ActiveX long ago). Also, if the Exchange is not currently patched could be a major factor.

Today, last I heard the pages <should> be straight HTML and not require any proprietary MS code, but YMMV and if Exchange is not latest versions would be a factor.

You may also have to experiment with different web browsers.

Since you don’t provide any exact error messages, I can only wildly guess that your messages could also be SSL related since the encryption and Diffie-Heilman handshake vulnerabilities were discovered a year ago. If both your browsers and Exchange/IIS have been updated since then, I assume that your connections would be secure and work, but if one or both weren’t upgraded you could still be using TLS1.2 instead of TLS2.0 or some other similar problem.


Many thanks for your reply!

I am not using a web browser for the email access, but Evolution/EWS. I can access my account quite successfully with a web browser (Firefox), but since I have several email accounts, I prefer to access them all with my evolution application.

Obviously, I can try to find out if the MS Exchange server is up to date and will do in due course. There are no ‘error’ messages as such, just ‘authentication’ requests (quite sporadically) for the account and access to the server’s ‘Global Address book’ (constantly, e.g. every minute or so). Obviously, this means that Evolution client is not totally successful in communicating with the server for some reason.

It seems that the cause of the problem lies in recent OpenSUSE updates (i.e. within the last two weeks, after 5.4.2016). I started my laptop for the first time since then and there were no problems with Evolution. I updated the 175 (!) packages that had become out of date in the meantime. Thereafter the authentication requests started coming every few seconds or so. A reboot did not help.

Sorry to have forgotten to report the versions earlier:

Evolution 3.16.5-4.8
Evolution-ews 3.16.5-2.3
Gnome 3.16.2

running on both desktop and laptop. These (very annoying) authentication requests pop up irregularly every few seconds. Mails get through in both directions most of the time.


I see the same issue with Evolution 3.20 on Tumbleweed. It’s only recently that I had to connect to an Exchange environment, if it did work on earlier versions, this could be a regression

I wonder if using DavMail would provide an acceptable workaround for the moment? I used that successfully for a few years when our company moved from using Zimbra to MS Exhange.

Unless I am mistaken, DavMail is not part of the distro. Normally I would switch back to the last version of Evolution/EWS but there is no earlier version of either. So did the problem come in when the kernel was updated?



I wouldn’t think so, it’s due to the nature of Tumbleweed, it gets “released” over and over again on each TW update.

It’s not, but I don’t see the relevance of that anyway. It is a java app, released under GPL, and there are third party packages available for openSUSE.


As a Thunderbird user, it is what I had to use in order to connect to our company’s Exchange server at the time. Hence, my suggestion that it might serve as a workaround until the regression is fixed. A bug report should be submitted in any case.

Stuck in the same boat as the OP. Exchange connection is constantly asking for authentication. Glad it wasn’t just me. Definitely something that was updated in early April. Was hoping it would be fixed in the next patches.

A colleage of mine (13.1) and me (42.1) are bitten by the same issue.

IIRC it was the reboot after updates on Friday 2016-04-15 when the issues started.

Just a wild guess: evolution uses libnss and there was an update to the ca-certificates-mozilla to 2.7 (but that was installed on 2014-0-18).

I have no problems putting the ews URL https://your.server/Ews/Exchange.asmx into a browser and authenticating with the AD credentials…

I submitted a bug 976369. Now someone has found that the cause was the last update of samba-winbind 4.2.4-15.1. They recommended a downgrade to 4.2.4-12.1. I did that and it worked!

Ah, looks like we got a bugzilla entry https://bugzilla.opensuse.org/show_bug.cgi?id=976110.

Looks like samba related. (Which was also among the updates installed on 2016-04-15). The linked redhat bugtracker carries very detailed information about it and it appears to have already been fixed over there…

Ouch, you have been faster. Trying to downgrade as well.

Downgrad to 4.2.4-12.1 (Leap) did the trick for me as well.

Caution though: PacakgeKit instantly came up with security updates regarding samba and it installs the -15.1 again.

Good thing: Verified downgrading works - twice :slight_smile:

Hi All
Please have a look at comment #9 in https://bugzilla.opensuse.org/show_bug.cgi?id=976110#c9 and test the packages in the repo indicated and provide some feedback :wink:

As @malcolmlewis said, please help test the packages. I just did and it apparently seems to work. I’d be happier if more then one tested these. Please leave feedback in the bugzilla.