Evolution default browser

Hi all,

If I could find a way to search I would have. :frowning:

New OpenSUSE forum user, OLD SUSE user - I bought SuSE 6.x to get the ADABAS database.

For many years I believed that any release after 7.3 was a step backwards. In fact I’m so old I can remember when dirt was clean. :wink:

My problem is I was forced to upgrade from OpenSUSE 10.3 to 11.2 on short notice.

Now I have a HUGE irritation - I worked around the problems and they were challenging, but not a constant itch under my skin, as this is.

The irritation is that I am running KDE 4.3.x with Evolution 2.28.0, and I can find no way to change the default browser from Epiphany to Firefox.

I have used the magic of Google without any relief from the itch.

Can anybody help - I’m sure it’s easy, but it eludes me.

Cheers
Richard

Ah, you can’t be that old–I remember when the Dead Sea wasn’t even sick.:\

During my 11.2 install a Firefox icon was automatically installed on the desktop folder. I suspect that such should be the norm, but you never know with Linux. :wink: Even if that didn’t happen, after accessing Firefox in the regular menu, right click on Firefox and select either Add to Favorites, Add to Desktop, or Add to Panel–depending on where you want the shortcut to appear. I hope that is somewhere in the ballpark of what you were seeking.

I dunno, I can remember when General motors was still a private. :wink:

I don’t have a problem with running Firefox, I have a problem clicking on a link in email, and it tries to open the link with Epiphany, which I don’t have installed.

How do I tell Evolution to stop being silly?

Another thing with Evo that’s causing me vast irritation is when I delete an email and press Ctl-E to expunge, it very often tells me there’s an error while expunging.

The only way I can get round that one is to close Evo totally and then run “find .evolution/ -name “*index” -delete” and try again.

Very disturbing release, this one. Although at last when running Evo under KDE, the box asking for passwords actually gets the focus instead of being orphaned.

Welcome to the forums. I’m old too…:wink:

Try this:

Systemsettings, Default Applications. Change the mail program from Epiphany to whatever you want.

Question:
Did you reuse your homedir over and over again? You might be suffering from old settings. A clean /home/USERNAME/.kde4 can often improve or even solve matters.

Thanks,

I really don’t seem to be making myself clear.

I am using Evolution as my email agent. It’s semi-satisfactory (but let’s not get into that).

When I click on a web URL in an email message, it tries to open the link - unfortunately it tries to open it with Epiphany which is the Gnome default browser, instead of Firefox. I do have Firefox installed, I don’t have Epiphany installed and probably never will.

Changing email agents is not an option - I transferred my mail to Kmail over the weekend, and Kmail decided to abend all over the place.

Hope this helps.
Richard

OK - I figured this out ('cause I needed it too):

  • Close Evolution
  • With YAST, install gconf-editor
  • From a Terminal, run: gconf-editor
  • Navigate to desktop/gnome/url-handlers/http
  • For “Command”, enter without quotes: ‘firefox %s’
  • Repeat this for desktop/gnome/url-handlers/https

Fire Evolution back up and Firefox now opens for links

Man that was too easy. :wink:

Thank you very much for that - it’s been a constant irritation.

I suppose I better start a new thread for my Evolution Expunge problem.

Thanks again
Richard

Thank you for sharing!

/Kevin

Thank you as well! I just upgraded from openSUSE 10.1 straight to 11.2 and was just piecing my user experience back again…

Thanks for posting the fix - very helpful