Evolution crashes everytime in Gnome

Hi all,

I am new to Linux, but with a bit of interest, common sense and a bit of research, I am now comfortable using Linux for basic needs. I have installed and tried some extra software from the repos etc. I am using the Gnome version of Opensuse 11, installed from a DVD.

The problem I am facing now is that after configuring 2 Gmail accounts and 1 Microsoft exchange server accounts (from University) using Evolution, I can read all the mails fine and I can also delete emails, but when I have to send an email using any account, the program crashes. I have to forcequit the program. This happens everytime.

Any thoughts on what might be happening?

Since I am new to Linux, if you need more information, or if you want me to get something from the console, you might have to be very specific as to exactly what I need to type in there. Sorry folks, I still haven’t learnt that yet.

Thanks in advance for your help.

PS: I have all animations and effects OFF. I have a single Firefox window and a single Pidgin chat window open. Monitoring the resources, it is using 66% of my 1Gb RAM. Is this normal??

Hi nanosri & welcome,

Just a few thoughts for you;

Which account is set as default and how have you set the sending SMTP server? Are they different for every account or all filled in with the same sending server? Is authentication enabled for the sending SMTP server (often not needed)?

Also when you enter the outbox in Evolution (or drag a mail item into it and back out), does Evolution crash as well?

Also try changing the account that’s set as default, close and open Evolution, and retry sending a mail with the account that is now set as default.

These steps might point you to what is happening.


Thank you WJ. One of the Gmail accounts is set as default. I configured them all separately with different SMTP I think. I went to Edit and went into Preferences and then added the accounts separately.

If I have send mail from any account, it crashes. In anycase, I will try out the other things you suggested later today and will post back. Now I am working on my thesis using XP dualboot.

Thank you.

I have tried changing the default and also tried sending the email from another account, but nothing is working. Within a few seconds the application freezes. Have to close it using Forcequit. Many a times as soon as I start typing into the “TO” field, even before I write any message, the whole application freezes and becomes grayed out, so that you have to close Evolution and start it again.

Do you think if I remove Evolution and completely, restart the system and install it again it might work? I am asking this coming from a Windows environment. I dont know if it will work for Linux systems!!!

Any help would be appreciated. Thank you.

Maybe try to run it from some terminal (ex. gnome-terminal). This give sometimes helpfull error messages.

Good tip meksykaniec,

You don’t have to reinstall Evolution just yet…
There are two folders you can rename to see if the problems are related to your user setup. Ifso, the problem is probably in 1)

  1. /home/<username>/.gconf/apps/evolution
    (contains application settings and mail accounts that you have setup)

  2. /home/<username>/.evolution
    (contains the mail itself, attachments & calendar/task items)

These are normally hidden directories and when you rename these logout and login again to make the changes effective (GNOME hooks into the mail configuration as soon as you login - thats why the logout/in is needed)

Thank you for all the support. But, how exactly do I unhide those directories? Is there an option in properties? Or do I have to type something in the terminal? How does it work?

Thanks in advance.

No prob & welcome :wink:

In Nautilus you can enter <CTRL>+<H> to show hidden files.

If you want this as permanent option you can find this setting under Edit > Preferences > tick the 'Show hidden and backup files ’

You should see the mentioned directories with either setting…


Thanks again for the reply.

I think I was playing around with some trackpad options (I am on a laptop) and now on that user mouse does not move. I can see the mouse, but it wont move. Using the keyboard I went into Yast and opened Mouse settings and checked that Trackpad was ON and everything seems to be fine.

If I login as root, not starting the system with the default user, then the mouse works fine. So, now I have created a new user where I can use the mouse. I saw the settings on both the users and saw that they were both the same. Now why would the trackpad not work in one user and work in another? Is there anyway to check if something is wrong from the terminal?

Please let me know. Coz, without this, I cannot test the other things suggested above.

Thank you for your help.

This is a known problem after having used the touchpad applet in control center.
As a quickfix delete the xml file found in /home/<username>/desktop/gnome/periphals/touchpad and logout/login. The touchpad movment should be ok again.

See this thread for some more info : Touchpad troubles on Dell Latitude D520 and OpenSuse 11.0 - openSUSE Forums

If you have a USB mouse you could use that to navigate when this happens.

Do you have all openSUSE updates applied? There was an update available to fix this.


I had this problem a lot with SP2 for SLED. I was able to correct the problem by clearing out the Exchange specific cache.

From the terminal:
rm -rf/.evolution/exchange~/.evolution/mail/exchange
evolution --force-shutdown

Then launch evolution again.

Coming back after a short absence. I successfully submitted my thesis yesterday, so I have a few days to play around with openSUSE.
Thank you Magic31 for the mouse problem. But I didnt find the directories you showed when I was trying couple of days ago. Yesterday, while I was travelling on the train, I began to go through each and every directory inside my username. So that is when I found that in the folder path that you have given, there is a directory you have missed out.

So, incase anybody else is having the same problem, I just would like to correct that path. You can find the XML file in:

I deleted that file and logged out and logged back in and everything was fine. Thank you for that fix.

Now I am going to try the evolution stuff. Dear D8TA, will tryout your suggestion and well and post back.

Thanks everyone.

@ D8TA,

Just tried what you suggested. Evolution still crashes. I am surprised that if I have to leave it at just receiving mail, it works fine. No problems at all. As soon as I open the compose message and type something in the TO: field, after sometime, Evolution just grays out and I cannot do anything but use forceshutdown.

Hello all,

I have just tried what Magic31 suggested about renaming the folder. After I renamed the folder within gconf, I had to reconfigure all the mails from the start.

I have now configured all my gmail accounts and everything is absolutely fine. I can SEND and RECEIVE mail.

Therefore, I think the problem was with the exchange account. What I think I am going to do now, is to rename the new one and put back the old one and in that I will remove the exchange account and see what happens.

Will post back.

Hello again,

Latest observations: I tried to rename the new evolution folder in apps and renamed the old one back to evolution. Now, I cant find the Microsoft exchange account on it. Now I didnt understand where it has disappeared.

Anybody have any suggestions. But its ok. I will need the Microsoft exchange for only 2 more months and not anymore. So even if I cant configure exchange its OK.

If anyone have any ideas, please let me know.
Thank you.