Evolution Broken

I attempted to restore from a backup and go the following erro.

Type EPluginMono registered from the mono-plugin-loader
*** nss-shared-helper: Shared database disabled (set NSS_USE_SHARED_DB to enable).
*** nss-shared-helper: Shared database disabled (set NSS_USE_SHARED_DB to enable).

(evolution:5511): camel-WARNING **: camel_exception_get_id called with NULL parameter.

(evolution:5511): camel-WARNING **: Cannot load summary file: ‘/home/abdrahim/.evolution/mail/local/Inbox.ev-summary’: No such file or directory

GLib-ERROR **: gmem.c:136: failed to allocate 8319072456 bytes
aborting…
Aborted

Anyone kno how to fix this?// I tried to reinstall evolution. The problem is still there.

The clue is in the error

/home/abdrahim/.evolution/mail/local/Inbox.ev-summary’: No such file or directory

If you still have the backup
I suggest deleting /.evolution

Start evolution again to create the new .evolution folder
then create your accounts as they were before

Once done there, copy the mailbox contents of the backup into the new mailboxe/s
and so on

Thanks. I will try that and let you know how it works out.

Tried copy ing in the address book but it said it could not openit , even though the correct permissions were applied. Maybe this back up is corrupt. It did the same thing on Ubuntu 8.1.

Unlikely, but possible.

Try mozilla Thunderbird. Just to see if you can get anywhere with that. You can delete it later.

I switched to Thunderbird aswell. Evolution didn’t download the mail anymore and also the creation of a new account failed.

med my evolution folder evolution old. Then I extracted the Evolution backup file., and copied the evolution folder into the home directory. Changed the permissions and opened Evolution. Created a new accout and voila - all my emails wer there.No contacts though. so I save the contact from anothe computer and i,ported them into Evolution. All is now well.

Thanks everyone.:):):slight_smile: