Ethernet interface with no IP stopped working

I have a secondary Ethernet interface which I use to sniff my WAN traffic. It doesn’t have an IP address assigned. It was working fine under 11.1, but no longer works after upgrading to 12.1 – Wireshark doesn’t capture any packets from it… I haven’t made any hardware or software configuration changes to the interface. I can see the activity LED blinking constantly on the switch port to which it’s connected, so I know it’s seeing traffic.

ifconfig shows this:

eth1      Link encap:Ethernet  HWaddr 00:1E:C2:FB:C2:1D  
          inet6 addr: fe80::21e:c2ff:fefb:c21d/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:37 errors:0 dropped:0 overruns:0 frame:0
          TX packets:7 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:3539 (3.4 Kb)  TX bytes:606 (606.0 b)

The RX bytes/TX bytes values never change after booting. Here is ifcfg-eth1:

BOOTPROTO='static'
BROADCAST=''
ETHTOOL_OPTIONS=''
MTU=''
NAME='Apple USB Ethernet Adapter'
NETMASK=''
NETWORK=''
REMOTE_IPADDR=''
STARTMODE='auto'
USERCONTROL='no'
IPADDR=''
PREFIXLEN='32'
ONBOOT='yes'
ARP='no'

This is unchanged from 11.1. Syslog shows this at boot time:

Dec 31 01:13:18 jwt ifup:     eth1      name: Apple USB Ethernet Adapter
Dec 31 01:13:18 jwt kernel:     7.301267] asix 1-3:1.0: eth1: link up, 100Mbps, full-duplex, lpa 0xC1E1
Dec 31 01:13:18 jwt kernel:     7.523966] asix 1-3:1.0: eth1: link up, 100Mbps, full-duplex, lpa 0xC1E1
Dec 31 01:13:20 jwt avahi-daemon[1078]: Registering new address record for fe80::21e:c2ff:fefb:c21d on eth1.*.

Does anyone have a suggestion on how to make this interface receive traffic?

If you’re using systemd and samba (nmb more precisely), see the description, bug report and workaround here: http://forums.opensuse.org/forums/english/get-technical-help-here/install-boot-login/469461-bug-nmb-systemd-more-than-1-ethernet-card.html. You can apply the patch I posted in the thread or apply this change: Access Denied suggested in the bug report.

  • or you can boot in Sytem V. The bug only affects systemd.

** Did you really upgrade from 11.1 to 12.1? That doesn’t sound right.

My apologies; my post wasn’t clear. My eth1 intentionally doesn’t have an IP address because it’s only used in promiscuous mode for sniffing WAN traffic. The problem is that it’s not working in promiscuous mode.

** Did you really upgrade from 11.1 to 12.1? That doesn’t sound right.

Yes, I really did (with Evergreen being used on 11.1). The upgrade went pretty smoothly.

Oh, I see. Can you not set the -promisc option with ifconfig on that interface?
Otherwise I don’t know.

That did the trick! Thank you so much.

I’ve added LINK_OPTIONS=‘promisc on’ to ifcfg-eth1, and this shows PROMISC when looking at ifconfig. But eth1 doesn’t actually receive any packets unless I unplug and replug the adapter (it’s USB). Doing an ifdown/ifup doesn’t cause it to receive packets, only unplugging/replugging. Any ideas what this could be?