Ethernet connection not coming up

I used this computer for more than 6 years with openSUSE/KDE now and always had an ethernet connection at home. Additional I used the WiFI connection when somewhere else. But now something strange happens. I can get internet through Wifi but no longer through ethernet. With Network Manager (my default setting) it looks like this:

linux-tl1r:~ # systemctl status network.service● NetworkManager.service - Network Manager
   Loaded: loaded (/usr/lib/systemd/system/NetworkManager.service; enabled; vendor preset: disabled)
  Drop-In: /usr/lib/systemd/system/NetworkManager.service.d
           └─NetworkManager-ovs.conf
   Active: active (running) since Tue 2019-01-01 19:08:05 NZDT; 6s ago
     Docs: man:NetworkManager(8)
 Main PID: 11410 (NetworkManager)
    Tasks: 4 (limit: 4915)
   CGroup: /system.slice/NetworkManager.service
           └─11410 /usr/sbin/NetworkManager --no-daemon


Jan 01 19:08:05 linux-tl1r.site NetworkManager[11410]: <info>  [1546322885.7980] manager: (eth0): new Ethernet device (/org/freedesktop/NetworkManager/Devices/2)
Jan 01 19:08:05 linux-tl1r.site NetworkManager[11410]: <info>  [1546322885.7995] device (eth0): state change: unmanaged -> unavailable (reason 'managed', sys-iface-state: 'external')
Jan 01 19:08:05 linux-tl1r.site NetworkManager[11410]: <info>  [1546322885.8008] wifi-nl80211: (wlan1): using nl80211 for WiFi device control
Jan 01 19:08:05 linux-tl1r.site NetworkManager[11410]: <info>  [1546322885.8010] device (wlan1): driver supports Access Point (AP) mode
Jan 01 19:08:05 linux-tl1r.site NetworkManager[11410]: <info>  [1546322885.8022] manager: (wlan1): new 802.11 WiFi device (/org/freedesktop/NetworkManager/Devices/3)
Jan 01 19:08:05 linux-tl1r.site NetworkManager[11410]: <info>  [1546322885.8031] device (wlan1): state change: unmanaged -> unavailable (reason 'managed', sys-iface-state: 'external')
Jan 01 19:08:05 linux-tl1r.site NetworkManager[11410]: <info>  [1546322885.8039] device (wlan1): set-hw-addr: set MAC address to EA:A6:74:AE:A4:1E (scanning)
Jan 01 19:08:05 linux-tl1r.site NetworkManager[11410]: <info>  [1546322885.8079] ovsdb: Could not connect: No such file or directory
Jan 01 19:08:05 linux-tl1r.site NetworkManager[11410]: <info>  [1546322885.8311] supplicant: wpa_supplicant running
Jan 01 19:08:11 linux-tl1r.site NetworkManager[11410]: <info>  [1546322891.8071] manager: startup complete
linux-tl1r:~ # ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN group default qlen 1000
    link/ether 48:5b:39:76:80:2d brd ff:ff:ff:ff:ff:ff
3: wlan1: <BROADCAST,MULTICAST> mtu 1500 qdisc noqueue state DOWN group default qlen 1000
    link/ether ea:a6:74:ae:a4:1e brd ff:ff:ff:ff:ff:ff
linux-tl1r:~ #

I tried wicked and there it looks like that:

linux-tl1r:~ # systemctl status network.service● wicked.service - wicked managed network interfaces
   Loaded: loaded (/usr/lib/systemd/system/wicked.service; enabled; vendor preset: disabled)
   Active: active (exited) since Tue 2019-01-01 19:05:42 NZDT; 20s ago
  Process: 10646 ExecStop=/usr/sbin/wicked --systemd ifdown all (code=exited, status=0/SUCCESS)
  Process: 10622 ExecReload=/usr/sbin/wicked --systemd ifreload all (code=exited, status=0/SUCCESS)
  Process: 10815 ExecStart=/usr/sbin/wicked --systemd ifup all (code=exited, status=0/SUCCESS)
 Main PID: 10815 (code=exited, status=0/SUCCESS)


Jan 01 19:05:12 linux-tl1r.site systemd[1]: Starting wicked managed network interfaces...
Jan 01 19:05:42 linux-tl1r.site wicked[10815]: lo              up
Jan 01 19:05:42 linux-tl1r.site wicked[10815]: eth0            setup-in-progress
Jan 01 19:05:42 linux-tl1r.site wicked[10815]: wlan0           no-device
Jan 01 19:05:42 linux-tl1r.site systemd[1]: Started wicked managed network interfaces.
linux-tl1r:~ # ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN group default qlen 1000
    link/ether 48:5b:39:76:80:2d brd ff:ff:ff:ff:ff:ff
3: wlan1: <BROADCAST,MULTICAST> mtu 1500 qdisc noqueue state DOWN group default qlen 1000
    link/ether 1c:4b:d6:d2:ed:fd brd ff:ff:ff:ff:ff:ff
linux-tl1r:~ #

So I don’t seem to get an IP address. So I switched back to wireless. But what can be the problem - DHCP? Previously as soon as it was plugged in it worked.
Any help is appreciated.
Cheers
Uli

Hardware details please…

/sbin/lspci -nnk | grep -iA3 net

Your eth0 interface is reported as down.

Open a terminal and do

dmesg -w

Connect the ethernet cable and observe/capture the output.

Thank you, deano-ferrari here is the output of the commands:

/sbin/lspci -nnk | grep -iA3 net02:00.0 Network controller [0280]: Qualcomm Atheros AR9285 Wireless Network Adapter (PCI-Express) [168c:002b] (rev 01)
        Subsystem: AzureWave AW-NE785 / AW-NE785H 802.11bgn Wireless Full or Half-size Mini PCIe Card [1a3b:1089]
        Kernel driver in use: ath9k
        Kernel modules: ath9k
--
04:00.5 Ethernet controller [0200]: JMicron Technology Corp. JMC250 PCI Express Gigabit Ethernet Controller [197b:0250] (rev 03)
        Subsystem: ASUSTeK Computer Inc. Device [1043:1905]
        Kernel driver in use: jme
        Kernel modules: jme

and I received quite a lengthy output from dmesg -w here is the part relating to the interfaces:

   49.015087] ip_tables: (C) 2000-2006 Netfilter Core Team   49.336674] ip6_tables: (C) 2000-2006 Netfilter Core Team
   49.645570] Ebtables v2.0 registered
   50.550000] nf_conntrack version 0.5.0 (16384 buckets, 65536 max)
   51.494113] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
   51.494333] jme 0000:04:00.5 eth0: Link is down
   51.520595] jme 0000:04:00.5 eth0: Link is down
   51.520599] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
   51.524160] IPv6: ADDRCONF(NETDEV_UP): wlan1: link is not ready
   51.539528] IPv6: ADDRCONF(NETDEV_UP): wlan1: link is not ready
   51.561887] IPv6: ADDRCONF(NETDEV_UP): wlan1: link is not ready
   52.459423] NET: Registered protocol family 17
   52.506282] IPv6: ADDRCONF(NETDEV_UP): wlan1: link is not ready
   52.588945] bridge: filtering via arp/ip/ip6tables is no longer available by default. Update your scripts to load br_netfilter if you need this.
   53.173896] Netfilter messages via NETLINK v0.30.
   53.215649] ip_set: protocol 6
   69.825517] jme 0000:04:00.5 eth0: Link is up at ANed: 10 Mbps, Half-Duplex, MDI-X
   69.825874] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
   70.038134] jme 0000:04:00.5 eth0: Link is down
   70.909401] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
  265.826140] jme 0000:04:00.5 eth0: Link is up at ANed: 10 Mbps, Half-Duplex, MDI-X
  265.826510] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
  267.954861] jme 0000:04:00.5 eth0: Link is down
  312.722643] jme 0000:04:00.5 eth0: Link is up at ANed: 10 Mbps, Half-Duplex, MDI-X
  313.126764] jme 0000:04:00.5 eth0: Link is down
  397.042381] IPv6: ADDRCONF(NETDEV_UP): wlan1: link is not ready
  402.366125] jme 0000:04:00.5 eth0: Link is up at ANed: 10 Mbps, Half-Duplex, MDI-X
  403.260367] jme 0000:04:00.5 eth0: Link is down
  514.029006] jme 0000:04:00.5 eth0: Link is up at ANed: 10 Mbps, Half-Duplex, MDI-X
  514.512436] jme 0000:04:00.5 eth0: Link is down
  559.248387] jme 0000:04:00.5 eth0: Link is up at ANed: 10 Mbps, Half-Duplex, MDI-X
  559.516252] jme 0000:04:00.5 eth0: Link is down
  585.209943] jme 0000:04:00.5 eth0: Link is up at ANed: 10 Mbps, Half-Duplex, MDI-X
  585.391547] jme 0000:04:00.5 eth0: Link is down
  603.436532] jme 0000:04:00.5 eth0: Link is up at ANed: 10 Mbps, Half-Duplex, MDI-X
  604.771121] jme 0000:04:00.5 eth0: Link is down
  652.854758] IPv6: ADDRCONF(NETDEV_UP): wlan1: link is not ready
  653.967936] wlan1: authenticate with 00:e0:20:1d:7f:d3
  653.985802] wlan1: send auth to 00:e0:20:1d:7f:d3 (try 1/3)
  653.987377] wlan1: authenticated
  653.989958] wlan1: associate with 00:e0:20:1d:7f:d3 (try 1/3)
  653.993936] wlan1: RX AssocResp from 00:e0:20:1d:7f:d3 (capab=0x411 status=0 aid=4)
  653.994091] wlan1: associated
  653.994142] IPv6: ADDRCONF(NETDEV_CHANGE): wlan1: link becomes ready
  653.998331] ath: EEPROM regdomain: 0x8348
  653.998333] ath: EEPROM indicates we should expect a country code
  653.998335] ath: doing EEPROM country->regdmn map search
  653.998335] ath: country maps to regdmn code: 0x3a
  653.998336] ath: Country alpha2 being used: US
  653.998337] ath: Regpair used: 0x3a
  653.998338] ath: regdomain 0x8348 dynamically updated by country IE
  661.759488] jme 0000:04:00.5 eth0: Link is up at ANed: 10 Mbps, Half-Duplex, MDI-X
  663.049455] jme 0000:04:00.5 eth0: Link is down
  678.919074] jme 0000:04:00.5 eth0: Link is up at ANed: 10 Mbps, Half-Duplex, MDI-X
  679.352109] jme 0000:04:00.5 eth0: Link is down
  704.349245] jme 0000:04:00.5 eth0: Link is up at ANed: 10 Mbps, Half-Duplex, MDI-X
  704.499349] jme 0000:04:00.5 eth0: Link is down
  712.989274] jme 0000:04:00.5 eth0: Link is up at ANed: 10 Mbps, Half-Duplex, MDI-X
  713.139108] jme 0000:04:00.5 eth0: Link is down
  866.497368] jme 0000:04:00.5 eth0: Link is up at ANed: 10 Mbps, Half-Duplex, MDI-X
  866.804092] jme 0000:04:00.5 eth0: Link is down
  875.389096] jme 0000:04:00.5 eth0: Link is up at ANed: 10 Mbps, Half-Duplex, MDI-X
  876.388894] jme 0000:04:00.5 eth0: Link is down

Does it works when booting wirh an older Kernel?

The ethernet port is clearly flapping. Does this happen regardless of whether your laptop connected to AC power or not? A quick search online turned up this old bug report describing similar hardware and symptoms. Unfortunately, it wasn’t investigated further. Also, check your cable and ethernet ports for problems. Failing that, a new bug report may be required.

You could try forcing the negotiation manually. For example if connecting to a router with 100Mbps port try

sudo ethtool -s eth0 speed 100 duplex full

then see if you can get connected. With NM start the desired connection, or if using wicked try

sudo ifdown eth0 && sudo ifup eth0

Thank you for your replies, Sauerland and deano_ferrari.
First, deano_ferrari I tried these old commands ifup, etc but they don’t work any more with Network Manager and systemD and I am not yet very familiar with all the options there…

**linux-tl1r:~ #** ethtool -s eth0 speed 100 duplex full      
**linux-tl1r:~ #** ifdown eth0 && sudo ifup eth0
<13>Jan  2 11:23:58 uli: Network is managed by 'NetworkManager.service' -> skipping

I took my Tumbleweed laptop which is connected to another ethernet port (and ethernet is working there) and plugged it in instead of the old LEAP laptop and there ethernet does not come up either. So it is not the DHCP server and it looks as if it is the connection. I will investigate later with a cable tester. Will send more information of the investigation later. Thanks again
Uli

The second command was only if using wicked (as I already explained). If using NM just try reconnecting via the NM GUI.

I took my Tumbleweed laptop which is connected to another ethernet port (and ethernet is working there) and plugged it in instead of the old LEAP laptop and there ethernet does not come up either. So it is not the DHCP server and it looks as if it is the connection. I will investigate later with a cable tester. Will send more information of the investigation later. Thanks again
Uli

No, it’s definitely not a DHCP issue, but an issue with ethernet negotiation (and perhaps a regression with the driver).

OK - I tested the patch cable upstairs, the cabling in the wall and finally the patch cable from the switch to the wall socket and this cable has 2 wires not connecting through. Strangely enough this is one of the few bought cables - most of the patch cables are home made and these are all working. Anyway now the connection is up straight away again. I have another question, however. When I open up the dialog box “Edit your network connections” in the right tab “General Configuration” I have set the priority to 3. On my home WiFi connection I have put the priority to -3. The idea is that even I have the wireless configuration turned on it will not connect to the same network as the connection with the higher priority. Is this how it works? It seems to be working now since my wireless is not connected now, only the cable.

 ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host  
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether 48:5b:39:76:80:2d brd ff:ff:ff:ff:ff:ff
    inet 192.168.2.26/24 brd 192.168.2.255 scope global noprefixroute dynamic eth0
       valid_lft 863986sec preferred_lft 863986sec
    inet6 2406:e001:ed04:de01:xxxxxxxxxxx/64 scope global temporary dynamic  
       valid_lft 7182sec preferred_lft 3582sec
    inet6 2406:e001:ed04:de01:xxxxxxxxxxx/64 scope global mngtmpaddr noprefixroute dynamic  
       valid_lft 7182sec preferred_lft 3582sec
    inet6 fe80::xxxxxxxxx/64 scope link noprefixroute  
       valid_lft forever preferred_lft forever
3: wlan1: <BROADCAST,MULTICAST> mtu 1500 qdisc noqueue state DOWN group default qlen 1000
    link/ether 72:92:53:80:b2:ec brd ff:ff:ff:ff:ff:ff

Glad to read that it was just a cable fault. Good result. :slight_smile:

I don’t use the NM connection priority feature. It is generally used to order competing connection profiles for a given network interface. Since the wireless network connection is using a different interface it won’t stop connectivity as such. You could alter the wireless connection profile so that it doesn’t connect automatically if desired. However, NM is designed to prefer wired ethernet over wireless connections anyway, and that is governed by the route metrics assigned.

Examine the routing table when both connections are active

ip route

and you’ll see what I mean.

Just for the benefit of the readers here is what deano_ferrari meant with the different route metrics:

ip route
default via 192.168.2.1 dev eth0 proto dhcp metric 100 
default via 192.168.2.1 dev wlan1 proto dhcp metric 600 
192.168.2.0/24 dev eth0 proto kernel scope link src 192.168.2.26 metric 100 
192.168.2.0/24 dev wlan1 proto kernel scope link src 192.168.2.33 metric 600