ethernet connection giving "Network is unreachable" error in

I’m working with a fresh install of SuSE 10.3 on a Dell Inspiron 6400 laptop. I’m having some trouble connecting to the internet via the ethernet card. The network setup passed during installation and I was able to download a few package updates. The cable is plugged in and I can actually get an IP address. I checked the DHCP client table on the router and the machine is there, so I don’t think that’s the problem. However, even with an IP address, I keep getting an error that reads “connect: Network is unreachable” every time I try to ping.

I’ve found a couple of other posts online dealing with similar problems, but nothing I’ve tried thus far has solved the problem. I have set up the network card (detected as eth1) to start up automatically via ifup rather than use networkmanager. I have disabled ipV6. My guess is that it has something to do with the Firewall settings, but I’m not sure how to proceed on that. Right now the network cards are all set to “External Zone” and the settings on the firewall match up. Any suggestions on what I’m doing wrong here?


Have you tried disabling the firewall before pinging to confirm that it is due to firewall settings?

Thanks for the reply. It turned out to be a problem with my default gateway settings. Once I fixed that, everything worked fine.

Please note that if you have tried everything to get “connect: Network is unreachable” make sure you go basic and as stated above - set DEFAULT GATEWAY.

Don’t feel bad. If I had a dollar for every time I’ve forgotten to change the default gateway, I’d be a VERY wealthy man …

DHCP has its flaws, but not having to remember to do that default gateway stuff when I’m moving a machine between subnets sure is nice! :slight_smile: