eth0 unconfigured after update to 11.2

I tried to update my fully-working 64-bit 11.1 system to 11.2. I used the network install and chose the Update option. It took a few hours so I didn’t sit through the entire installation but when I returned the 11.2 login screen was displayed. Having logged in, however, I found that I couldn’t access the network.

The boot log showed that network had failed to start. “ifconfig” lists only the “lo” interface. “ifstatus eth0” returns “Interface eth0 is not available”

Network Settings in YaST lists 2 entries in the Overview tab. The first entry has Name: “NetXtreme BCM5755 Gigabit Ethernet PCI Express” and IP Address: “Not configured”. The detail pane for this entry shows “NetXtreme BCM5755 Gigabit Ethernet PCI Express (Not connected) BusID:0000:3f00.0 Unable to configure the network card because the kernel device (eth0, wlan0) is not present. This is mostly caused by missing firmware (for wlan devices). See dmesg output for details”. The Edit and Delete buttons are both disabled for this entry.

The second entry has exactly the same name as the first with the IP Address listed as “DHCP4”. I assume this was the entry that was carried over from the 11.1 system. The detail pane for this entry shows “NetXtreme BCM5755 Gigabit Ethernet PCI Express (No hwinfo) Device Name: eth0. Started automatically at boot. IP address assigned using DHCP4”. The Edit and Delete buttons are both enabled for this entry.

lspci reports “3f:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5755 Gigabit Ethernet PCI Express (rev 02)”

lsmod lists only “edd”, “loop”, “sr_mod”, “sg”, “cdrom” and “dm_mod”.

The files in /etc/sysconfig/network/ are “if-down.d/”, “if-up.d/”, “providers/”, “scripts/”, “config”, “dhcp”, “ifcfg-eth0”, “ifcfg-lo”, “ifcfg.template”, “ifroute-lo”, “routes” and “routes.YaST2save”.

The contents of ifcfg-eth0 are:
BOOTPROTO=‘dhcp4’
STARTMODE=‘onboot’
NAME=‘NetXtreme BCM5755 Gigabit Ethernet PCI Express’

I tried re-booting from the 11.2 Network Install boot CD and choosing the Repair option. That downloaded 3 more packages to fulfil the minimum system requirement and removed all but 2 entries from the list of boot options but didn’t address the networking issue.

I’ve googled for similar problems and the few results I’ve found all suggest the file “/etc/network/interfaces” as a starting point but neither that file nor that directory exists on my system.

Can anyone suggest where I go from here, please?

Did you try removing every entry in Yast and try re-adding them?

I can’t remove the unconfigured entry because the Delete button is disabled when that is selected. Is there a way to remove the entries from outside Yast?

I had the same problem after upgrading from 11.1 to 11.2 - neither eth0 nor wlan0 were available, as well as the sound.

Looking at the installed packages related to the kernel I noticed that the kernel-default package was not installed, only kernal-default-base and kernel-desktop.

So I ran the upgrade again and selected the kernel-default package and after that the network and sound worked fine.

Thank you very much - that did the trick! (I hadn’t even started to worry about the non-working sound but it fixed that too)

I always recommend not to upgrade but to install by keeping /home partition intact. This looks like another issue when upgrading.

I had the same problem with my ASRock MCP51 ethernet controller :frowning:

No interfaces after the installation
I launchef YaST and it created two incorrect interfaces (eth0 and eth1)
One had good parameters but no driver and the other the good driver but bad parameters

I had to delete the two interfaces and re-create one manually with the good parameters and driver (forcedeth)… now it works :slight_smile:

Need Help :
I Installed suse 11.1 in my desktop
but not able to configure the network

ifconfig not found

eth0 and wlan0 is missing

please help me , how to configure the network

Thank you! Have been fighting this half the day!
I was getting eth0 and ntfs not found!

And it is still a problem 6 months later!