erros installing GRUB


First time experimenting with opensuse or any linux based OS before… I am having a little trouble getting it to install right.

I burnt the ISO and it installed fine. I had the GUI running but then when I restarted the computer it would not boot opensuse. I think the bootloader is not getting installed correctly.

Here is whats happening:
When I try to boot, it goes through the BIOS and then Displays:

Grub Loading stage 2…
(hd2,1)/boot/message: file not found

So then an option comes up select which OS to boot, either “SUSE LINUX” or “Failsafe – SUSE LINUX”

at the bottom it displays, “the highlighted entry will be booted automatically in X seconds.” When it does attempt to boot the highlighted entry the system reboots and it does this over and over again.

SO if I boot from the DVD, and select the option Boot from Disk, I get the screen:
Booting from local disk…
isolinux: Disk error 80, AX = 0201, drive 80

Boot failed: press a key to retry…

So that brings me to where I am now, trying to get the boot loader settings correct in the Repair Installed System option. I am thinking I have a drive setting wrong where its refering to the wrong drive to find stage 2 of the bootloader, but since im such a total newb I really don’t know what Im talking about.:wink:

So every time I run the Repair tool, I get the error message:

Boot Loader Error Detected
The configuration of the boot loader contains errors. Press repair to generate a new config. automatically

If i click help, it says:

**A default GRUB installation needs three configuration files:


The following files are not valid:


This generally means your system is not bootable.

Creating a new boot loader cofiguration is recommended.

So I click repair and it takes me to the Boot Loader Settings screen and thats where I get a bit lost. I have tried screwing with the settings here but Im not too sure what Im doing.

If anyone has some suggestions for me that would be awesome.

I am not trying to dual boot here or anything, just installing linux on a clean hard drive.

Thanks for your help

Do the repair mode again and tell it to install GRUB to the mbr.

yes I have done that. I have made sure all other boxes were un selected and only master boot record was checked. It went through the process and then again said “Boot loader error detected”

If the system has multiple drives, maybe try this… If you can get to a root shell on the DVD, you can type

fdisk -l

which will give you a list of all the partitions visible to the system. Work out which one is SUSE’s root partition (or boot partition, if you made one), then run

mkdir /mnt/suse
mount /dev/sdXY /mnt/suse
cd /mnt/suse/boot/grub
cp device.bak

Substituting XY for the right partition. You will now be in the editor vi, looking at Vi is confusing, but fortunately the file is simple. What you probably need to do is press ‘i’ for insert, and try to swap the lines around, so the one that was labeled (hd0) says (hd1) and vice versa. Obviously this is more complicated if you have lots of drives, but it shouldn’t take forever. I doubt the order they appear in is relevant, but it’s probably safer to keep them in the same order (as in hd0, hd1, hd2…), swapping round the other parts.

Once you’re done, hit escape, then type a colon, then type ‘wq’ at the prompt. That should save and quit. Type reboot (or if that doesn’t work, try ‘exit’, and reboot from the menu), try to load the system again, rinse and repeat.

okay I will try that, I have only one drive so it shouldnt be too difficult. I think I can get to a shell from the DVD in the rescue system option. Ill let you know what happens

Hmm… If you only have one drive, I suspect there will only be one line in it.

Have a look - no harm checking.

If that doesn’t help, perhaps try

find /boot/grub/stage1

That should give you a list of locations where a grub stage1 file is found - normally root or boot partitions. There should only be one, hopefully. Say it’s (hd0,0), then run

root (hd0,0)
setup (hd0)

So for the ‘root’ part put exactly what it reported for the find command, for the setup command just put the first digit.

I’m struggling to see what’s wrong, or how this will help… But there’s no harm trying, is there? :wink:

okay ran the fdisk -l and it came back with three partitions:

/dev/sda1 linux swap / solaris
/dev/sda2 linux
/dev/sda3 linux

it has sda2 with an asterisk for the boot partition.

ill try and run the next part to find the stage 1 and report back

okay, ran that part and it came back with (hd0,1) so I entered those values like you said to. It went through those three checks and then running “embed /boot/grub/e2fs_stage1_5 (hd0”… 17 sectors are embedded. succeeded
running “install /boot/grub/stage1 (hd0) (hd0)1+17 p (hd0,1)/boot/grub/stage2 /boot/grub/menu.lst” … succeeded.

Restarted the system without the DVD in and got the same error message again:
(hd2,1)/boot/message/: file not found

Ok, try mounting the suse root partition as suggested before,

mkdir /mnt/suse
mount /dev/sdXY /mnt/suse
cd /mnt/suse/boot/grub
cp menu.lst menu.bak
vi menu.lst

Then going through this file, and changing all occurrences of (hd2,1) to (hd0,1).

If you’ve changed the, restore it from the backup…

cp device.bak

That might help… Also, tell us what the says


This is quite curious!

Okay I am currently trying to change those values, you are right, this editor is quite tricky. I messed up the strings in there and couldnt figure out how to change them back. So im rebooting and trying again here. How do you save it once its changed?

:q! is quit without saving

:wq is save and quit.

If you need to recover from the backup you made, do ‘cp menu.bak menu.lst’

Okay! got all the instances of (hd2,1) changed to (hd0,1). There were three of them.

I ran cat and got this:

(hd2) /dev/disk/by-id/ata-ST3250623A_4ND4YKRK

Restarted and booted up right into opensuse! Looks like that was it. Thank you so much. I would have never got that, and was on the brink of just scrapping the whole idea!

Hmm… I’d love to say I understood fully what that was all about. But I don’t. Some of this can be a bit trial and error.

Glad it works any way! Have fun with SUSE… :slight_smile:

You got that right, well thanks again! (already posting from my suse computer!):wink:

One other bit of advice - install nano. There’s nothing wrong with vi, once you get the hang of it, but it’s much nicer to be able to worry about what you’re trying to correct when something goes wrong, rather than wrestling with the editor - and nano is pretty much as easy to use as you can get.

Ah thanks for the tip, I will do that. :slight_smile: