Errors when installating oS 13.1 on Mavericks Macbook with Fusion 6


When I try to install openSuse 13.1 64 bit from the .iso file, I keep getting the same errors - first it runs through normally, when it’s at „Preparing system for automatic configuration“ the first submenu („Probe hardware“) is checked. At the 2nd entry there, „Retrieve & read control file“, I get the following error: “Calling the YaST Module 'Inst_autoinit has failed. More information can be found near the end of the ‘var/log/YaST2/y2log’ file.”
Of course, this log file is saved on some linux partition - which I think I cannot enter, since Linux installation hasn’t finished yet?
Anyway, if I click “Next”, it seems to run through normally for 2-3 seconds, but then produces the next error (under „Partitioning“): „Nothing assigned as root file system!
Installation will most certainly fail fatally!“.
I can proceed all the same (click Install), but after 45% the installation hangs… Doesn’t proceed anymore, waited for 15 minutes but no luck.

I tried the following:

  • installing on HFS+ partition (on a 32GB SDHC card, volume formatted as HFS+), or on an Ext3 partition (on the same card) - no difference.
  • Tried with all default options in VMware (for openSuse, this is recognized normally by VMware) - also tried customizing, like raising Ram amount, 2 CPU cores etc.
  • At the point, where one gets the 2nd error, I clicked the „Change“ drop down menu, tried to adapt the partitioning settings - but no volume / partition is found.
  • Searched the forum here (not for hours, and I’m a newbie so it’s possible I missed something).

System is the latest Mac OS, updated; Fusion 6 also updated; MBP i7 / 2,3 Ghz / 16GB ram / Radeon HD 6750M … And as said trying to install on SDHC card - I installed various VMware OS-ses on SDHC cards in the past, never had any issues.

Thanks in advance for tips :slight_smile:

Ok I filed a ticket at VMware, got a reply which fortunately resolved the issue - it only works, when you install manually, as described here:
VMware KB: Creating a custom virtual machine in Fusion

Key thing is at point 10, to choose the .iso file with the installer and define this as “Superdrive”; then it works… :slight_smile: