Error with nvidia 1 click-install drivers

hi guys,i’m having problems with my graphic card.i installed opensuse DVD yesterday and after the update i used the 1 click-install to install the nvidia drivers,but after i restarted the graphical interface doesn’t boot.i have this issue since release of opensuse 13.1 and i’m using windows only because of it.the 12.3 version runs fine.

sorry my bad english,i’m brazillian

here are my hardware:

openSUSE 13.1 x64
Intel Pentium 4 640 3.2ghz
Xfx Nvidia Geforce GT 630 1GB
3GB RAM

Try to boot to “Recovery Mode” (“Advanced Options” in the boot menu), then post the following information please:

  • /var/log/Xorg.0.log.old (upload to a sharing/pasting site like http://susepaste.org/ or similar)
  • which nvidia/kernel packages do you actually have installed:
rpm -qa | egrep "(kernel|nvidia)"

i tried to run in recovery mode but gnome says that had an error and need to log out.

Then log in to something else than GNOME. GNOME has quite heavy requirements on the graphics stack as it unconditionally uses OpenGL.
You should be able to choose a different session at the login screen (click on the wrench). Maybe “GNOME failsafe” (or whatever it’s called) would work, if not choose “IceWM”.

Then post the information I requested. For the Xorg.0.log.old to contain useful info, you have to do a normal boot first, then reboot to recovery mode.

so i installed openbox and when i tried to run ,i got it:

fail to open environment variable screen DISPLAY (it was in portuguese so…)

How did you tried to run it?
In text mode? That doesn’t work, it needs an X session to run, like any other window manager.

So can’t you login to IceWM?

Don’t you even get to a login screen maybe? Not even in Recovery Mode?

In that case, try to set DISPLAYMANAGER=“xdm” in /etc/sysconfig/displaymanager.
And set a different DEFAULT_WM in /etc/sysconfig/windowmanager. (as I said, “icewm” should be installed by default)

I have no idea what’s happening on your system, so please describe it.

Even better (if you can do that), copy the file /var/log/Xorg.0.log in text mode (when the graphical system fails to start) to somewhere else where you can access it, and post it.

well, it’s taking me a time that i don’t wanna lost and i think i will wait the new release of opensuse in november, or another linux distribution.i’m with a fresh install again and i will stay with it.sorry guys if i make you lost your time.

Fair enough.

But the nvidia driver should just work.
Most likely that 1-click install just installed the wrong packages (for the kernel modules especially).

And your recovery mode problem comes from the fact that you are using GNOME.
GNOME3 absolutely needs OpenGL to function.
In recovery mode this would be provided by Mesa’s software renderer, as only a generic graphics driver is used.
But the installation of the nvidia driver totally breaks Mesa, as it replaces system libraries (libglx and libGL) with its own incompatible versions.

Any other window manager/desktop environment should work though (in recovery mode that is).

After fixing the nvidia driver installation, GNOME should work, too.