error with joining flv files in avidemux

Hi guys,

I’m trying to join flv files with avidemux app. But after joining, the audio and the video is different, it not play right.

Anyway, is there any perfect way for joining flv files?


I’m using OpenSUSE 12.2, KDE 4.9

what version of avidemux are you using?
There have been some great improvements with audio sync in avidemux3 (2.6).

Many do not like the flv format.

Inside the flv wrapper can be different bit rates, different codecs (I believe) and different frame rates. If those aspects don’t match then a simple joining is unlikely to work, and re-encoding is likely necessary (IMHO).

If you have KDE running with kdenlive installed, you likely could use kdenlive to join the two files (as it will re-encode both to same bitrate, framerate, codecs and resolutions). But I would not say its a perfect way as I believe there is no perfect way.

can you supply me the good repo for avidemux3? i’m using avidemux 2.5.6

As suggested before can check video and audio rates of both files(flvs).
If they are different then you can convert them to a single format and then join both ?

I installed kdenlive. But when I add flv clip to the project, it said: Clip is invalid, will be removed from project.

Any solution?

If the clip is invalid … ie if the clip is corrupted … it could say that. Is the clip corrupted ?

no it’s not corrupted. i still can play it normally

What version of kdelive are you using ? It suggests to me you have a version unable to handle nominal codecs. Are you using the packman packaged version ? For example I have installed (on my openSUSE-12.1 system: kdenlive-0.9.2-6.2.x86_64 ).

[QUOTE=n00bvn;2524avidemux 047]can you supply me the good repo for avidemux3? i’m using avidemux 2.5.6

avidemux3 has yet to make it into packman. You can get a copy to try out from Malcolm Lewis’s repo. Check this thread

but - remember that flv is a container - avidemux will make no difference if the files you are trying to join are not identical in codec and bitrate for audio and video.

I’ve OpenSUSE 12.2, KDE4.9 and kdenlive 0.9.4, installed from YaST, but still cannot add flv clips to project.

Please, can you help me here ? How I am I supposed to deduce which packager’s kdenlive version you are using with that quote ?

YaST is a tool. Stating you have a version 0.9.4 of kdenlive installed from YaST does not state where the rpm came from. Did it come from an openSUSE OSS repository ? from an openSUSE update repository ? From a Packman packager respository ?

The openSUSE-12.2 OSS repository has: kdenlive-0.9.2-2.1.2.x86_64.rpm

The openSUSE-12.2 OSS update repository has:
kdenlive-0.9.2-2.4.2.x86_64.rpm (from 05-Sep-2012)
kdenlive-0.9.2-2.8.1.x86_64.rpm (from 12 Dec-2012)

The Packman packager packaged version of kdenlive for openSUSE-12.2 is kdenlive-0.9.4-2.1.x86_64.rpm

If one does a search for kdenlive one will get something like this:](

  • (click on the above to enlargen it)*
    (note one will not see the packman packager packaged version in the above).

I can see from the above that there are other places where it can come from, such as the KDE : Distro : Factory, or the KDE : Release : 49 … all of which can be installed from YaST if YaST has the repository setup. I notice you have KDE-4.9 which suggests you could have the KDE-4.9 version of kdenlive (which is likely broken for codecs - and could explain your problem).

I am assuming you understand the concept of there being different packagers in the openSUSE project and hence there can be different versions of a package with different functionalities dependant on how the packager built the package ? (apologies if I am telling you something you already know - its my intent to help here … )

How about instead, typing :

rpm -qi kdenlive | grep Packager

and provide here the output ?

That should tell us the Packager of your kdenlive version.

If you have a version ‘other’ than the Packman packager version, its quite possible that non-Packman packaged version does not have the necessary codecs. In such a case, you may need to re-encode the flv files first to a common format, using a package such as handbrake, being certain to use the same settings for each video you reencode. Then after reencoding each one individually, only then try to combine them.

when i run “rpm -qi kdenlive | grep packager”, it showed me nothing. so i tried “rpm -qi kdenlive”, and i got this:

Name        : kdenliveVersion     : 0.9.4
Release     : 31.1
Architecture: i586
Install Date: Sun Feb  3 00:34:39 2013
Group       : Productivity/Multimedia/Video/Editors and Convertors
Size        : 18826872
License     : GPL-3.0+
Signature   : DSA/SHA1, Wed Jan 30 20:31:24 2013, Key ID 27c070176f88bb2f
Source RPM  : kdenlive-0.9.4-31.1.src.rpm
Build Date  : Wed Jan 30 20:28:56 2013
Build Host  : build40
Relocations : (not relocatable)
Vendor      : obs://
URL         :
Summary     : Non-linear video editor
Description :
Kdenlive is a non-linear video editor for GNU/Linux and FreeBSD, which supports
DV, AVCHD (experimental support) and HDV editing. Kdenlive relies on several
other open source projects, such as FFmpeg and the MLT video framework. It was
designed to answer all needs, from basic video editing to semi-professional
Distribution: KDE:Release:49 / openSUSE_12.2

as oldcpu suggested - it appears you have kdenlive from the KDE 4.9 repo and this is “likely broken for codecs”

Try switching to the packman packaged version and see if that gets you anywhere.

OMG i really have problem here.

first, i re-installed kdenlive from PackMan :: Package details for kdenlive
second, i downloaded video from youtube in 2 files: 1 flv and 1 mp4 (download thru

and when i tried to Add Clip to project, it said “Clip is invalid…” for both files >:(

do i have to install any lib or something for kdenlive?

PS: i can play both files in both kaffein, smplayer and vlc player

Can we try mp4 from keepvid and try ?

When you installed the Packman kdenlive version, it should have picked up all the necessary codecs. I assume (hope) you did not force the install of anything.

Did you try re-encoding first, with an app such as handbrake ?

Also, if you don’t mind terminal/command line apps, then ‘h264enc’ or ‘xvidenc’ scripts walk one through a re-encoding of a video to a format that kdenlive can nominally handle easily.

Also, if you can point us to a sample of the flv/mp4 files that are giving you a problem, we can test them to determine if the problem is with your setup, or if it is with the video files encoding.

i installed both h264enc and xvidenc but still not work.

below are sample videos.

Xperia™ Z - Exmor RS™ for mobile, the world’s first image sensor with HDR video for smartphones - YouTube

then i download thru KeepVid: Download and save any video from Youtube, Dailymotion, Metacafe, iFilm and more!. 1 flv and 1 mp4 (both 480p)

thanks for your helps!

ok. i think i found out something is missing with my kdenlive somehow. when i run config wizard, i saw that 1 module is not installed. below is image that i got:](

so how can i fix this?

Those import fine with my kdenlive on my 64-bit openSUSE-12.1 with KDE. I have installed:

oldcpu@corei7:~> rpm -q kdenlive melt mlt

which are all from the Packman packager repository.

If you launch kdenlive from a terminal (konsole), setup your kde project settings for the appropriate bit rate and resolution, and then drag one of the videos into kdenlive, when it fails for it, you may see an error message in the konsole providing a hint as to where the kdenlive (on your PC) configuration problem may be.