Error with install - does this video card work with OpenSUSE

Ubuntu and Kubunut both work with this card (using restricted driver method):

Diamond Radeon X1550 Pro / 512MB GDDR2 / AGP 8x / DL DVI / VGA / HDTV / Video Card

But every time I try to install OpenSUSE 11 (from liveCD and DVD) - I get errors (Radeon not supported…)

So is this card going to work, or do I have to forgo OpenSUSE?

I do not see why it would not work with the proprietary fglrx driver.

What problems are you having, exactly?

The install drops to a bash prompt, and so I never get the GUI for installation. I “login”, and try startx, but the screen flashes and I get “no screens found” (and such.) I’ve tried*** sax2 -r -a -m 0=fglrx*** and other methods I’ve found on the net, but nothing works.

Lastly, I’ve tried nano /etc/x11/xorgconfig but I get “command not found”.


did you become root to do that stuff


su -
sax2 -r -m 0=vesa

Then startx.

This will us the VESA driver and should get you moving forward.

I get a login prompt, which I type root, then I do that sax… line. I have not tried su - sax…

I’ll try that. Do I keep that " - " after su?

wOOt!!! It works! I’m in the livecd now. I’ll install and let you all know how it goes from here.

What I did was:
sudo sax2 -r -m 0=vesa

Good stuff - “unfortunately” the system tries to use the radeon driver but apparently it fails for this particular card.

Luckily there’s always VESA to fall back to.

Ha ha…

I still am not running OpenSUSE 11. I even purchased both the Live CD and the DVD of it, hoping that would “help” with my installation.

I still get to the command prompt, and no GUI :’(

i am think better place for you is FAQ

[Published]Howto: ATI Radeon Driver - openSUSE Forums](

i have installed drivers for xpress 1100 but have some problems with it… you could have some problems with wine and compiz