Error while installing nvidia gfxG02 driver

Hello
I have a problem wih installing a driver for GeeForce 6200 video card. I have built a package based on X11:Drivers:Video/nvidia-gfxG02 plus a patch for kernel 5,x. This autor of the patch tested it with several kernels up to 5,4,x.
The build is sussesfull, I get the binary package, but when I install it I get the following message:


make -f /usr/src/linux-3.10.18-lp152.106/scripts/Makefile.modpost
sed ‘s/ko$/o’ /usr/src/linux-5.3.18-default/modules.order | scripts//mod/modpost -m -a -i ./Modulesymvers -I /usr/src/kernel-modules/nvidia-304.137-default/Module.symvers -o /usr/src/kernel-modules/nvidia-304.137-default/Module.symvers -s -T -
FATAL: parse error in symbol dump file

NVIDIA: left KBUILD.
nvidia.ko failed to build!

and no kernel module is created.

How to fix this?

Kernel in Leap 15.2 is a backported kernel 5.6.

nvidia-g02 is out of support, use nouveau.

Leap 15.2 will be supported until Jan/Feb 2022…

So use Leap 15.3 with nouveau driver.

https://en.opensuse.org/Lifetime

openSUSE Leap 15.2 reach its end of life on Dec. 31, 2021.

Where did you find this? Provide info if you need help.

Worked before: Install NVIDIA [550.40.07 / 545.29.06 / 535.154.05 / 525.147.05 / 470.223.02 / 390.157 / 340.108] Drivers on Debian / Ubuntu / Linux Mint / LMDE :: If Not True Then False

Easier way is in using Radeon GPU.

Once more:
That does not help and is not true!!

So please do not advice it every time.

A new Nvidia Card is also working as a new ATI Card.

The card wkazubski is using is an old card, my first card using with linux was a newer card Nvidia GS7600 in 2007 and it is also not supported by Nvidia anymore (G02).
What cards has ATI at the same time?
Think of fglrx at that time and what has ATI/AMD done with the fglrx driver?
I know the 2 people who has build it for openSUSE.

@ wkazubski:
The Leap 15.2 is an kernel 5.6, so you need patches up to Kernel 5.6.

But Leap 15.2 is only supported for a few weeks ( I do not find the post where an openSUSE maintainer has said, that Leap 15.2 definitely end at Jan or Febr 2022, but if 4 weeks or 8 weeks…)

And in Leap 15.3 is an Kernel 5.9 working, problems also with G03 driver, some have the G03 driver working, some not.
But G02 is not working anymore in Leap 15.3.

Use the nouveau driver or use a new graphics card, but if your PC is also as old as your card…

The Nvidia G02 repository:
https://build.opensuse.org/package/show/X11:Drivers:Video/nvidia-gfxG02/

Patch for kernels 5.x:
http://blog.schmorp.de/2019-08-03-nvidia-legacy-304-patch-for-post-50-linux-kernels.html/
http://blog.schmorp.de/data/nvidia/nvidia-legacy-304xx-304.137-linux5.patch/

Patch worked without problems with kernels up to 5.0.13 for Tumbleweed. Since I have some older computers with GF 6200 or 7300 GPU’s i tried to build the driver for Leap 15.x. For 15.2 it almost succeded (crash at rpm install) so I expected a simple solution. But I see that it is not so simple.
For current Leap 15.3 I have more problems, the package does not build at all.