error while installing grub

hi, i have windows xp and ubuntu 7.10 installed in my system. i was attempting to install opensuse 11 (gnome version). in the window ‘Finishing Basic Installation’, the steps (1)copy file to basic systems and (2)save configuration are successful but in step (3)install boot manager YaST2 gives the error:
‘Error occurred while installing grub’

grub>setup --stage2=/boot/grub/stage2 (hd0)(hd0,4)
Error 17: Cannot mount selected partition

whata to do??

Perhaps you could provide us your HDD partitioning layout, disk sizes, any other info…

Are you using the DVD ?

Did you shutdown the system before booting from the disc ?

Sometimes GRUB fails to install if the system had been rebooted from Windows.

You may shutdown the system and switch it on again booting with the DVD to reinstall GRUB.

i have 2 HDDs, but am using only one for all the OS. i have allocated a 20gb space for opensuse root partition and am planning to use swap common to ubuntu and opensuse. i chose the option ‘create partition setup’.
yes i am using the DVD.
I did not shutdown the system before booting from disk, but i restarted from ubuntu.
i don’t know if it is connected, but my HDD had bad sectors near (i guess) boot sector. they are now repaired, but while booting from ubuntu i still get the message ‘there are differences between boot sector and its backup’ though the guys at ubuntu forum seem not to be too concerned about the message.

What partition is Suse’s root installed on? Like sdax, what is the numeral x?
If you don’t know look in Ubuntu with this comnmand for inspiration:

sudo /sbin/fdisk -l

If you can’t interpret it post the results back here from in Ubuntu together with your estimate of which partition is Suse’s root partition.

What I’m getting at is the possibility of installing a bootloader to Suse from within Ubuntu or booting to Suse and repairing the bootloader of Suse from within Suse.

the partition for suse is /dev/sda5 and swap is /dev/sda7(swap common to both suse and ubuntu).
i have 2 HDDs. i wish to install all OS in one hdd. since grub was not getting installed i tried installing suse in my 2nd hdd while keeeping the 1st hdd as the bootable one. in this attempt the grub got properly installed but when i again tried to install suse in 1st hdd, the same error came ie ‘error while installing grub’. i used option ‘create partition setup’, but while installing in 1st hdd i did not get the option if selecting a separate space for /home. i just allocated 20gb for / .
i’ll shortly post the results of sudo /sbin/fdisk -l in ubuntu.
appreciate if i do not have to post results very often as i do not have a netconnection where i am installing suse ( i have to go a mile away to avail net facilities).

Have a go at installing grub in Suse from Ubuntu: boot to the Ubu Grub screen and press escape. Go to the text screen as suggested and press c for command line. Enter this command: grub, then this command : find /boot/grub/stage1

If you get a list that includes this item: (hd0,4) then the Suse installation went far enough to install Grub in Suse. But did it go far enough to analyse the hard drive and put the Grub config file menu.lst in place? To discover that enter this command next: find /boot/grub/menu.lst.

If it did you will once again get (hd0,4) in the list. Then boot from the Suse Grub by doing this:

root (hda0,4)
kernel /boot/vmlinuz
initrd /boot/initrd

When if you get into Suse, repair the bootloader in Yast, using “Step 2 - Reinitialise and Reinstall Grug” inthis Tutorial"
GRUB Boot Multiboot openSUSE Windows (2000, XP, Vista) using the Grub bootloader.

If you don’t get that far, give us a blow by blow description of where you got to.

the grub loading problem is solved though i do not know how. i booted ubuntu and formatted all the partitions where opensuse 11 was installed (i had to install it twice in two different locations in two different hdds. there was no trouble for the grub pointing to the open suse installation in the hdd where i didn’t want suse to be installed). then the grub got lost. i managed to retrieve ubuntu’s grub and then again tried to install suse, and it worked!! no grub error! wonder how…